Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] OS radeon driver glamor no vsync
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
gorg86
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2011
Posts: 123

PostPosted: Wed Apr 22, 2015 6:48 pm    Post subject: [SOLVED] OS radeon driver glamor no vsync Reply with quote

Hello fellow gentoo users,

I recently transitioned my desktop system from the proprietary radeon drivers to the OS drivers.
I am happy with the results especially with the 2D performance and video playback but I
can´t activate vsync and that is quite annoying. I use the "radeon" driver and glamor with 2 screens and a southern islands graphics card.
The only application that is not affected by tearing is the VLC media player.
Any suggestions how to activate vsync?

thanks in advance

edit:
Using compton with the following settings solved the problem:
Code:
backend = "glx"
vsync = "opengl-mswc"
swi-opti = true
paint-on-overlay = true


The important parameter is 'backend = "glx"' the others are just for performance tuning.
I also changed the Preemtion Model in the kernel config to "Preemptible Kernel (Low-Latency Desktop)".

Fortunately compton does not interfere with any kind of video playback even in Firefox and Chromium.
It doesn´t matter what output module I use, even opengl output modules do not interfere with compton there is no stuttering.
I really don´t understand how that works, because I use 3 screens with different refresh rates and there is no stuttering/flickering or tearing on any of them.

There is one problem though, compton causes a little bit of stuttering in all other opengl applications I tested.
It is not a big deal, all windows machines and every linux desktop that uses a compositor have that problem and most people won´t even notice that
but I find that annoying.
I just turn off compton when I use other opengl applications and turn it back on afterwards, I can live with that.

I think that problem is X server related and not fixable. I guess I have to wait for wayland to get that fixed :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum