Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia-drivers and kernel-4.0.0
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6101
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jun 24, 2015 9:30 pm    Post subject: Reply with quote

Great !

Just wanted to ask whether it works with 4.1.0 :mrgreen:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1309

PostPosted: Thu Jun 25, 2015 4:38 am    Post subject: Reply with quote

For me it seems I'll hold off on updating to the new kernel for a little while longer. I don't feel like having to deal with maintaining those extra patches, when the only thing the new kernel brings to my system, is my i2c chipset finally being supported. Considering I am running a desktop that I don't shutdown, hwmon/acpi isn't much of a concern.
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 436
Location: USA

PostPosted: Tue Jun 30, 2015 9:19 pm    Post subject: Reply with quote

gienah wrote:
In case there are problems with copy/pasting the patch, I have tar'd up the patches that I use on my system running kernel 4.0.4-hardened-r1 with x11-drivers/nvidia-drivers-340.76 here:

I can confirm these patches work with nvidia-drivers-340.76 and kernel-4.1.0-gentoo-r1.

Many thanks.
Back to top
View user's profile Send private message
triffid_hunter
n00b
n00b


Joined: 31 Aug 2013
Posts: 2

PostPosted: Fri Jul 03, 2015 7:42 am    Post subject: Reply with quote

Hi, with gienah's patch I get further, but I'm running into the following:

Code:
/var/tmp/portage/x11-drivers/nvidia-drivers-340.76/work/kernel/nv_uvm_interface.o:(.bss+0x10): multiple definition of `__no_const'
/var/tmp/portage/x11-drivers/nvidia-drivers-340.76/work/kernel/nv.o:(.bss+0x700): first defined here


I have tried nvidia-drivers-340.76 with gentoo-sources-4.0.5, gentoo-sources-4.1.0 and gentoo-sources-4.1.1-r1 all with the same result.

Google brings up literally nothing about this error.

It seems to be a struct defined at kernel/nv_uvm_interface.h lines 377-382.

Perhaps this is supposed to be a preprocessor macro, but it's not defined anywhere?

I could not find it in gentoo-sources-3.17.2 either.

I added
Code:
--- a/kernel/nv_uvm_interface.h 2015-07-03 17:20:22.000000000 +1000
+++ b/kernel/nv_uvm_interface.h 2015-07-03 17:31:52.344707158 +1000
@@ -379,7 +379,7 @@
     uvmEventStartDevice_t startDevice;
     uvmEventStopDevice_t  stopDevice;
     uvmEventIsrTopHalf_t  isrTopHalf;
-} __no_const;
+};
 
 //
 // Called by the UVM driver to register operations with RM
to the end of gienah's patch, and it compiles successfully.

I am using gcc-4.8.5, platform is amd64.

I will report back when I've actually tested the driver.
Back to top
View user's profile Send private message
gienah
Developer
Developer


Joined: 24 Nov 2010
Posts: 196
Location: AU

PostPosted: Sat Jul 04, 2015 12:08 pm    Post subject: Reply with quote

Quote:
Hi, with gienah's patch I get further, but I'm running into the following:
Code:
/var/tmp/portage/x11-drivers/nvidia-drivers-340.76/work/kernel/nv_uvm_interface.o:(.bss+0x10): multiple definition of `__no_const'
/var/tmp/portage/x11-drivers/nvidia-drivers-340.76/work/kernel/nv.o:(.bss+0x700): first defined here

I have tried nvidia-drivers-340.76 with gentoo-sources-4.0.5, gentoo-sources-4.1.0 and gentoo-sources-4.1.1-r1 all with the same result.

If you are not running sys-kernel/hardened-sources, then since as you report it causes problems with non-hardened kernels,
it is best to delete the pax patch:
Code:
rm /etc/portage/patches/x11-drivers/nvidia-drivers-340.76/nvidia-drivers-331.49-pax-uvm.patch
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 524
Location: US

PostPosted: Sun Jul 05, 2015 2:32 am    Post subject: Reply with quote

Just wondering: is there a status page somewhere on the Gentoo infrastructure (preferred) or at nvidia where they show which kernels are supported by nvidia-drivers-340.xx? I'm not interested in applying special patches at this time and currently am just masking with:

Code:

>x11-drivers/nvidia-drivers-340.9999
>sys-kernel/gentoo-sources-3.19.9999


It would be nice to have somewhere to check every once in a while to see if I can upgrade the kernel without issues. Though an option the trial and error approach wastes a lot of time.

edit: In thinking I guess I would only need to text out major releases as presumably things would remain the same. And then only retest once a nvidia-drivers compatible point release is made. I guess the changelog might have the info. Still a status page somewhere might be nice. :)
Back to top
View user's profile Send private message
Meet Joe Black
n00b
n00b


Joined: 19 Mar 2005
Posts: 34

PostPosted: Tue Jul 14, 2015 1:43 am    Post subject: Reply with quote

This is not only 4.0 kernel related, I have the same compile error with 3.18.18. 3.18.16 worked just fine before (nvidia-drivers-304.125 there).

Code:
/var/tmp/portage/x11-drivers/nvidia-drivers-304.125/work/kernel/nv-pat.c: In function ‘nv_disable_caches’:
/var/tmp/portage/x11-drivers/nvidia-drivers-304.125/work/kernel/nv-pat.c:38:5: error: implicit declaration of function ‘read_cr4’ [-Werror=implicit-function-declaration]
     *cr4 = read_cr4();
     ^
/var/tmp/portage/x11-drivers/nvidia-drivers-304.125/work/kernel/nv-pat.c:39:5: error: implicit declaration of function ‘write_cr4’ [-Werror=implicit-function-declaration]
     if (*cr4 & 0x80) write_cr4(*cr4 & ~0x80);
     ^
cc1: some warnings being treated as errors
/usr/src/linux-3.18.18-gentoo/scripts/Makefile.build:257: recipe for target '/var/tmp/portage/x11-drivers/nvidia-drivers-304.125/work/kernel/nv-pat.o' failed


P.S. I can confirm successful compilation of nvidia-drivers-304.125 on 3.18.18 kernel after small change in the above patch (
Code:
KERNEL_VERSION(3, 18, 18)
instead of
Code:
KERNEL_VERSION(3, 20, 0)
). Thank you guys.
_________________
Some strange sentences ? Grammar mistakes ?
I'll be happy if you write a short PM, I always try to improve my English.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3758
Location: Austro Bavaria

PostPosted: Tue Aug 18, 2015 5:33 pm    Post subject: Reply with quote

NEwest gentoo-sources for longterm supported kernel.org branch does not compile anymore...

Code:
qlist -Iv gentoo-sources;qlist -Iv nvidia-drivers
sys-kernel/gentoo-sources-3.18.19
x11-drivers/nvidia-drivers-340.76


gentoo-sources, 3.18.16 does, details see here:

https://bugs.gentoo.org/show_bug.cgi?id=558028

kernel org claims only security fixes but they did something to the gpu code, else it would not break for these small revision.

off-topic: so please support 3.18 longterm branch
I want to stay on the longterm supported branch 3.18. i consider 4.x.x kernels as alpha, untested!
I had lots of hassles with 3.0, 3.2, and so on in the past,
2.6.32 was kinda stable branch, I wont bother with any alpha early kernel releases until they tested everything out ...
Back to top
View user's profile Send private message
Meet Joe Black
n00b
n00b


Joined: 19 Mar 2005
Posts: 34

PostPosted: Tue Aug 18, 2015 7:04 pm    Post subject: Reply with quote

sys-kernel/gentoo-sources-3.18.19 has successfully compiled for me with x11-drivers/nvidia-drivers-304.125 (GeFoce 7 series here). It works but I have some problems with games or video with big frames. mpv -vo x11 workaround works instead of mpv -vo xv in this cases. It can be tested using glxgears. When you resize window FPS are starting to drop at some size of window from 85 FPS to 10-20 FPS and smaller. Maybe I forgot to restart system after recompile of nvidia-drivers, IDK, but it looks bad when some videos started to lag on usual 720p or 1080p in youtube as well as games are unplayable.
_________________
Some strange sentences ? Grammar mistakes ?
I'll be happy if you write a short PM, I always try to improve my English.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3758
Location: Austro Bavaria

PostPosted: Thu Aug 20, 2015 10:18 am    Post subject: Reply with quote

Quote:
emerge nvidia-drivers
Calculating dependencies... done!

>>> Verifying ebuild manifests
>>> Running pre-merge checks for x11-drivers/nvidia-drivers-340.76
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found sources for kernel version:
* 3.18.19-gentoo_08_17_2015
* Gentoo supports kernels which are supported by NVIDIA
* which are limited to the following kernels:
* <sys-kernel/gentoo-sources-3.18
* <sys-kernel/vanilla-sources-3.18
*
* You are free to utilize epatch_user to provide whatever
* support you feel is appropriate, but will not receive
* support as a result of those changes.
*
* Do not file a bug report about this.
* Checking for suitable kernel configuration options... [ ok ]

>>> Emerging (1 of 1) x11-drivers/nvidia-drivers-340.76::gentoo


Darn, back to the good old days of 2010, when I patched every kernel by hand to get my gpu running. lol (memory bars are cool when they are misalgined and the kernel crashed in 2010...)

When I find the time I will check what the patches are doing and will apply them manually or fix that issue myself. I doubt there are big changes from 3.18.xx to 3.18.yy. Quite annoying that it happens now. I expected that a longterm kernel won t change anything regarding non security things... well kernel devs are lying :P

sadly a few versions back works fine, and gentoo devs made their life easy with We wont support 3.18.

Serious, long term supported kernel is only 3.18.
3.10 is running out in a few months or is already legacy.
4.x is higher and alpha in my eyes.
others are not really an option ...
Back to top
View user's profile Send private message
Meet Joe Black
n00b
n00b


Joined: 19 Mar 2005
Posts: 34

PostPosted: Thu Aug 20, 2015 10:33 am    Post subject: Reply with quote

Does GPU works OK in games and during playing videos (with usual resolutions like 1280x1024 or 1280x720 for my GeForce7) in your case?
_________________
Some strange sentences ? Grammar mistakes ?
I'll be happy if you write a short PM, I always try to improve my English.
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 524
Location: US

PostPosted: Thu Aug 20, 2015 5:59 pm    Post subject: Reply with quote

tw04l124 wrote:

off-topic: so please support 3.18 longterm branch
I want to stay on the longterm supported branch 3.18. i consider 4.x.x kernels as alpha, untested!
I had lots of hassles with 3.0, 3.2, and so on in the past,
2.6.32 was kinda stable branch, I wont bother with any alpha early kernel releases until they tested everything out ...


It probably would be nice if Gentoo supported it but I think we should probably put the blame where it belongs-- with Nvidia. They stop supporting hardware and create these messes for everyone to deal with. It makes for a lot of extra work. Gentoo like most (Actually ALL) distros seems to be in need of more developers. It might be a good discussion on Gentoo Chat or the mailing list on what the policy is and whether it should or can be changed.

I did read in another topic that 4.1 is going to be the new long term supported kernel. So unless Nvidia does something soon this isn't going to get any better.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3758
Location: Austro Bavaria

PostPosted: Thu Aug 20, 2015 6:00 pm    Post subject: Reply with quote

well

uname -a
Linux localhost 3.18.16-gentoo_2015_07_08 #3 SMP PREEMPT Wed Jul 8 17:07:05 CEST 2015 x86_64 Intel(R) Core(TM)2 Duo CPU T9500 @ 2.60GHz GenuineIntel GNU/Linux

qlist -Iv nvidia-drivers
x11-drivers/nvidia-drivers-340.76

I have also a legacy gpu, but i am not sure if its the same range of legacy gpu. I have a 9800m GTS .
I am not sure if your legacy gpu is in the same age or older. there used to be, I call it legacy 1 cards, and I ahve a legacy 2 card. mine went to legacy gpu half a yaer till 1 year ago. you need to check nvidia-homepage whats the latest supported nvidia blob for each card and linux 64 for example. Means nvidia dropped support for my card with their latest releaes in less than a year ago. I think your card belongs to legacy 1 (thats my naming ...)

yes anything works flawless. e.g. urbanterror, unvanquished. alienarena. ...
except newer 3.18.19 or so gentoo sources do not compile the nvidia-drviers anymore ...


edit: the other thread mentiones that 4.1 will be the next long term supported kernel branch. Seems I am forced soon to switch to that, sigh. And this topic covers the patch / or a way to get my needed binary blob for that...
Back to top
View user's profile Send private message
Meet Joe Black
n00b
n00b


Joined: 19 Mar 2005
Posts: 34

PostPosted: Thu Aug 20, 2015 6:57 pm    Post subject: Reply with quote

I have GeForce 7600 GS. The latest drivers are 304.125 (2014.12.5). Also I have the following problem:
Total Dedicated Memory: 512 MB
Used Dedicated Memory: 477 MB (93%)
That's the problem I think with big resolutions. IDK how to figure out wich application consumed all GPU memory resources. Also 3.18.19 compiled for me without any patches. Only 3.18.18 has been needed to patch.
_________________
Some strange sentences ? Grammar mistakes ?
I'll be happy if you write a short PM, I always try to improve my English.
Back to top
View user's profile Send private message
Meet Joe Black
n00b
n00b


Joined: 19 Mar 2005
Posts: 34

PostPosted: Thu Aug 20, 2015 11:15 pm    Post subject: Reply with quote

I found what was my problem with GPU memory exhaustion. I opened too many pdf files in okular in kde. It's better to use some dedicated path with pdfs or links to pdfs inside it. And it looks like I don't have any problems with 3.18.19 now.
_________________
Some strange sentences ? Grammar mistakes ?
I'll be happy if you write a short PM, I always try to improve my English.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3758
Location: Austro Bavaria

PostPosted: Sat Aug 22, 2015 9:30 pm    Post subject: Reply with quote

Thanks. Working.

Summary for 9800m gts card, legacy gpu from nvidia.

Code:
Knight roman # glxinfo |grep Yes
direct rendering: Yes
Knight roman # uname -a
Linux Knight 4.1.6-gentoo_08_22_2015 #1 SMP PREEMPT Sat Aug 22 23:18:22 CEST 2015 x86_64 Intel(R) Core(TM)2 Duo CPU T9500 @ 2.60GHz GenuineIntel GNU/Linux
Knight roman # cat /etc/portage/patches/x11-drivers/nvidia-drivers-340.76/nvidia-drivers-340-76-kernel-4.0.patch
--- a/kernel/nv-pat.c.orig     2015-02-20 02:49:40.000000000 +0100
+++ b/kernel/nv-pat.c  2015-02-25 07:56:40.000000000 +0100
@@ -35,8 +35,13 @@
     unsigned long cr0 = read_cr0();
     write_cr0(((cr0 & (0xdfffffff)) | 0x40000000));
     wbinvd();
+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 20, 0)
     *cr4 = read_cr4();
     if (*cr4 & 0x80) write_cr4(*cr4 & ~0x80);
+#else
+    *cr4 = __read_cr4();
+    if (*cr4 & 0x80) __write_cr4(*cr4 & ~0x80);
+#endif
     __flush_tlb();
 }
 
@@ -46,7 +51,11 @@
     wbinvd();
     __flush_tlb();
     write_cr0((cr0 & 0x9fffffff));
+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 20, 0)
     if (cr4 & 0x80) write_cr4(cr4);
+#else
+    if (cr4 & 0x80) __write_cr4(cr4);
+#endif   
 }

 static int nv_determine_pat_mode(void)


My bug for this nvidia-driver blob: https://bugs.gentoo.org/show_bug.cgi?id=558028
I hope our bug wranglers will apply the patch to the ebuild now and bumb the ebuild revision.
We are running in a security risk in the longterm with kernels below 3.18. long term supported kernels are now 4.1 afaik..
Back to top
View user's profile Send private message
Meet Joe Black
n00b
n00b


Joined: 19 Mar 2005
Posts: 34

PostPosted: Sat Aug 22, 2015 10:07 pm    Post subject: Reply with quote

I can confirm that 3.18.20 works just fine without any patching too on my legacy card (GeForce 7600 GS with nvidia-drivers-304.125).
_________________
Some strange sentences ? Grammar mistakes ?
I'll be happy if you write a short PM, I always try to improve my English.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3758
Location: Austro Bavaria

PostPosted: Sun Sep 06, 2015 9:16 am    Post subject: Reply with quote

http://www.nvidia.com/Download/driverResults.aspx/91217/en-us

A one for all driver now, eh?

Quote:
Version: 340.93
Release Date: 2015.9.2
Operating System: Linux 64-bit
CUDA Toolkit: 6.5
Language: English (US)
File Size: 66.58 MB


Quote:
GeForce 800M Series (Notebooks):
GeForce GTX 880M, GeForce GTX 870M, GeForce GTX 860M, GeForce GTX 850M, GeForce 840M, GeForce 830M, GeForce 820M, GeForce 810M

GeForce 700 Series:
GeForce GTX TITAN Z, GeForce GTX TITAN Black, GeForce GTX TITAN, GeForce GTX 780 Ti, GeForce GTX 780, GeForce GTX 770, GeForce GTX 760, GeForce GTX 760 Ti (OEM), GeForce GTX 750 Ti, GeForce GTX 750, GeForce GTX 745, GeForce GT 740, GeForce GT 730, GeForce GT 720, GeForce GT 710, GeForce GT 705

GeForce 700M Series (Notebooks):
GeForce GTX 780M, GeForce GTX 770M, GeForce GTX 765M, GeForce GTX 760M, GeForce GT 755M, GeForce GT 750M, GeForce GT 745M, GeForce GT 740M, GeForce GT 735M, GeForce GT 730M, GeForce GT 720M, GeForce 710M

GeForce 600 Series:
GeForce GTX 690, GeForce GTX 680, GeForce GTX 670, GeForce GTX 660 Ti, GeForce GTX 660, GeForce GTX 650 Ti BOOST, GeForce GTX 650 Ti, GeForce GTX 650, GeForce GTX 645, GeForce GT 645, GeForce GT 640, GeForce GT 630, GeForce GT 620, GeForce GT 610, GeForce 605

GeForce 600M Series (Notebooks):
GeForce GTX 680MX, GeForce GTX 680M, GeForce GTX 675MX, GeForce GTX 675M, GeForce GTX 670MX, GeForce GTX 670M, GeForce GTX 660M, GeForce GT 650M, GeForce GT 645M, GeForce GT 640M, GeForce GT 640M LE, GeForce GT 635M, GeForce GT 630M, GeForce GT 625M, GeForce GT 620M, GeForce 610M

GeForce 500 Series:
GeForce GTX 590, GeForce GTX 580, GeForce GTX 570, GeForce GTX 560 Ti, GeForce GTX 560 SE, GeForce GTX 560, GeForce GTX 555, GeForce GTX 550 Ti, GeForce GT 545, GeForce GT 530, GeForce GT 520, GeForce 510

GeForce 500M Series (Notebooks):
GeForce GTX 580M, GeForce GTX 570M, GeForce GTX 560M, GeForce GT 555M, GeForce GT 550M, GeForce GT 540M, GeForce GT 525M, GeForce GT 520M

GeForce 400 Series:
GeForce GTX 480, GeForce GTX 470, GeForce GTX 465, GeForce GTX 460 SE v2, GeForce GTX 460 SE, GeForce GTX 460, GeForce GTS 450, GeForce GT 440, GeForce GT 430, GeForce GT 420, GeForce 405

GeForce 400M Series (Notebooks):
GeForce GTX 485M, GeForce GTX 480M, GeForce GTX 470M, GeForce GTX 460M, GeForce GT 445M, GeForce GT 435M, GeForce GT 425M, GeForce GT 420M, GeForce GT 415M, GeForce 410M, GeForce 405M

GeForce 300 Series:
GeForce GT 340, GeForce GT 330, GeForce GT 320, GeForce 315, GeForce 310

GeForce 300M Series (Notebooks):
GeForce GTS 360M, GeForce GTS 350M, GeForce GT 335M, GeForce GT 330M, GeForce GT 325M, GeForce GT 320M, GeForce 320M, GeForce 315M, GeForce 310M, GeForce 305M

GeForce 200 Series:
GeForce GTX 295, GeForce GTX 285, GeForce GTX 280, GeForce GTX 275, GeForce GTX 260, GeForce GTS 250, GeForce GTS 240, GeForce GT 230, GeForce GT 240, GeForce GT 220, GeForce G210, GeForce 210, GeForce 205

GeForce 200M Series (Notebooks):
GeForce GTX 285M, GeForce GTX 280M, GeForce GTX 260M, GeForce GTS 260M, GeForce GTS 250M, GeForce GT 240M, GeForce GT 230M, GeForce GT 220M, GeForce G210M, GeForce G205M

GeForce 100 Series:
GeForce GT 140, GeForce GT 130, GeForce GT 120, GeForce G100

GeForce 100M Series (Notebooks):
GeForce GTS 160M, GeForce GTS 150M, GeForce GT 130M, GeForce GT 120M, GeForce G 110M, GeForce G 105M, GeForce G 103M, GeForce G 102M

GeForce 9 Series:
GeForce 9800 GX2, GeForce 9800 GTX/GTX+, GeForce 9800 GT, GeForce 9600 GT, GeForce 9600 GSO, GeForce 9600 GSO 512, GeForce 9600 GS, GeForce 9500 GT, GeForce 9500 GS, GeForce 9400 GT, GeForce 9400, GeForce 9300 GS, GeForce 9300 GE, GeForce 9300 SE, GeForce 9300, GeForce 9200, GeForce 9100

GeForce 9M Series (Notebooks):
GeForce 9800M GTX, GeForce 9800M GTS, GeForce 9800M GT, GeForce 9800M GS, GeForce 9700M GTS, GeForce 9700M GT, GeForce 9650M GT, GeForce 9650M GS, GeForce 9600M GT, GeForce 9600M GS, GeForce 9500M GS, GeForce 9500M G, GeForce 9400M G, GeForce 9400M, GeForce 9300M GS, GeForce 9300M G, GeForce 9200M GS, GeForce 9100M G

GeForce 8 Series:
GeForce 8800 Ultra, GeForce 8800 GTX, GeForce 8800 GTS 512, GeForce 8800 GTS, GeForce 8800 GT, GeForce 8800 GS, GeForce 8600 GTS, GeForce 8600 GT, GeForce 8600 GS, GeForce 8500 GT, GeForce 8400 GS, GeForce 8400 SE, GeForce 8400, GeForce 8300 GS, GeForce 8300, GeForce 8200, GeForce 8100 /nForce 720a

GeForce 8M Series (Notebooks):
GeForce 8800M GTX, GeForce 8800M GTS, GeForce 8700M GT, GeForce 8600M GT, GeForce 8600M GS, GeForce 8400M GT, GeForce 8400M GS, GeForce 8400M G, GeForce 8200M G, GeForce 8200M

Quadro Series:
Quadro K6000, Quadro K5200, Quadro K5000, Quadro K4000, Quadro K4200, Quadro K2200, Quadro K2000, Quadro K2000D, Quadro K620, Quadro K600, Quadro K420, Quadro 6000, Quadro 5000, Quadro 4000, Quadro 2000, Quadro 2000D, Quadro 600, Quadro 410, Quadro 400

Quadro Series (Notebooks):
Quadro K5100M, Quadro K5000M, Quadro K4100M, Quadro K4000M, Quadro K3100M, Quadro K2100M, Quadro K3000M, Quadro K2000M, Quadro K1100M, Quadro K1000M, Quadro K610M, Quadro K510M, Quadro K500M, Quadro 5010M, Quadro 5000M, Quadro 4000M, Quadro 3000M, Quadro 2000M, Quadro 1000M

Quadro FX Series:
Quadro CX, Quadro FX 370, Quadro FX 370 Low Profile, Quadro FX 380, Quadro FX 380 Low Profile, Quadro FX 570, Quadro FX 580, Quadro FX 1700, Quadro FX 1800, Quadro FX 3700, Quadro FX 3800, Quadro FX 4600, Quadro FX 4700 X2, Quadro FX 4800, Quadro FX 5600, Quadro FX 5800

Quadro FX Series (Notebooks):
Quadro FX 3800M, Quadro FX 3700M, Quadro FX 3600M, Quadro FX 2800M, Quadro FX 2700M, Quadro FX 1800M, Quadro FX 1700M, Quadro FX 1600M, Quadro FX 880M, Quadro FX 770M, Quadro FX 570M, Quadro FX 380M, Quadro FX 370M, Quadro FX 360M

Quadro NVS Series:
Quadro NVS 290, Quadro NVS 295, NVS 510, NVS 315, NVS 310, NVS 300, Quadro NVS 420, Quadro NVS 450

Quadro NVS Series (Notebooks):
NVS 5400M, NVS 5200M, NVS 5100M, NVS 4200M, NVS 3100M, NVS 2100M, Quadro NVS 320M, Quadro NVS 160M, Quadro NVS 150M, Quadro NVS 140M, Quadro NVS 135M, Quadro NVS 130M

Quadro Plex Series:
Quadro Plex Model II, Quadro Plex D Series, Quadro Plex Model IV, Quadro Plex 7000

Quadro Sync Series:
Quadro Sync, Quadro G-Sync II

Quadro SDI:
Quadro SDI

GRID Series:
GRID K2, GRID K520, GRID K1, GRID K340

NVS Series:
Quadro NVS 290, Quadro NVS 295, NVS 510, NVS 315, NVS 310, NVS 300, Quadro NVS 420, Quadro NVS 450

NVS Series (Notebooks):
NVS 5400M, NVS 5200M, NVS 5100M, NVS 4200M, NVS 3100M, NVS 2100M, Quadro NVS 320M, Quadro NVS 160M, Quadro NVS 150M, Quadro NVS 140M, Quadro NVS 135M, Quadro NVS 130M

ION (Desktops):
ION

ION (Notebooks):
ION

ION LE (Desktops):
ION LE

ION LE (Notebooks):
ION LE
Back to top
View user's profile Send private message
tomtom69
Apprentice
Apprentice


Joined: 09 Nov 2010
Posts: 170
Location: Bavaria

PostPosted: Thu Sep 17, 2015 6:20 pm    Post subject: Reply with quote

x11-drivers/nvidia-drivers-304.128 is now stable. It seems to contain all necessary patches for me. It compiles and runs fine without needing patches for latest stable kernel 4.0.5
Back to top
View user's profile Send private message
e3k
Apprentice
Apprentice


Joined: 01 Oct 2007
Posts: 292
Location: Slovakia

PostPosted: Wed Sep 23, 2015 4:12 pm    Post subject: Reply with quote

i got here because i forgot to switch from 3.18 kernel to 4.0.5 (grub). after the update from nvidia-drivers-340.76 to 340.93 X did not start anymore.
but i can confirm that with 4.0.5 kernel the new 340.93 nvidia driver works fine.

Geforce 9600 GT
_________________
--_o_--
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3758
Location: Austro Bavaria

PostPosted: Thu Sep 24, 2015 9:00 am    Post subject: Reply with quote

I highly advise that you read the full topic please! (your card is in the same range / type as mine / from the age and chipset)
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 436
Location: USA

PostPosted: Thu Nov 12, 2015 3:13 am    Post subject: Reply with quote

gienah wrote:
In case there are problems with copy/pasting the patch, I have tar'd up the patches that I use on my system running
kernel 4.0.4-hardened-r1 with x11-drivers/nvidia-drivers-340.76 here:

http://dev.gentoo.org/~gienah/unsupported/etc-portage-patches-x11-drivers-nvidia-drivers-340.76-for-kernel-gt-3.14.tar.gz

I can confirm that these patches work with kernel-4.2.5-gentoo and nvidia-drivers-340.93-r1.

However, under kernel-4.3.0-gentoo I get these errors:
Code:
$ grep -i error: emerge-nvidia-drivers
echo >&2 "  ERROR: Kernel configuration is invalid.";           \
/var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/work/kernel/nv-procfs.c:359:5: error: void value not ignored as it ought to be
/var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/work/kernel/nv-procfs.c:555:5: error: void value not ignored as it ought to be
 * ERROR: x11-drivers/nvidia-drivers-340.93-r1::gentoo failed (compile phase):
 * ERROR: x11-drivers/nvidia-drivers-340.93-r1::gentoo failed (compile phase):

Any debugging hints will be gratefully received.


Last edited by cfgauss on Thu Nov 12, 2015 4:34 am; edited 1 time in total
Back to top
View user's profile Send private message
saellaven
Guru
Guru


Joined: 23 Jul 2006
Posts: 463

PostPosted: Thu Nov 12, 2015 3:16 am    Post subject: Reply with quote

cfgauss wrote:
gienah wrote:
In case there are problems with copy/pasting the patch, I have tar'd up the patches that I use on my system running
kernel 4.0.4-hardened-r1 with x11-drivers/nvidia-drivers-340.76 here:

http://dev.gentoo.org/~gienah/unsupported/etc-portage-patches-x11-drivers-nvidia-drivers-340.76-for-kernel-gt-3.14.tar.gz

I can confirm that these patches work with kernel-4.2.5-gentoo and nvidia-drivers-340.93-r1.

However, under kernel-4.3.0-gentoo I get these errors:
Code:
$ grep -i error emerge-nvidia-drivers|grep -v Werror
echo >&2 "  ERROR: Kernel configuration is invalid.";      \
/var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/work/kernel/nv-procfs.c:359:5: error: void value not ignored as it ought to be
/var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/work/kernel/nv-procfs.c:555:5: error: void value not ignored as it ought to be
make[3]: *** [/var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/work/kernel/nv-procfs.o] Error 1
make[2]: *** [_module_/var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/work/kernel] Error 2
make[1]: *** [sub-make] Error 2
make: *** [nvidia.ko] Error 1
 * ERROR: x11-drivers/nvidia-drivers-340.93-r1::gentoo failed (compile phase):
 * ERROR: x11-drivers/nvidia-drivers-340.93-r1::gentoo failed (compile phase):

Any debugging hints will be gratefully received.


Try the patch I posted in https://forums.gentoo.org/viewtopic-p-7838838.html#7838838
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 436
Location: USA

PostPosted: Thu Nov 12, 2015 4:18 am    Post subject: Reply with quote

saellaven wrote:
Try the patch I posted in https://forums.gentoo.org/viewtopic-p-7838838.html#7838838

I put procfs-linux-4.3.patch into /etc/portage/patches/x11-drivers/nvidia-drivers-340.93-r1 and got a patch error:
Code:
***** procfs-linux-4.3.patch *****
PWD: /var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/work
PATCH TOOL: patch -> /usr/bin/patch
VERSION INFO:
GNU patch 2.7.5
Copyright (C) 2003, 2009-2012 Free Software Foundation, Inc.
Copyright (C) 1988 Larry Wall

License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Larry Wall and Paul Eggert

==================================

PATCH COMMAND:  patch -p0 -g0 -E --no-backup-if-mismatch  < '/etc/portage/patches//x11-drivers/nvidia-drivers-340.93-r1/procfs-linux-4.3.patch'

==================================
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- kernel/nvidia/nv-procfs.c.orig   2015-11-07 20:22:44.937383656 -0500
|+++ kernel/nvidia/nv-procfs.c   2015-11-07 20:24:20.755353556 -0500
--------------------------
No file to patch.  Skipping patch.
2 out of 2 hunks ignored

patch program exited with status 1
==================================

PATCH COMMAND:  patch -p1 -g0 -E --no-backup-if-mismatch  < '/etc/portage/patches//x11-drivers/nvidia-drivers-340.93-r1/procfs-linux-4.3.patch'

==================================
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- kernel/nvidia/nv-procfs.c.orig   2015-11-07 20:22:44.937383656 -0500
|+++ kernel/nvidia/nv-procfs.c   2015-11-07 20:24:20.755353556 -0500
--------------------------
No file to patch.  Skipping patch.
2 out of 2 hunks ignored

patch program exited with status 1
==================================

PATCH COMMAND:  patch -p2 -g0 -E --no-backup-if-mismatch  < '/etc/portage/patches//x11-drivers/nvidia-drivers-340.93-r1/procfs-linux-4.3.patch'

==================================
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- kernel/nvidia/nv-procfs.c.orig   2015-11-07 20:22:44.937383656 -0500
|+++ kernel/nvidia/nv-procfs.c   2015-11-07 20:24:20.755353556 -0500
--------------------------
No file to patch.  Skipping patch.
2 out of 2 hunks ignored

patch program exited with status 1
==================================

PATCH COMMAND:  patch -p3 -g0 -E --no-backup-if-mismatch  < '/etc/portage/patches//x11-drivers/nvidia-drivers-340.93-r1/procfs-linux-4.3.patch'

==================================
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- kernel/nvidia/nv-procfs.c.orig   2015-11-07 20:22:44.937383656 -0500
|+++ kernel/nvidia/nv-procfs.c   2015-11-07 20:24:20.755353556 -0500
--------------------------
No file to patch.  Skipping patch.
2 out of 2 hunks ignored

patch program exited with status 1
==================================

PATCH COMMAND:  patch -p4 -g0 -E --no-backup-if-mismatch  < '/etc/portage/patches//x11-drivers/nvidia-drivers-340.93-r1/procfs-linux-4.3.patch'

==================================
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- kernel/nvidia/nv-procfs.c.orig   2015-11-07 20:22:44.937383656 -0500
|+++ kernel/nvidia/nv-procfs.c   2015-11-07 20:24:20.755353556 -0500
--------------------------
No file to patch.  Skipping patch.
2 out of 2 hunks ignored

patch program exited with status 1

I'm not sure how to interpret the error.

Any debugging hints will be gratefully received.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6101
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Nov 13, 2015 1:04 am    Post subject: Reply with quote

https://devtalk.nvidia.com/default/topic/894842/linux/340-93-kernel-module-does-not-build-with-kernel-4-3/

https://devtalk.nvidia.com/default/topic/877365/linux/355-11-linux-4-3-rc1-build-error/


also take note that there's an ABI version change with xorg-server 1.18

https://devtalk.nvidia.com/default/topic/894725/linux/abi-version-20-0-issues/
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum