Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xrandr not listing discrete GPU [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
vanjo9800
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2015
Posts: 76

PostPosted: Sat Apr 11, 2015 4:56 pm    Post subject: Xrandr not listing discrete GPU [SOLVED] Reply with quote

I have an Optimus laptop with Nvidia and Intel GPUs. The Intel GPU is connected to the desktop and because of kernel dynamic power management the Nvidia GPU is turned off. I am using the open-source Nouveau driver for nvidia. However, xrandr is listing only my Intel GPU and I cannot use my Nvidia GPU with PRIME.
These are the models of the GPUs:
Code:

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)
08:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
09:00.0 Ethernet controller: Qualcomm Atheros QCA8171 Gigabit Ethernet (rev 10)


Here is the output of Xrandr:
Code:

user@localhost ~ $ xrandr --listproviders                                                                                                                     
Providers: number : 1
Provider 0: id: 0x48 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 5 associated providers: 0 name:Intel


Thank you in advance for your help!!!


Last edited by vanjo9800 on Thu Apr 16, 2015 5:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
lovelytux
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2013
Posts: 93
Location: Westwoods of Germany

PostPosted: Sun Apr 12, 2015 11:09 am    Post subject: Reply with quote

Hey, do you know this GENTOO-WIKI? => https://wiki.gentoo.org/wiki/NVIDIA_Driver_with_Optimus_Laptops

lovelytux
Back to top
View user's profile Send private message
vanjo9800
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2015
Posts: 76

PostPosted: Sun Apr 12, 2015 3:51 pm    Post subject: Reply with quote

I know that nvidia has its own binary not open-source drivers. However, I have been using nouveau in Arch Linux and xrandr detected the NVIDIA card.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Apr 14, 2015 3:33 pm    Post subject: Reply with quote

Do you have nouveau enabled in your kernel and xf86-video-nouveau installed? Do you have any xorg.conf file?
Back to top
View user's profile Send private message
vanjo9800
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2015
Posts: 76

PostPosted: Tue Apr 14, 2015 5:46 pm    Post subject: Reply with quote

I have the nouveau driver installed and loaded. It even shows the temperature of my video card, which now is "N/A," because the card is on dynamic power management. It seems that I do not have a clear xorg.conf file, but I have made one configuration for my intel video card as it is mentioned there: https://wiki.gentoo.org/wiki/Intel. Do I need to have a specific file named "xorg.conf"?

Thank you in advance!!!
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Apr 14, 2015 6:07 pm    Post subject: Reply with quote

Usually, no xorg.conf is needed unless you have some special setup.

Try renaming or removing xorg.conf and check xrandr --listproviders again after restarting X.
Back to top
View user's profile Send private message
vanjo9800
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2015
Posts: 76

PostPosted: Wed Apr 15, 2015 7:22 pm    Post subject: Reply with quote

I have no file "xorg.conf" however I have some files in /usr/share/X11/xorg.conf.d/ .
Restarting X does not work, unfortunately.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Thu Apr 16, 2015 11:53 am    Post subject: Reply with quote

I mean xorg.conf or anything in xorg.conf.d/ with a Device section.
Back to top
View user's profile Send private message
vanjo9800
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2015
Posts: 76

PostPosted: Thu Apr 16, 2015 5:23 pm    Post subject: Reply with quote

By removing the device_no_vesa.conf it worked.

Thank you very much!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum