Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X video driver really strange behavior, video included
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ALF__
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2003
Posts: 143

PostPosted: Fri Apr 10, 2015 9:52 pm    Post subject: X video driver really strange behavior, video included Reply with quote

Hello!

Im trying to get a very old laptop up and running, it uses the prosavage8 videocard, so i need to run the vesa driver.

Everything seems to be working very good "inside" of x. But it have this extremely strange behavior when you first start it, and similiar when you quit X server, it fills the screen with a very strange pattern, that just seem to "grow"

Please see this link:
https://www.youtube.com/watch?v=1K5MT22tzUY


What is happening here? :)
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1687
Location: Here and Away Again

PostPosted: Fri Apr 10, 2015 10:38 pm    Post subject: ><)))°€ Reply with quote

For one, it's not recommended, not common to run X as root, so as a first thing I'd suggest you do it as a regular user.

Second, I have had this happen some ages ago, with some testing machine, though I don't remember it actually getting to the desktop, but instead, just “freeze” like that with the “cool” effect. It was likely with an older nvidia card, but I really can't remember the specifics, or if I actually did get it running normally in the end or not.

I really doubt the running as root is the cause, but I do believe most would suggest against running xorg-server as root, usually for security reasons alone. ^^

It might be a good idea to post your xorg.conf (if you are using any), as well as Xorg.0.log. Perhaps the kernel-configuration and dmesg as well.


Just a few, quick-like thoughts!
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
ALF__
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2003
Posts: 143

PostPosted: Sat Apr 11, 2015 1:15 pm    Post subject: Reply with quote

I will try to post the log.

I havent configured much else than it should use the vesa driver..

My guess is that it is trying some modes automacally first, and that maybe that makes the screen goes crazy?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum