Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba - SWAT not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Cyker
Veteran
Veteran


Joined: 15 Jun 2006
Posts: 1746

PostPosted: Wed Apr 08, 2015 5:43 pm    Post subject: Samba - SWAT not working Reply with quote

Hey all,

I just noticed that swat isn't working; I checked the xinetd.d/swat file is correctly set and enabled, but when you browse to localhost:901 I get this weird error:

Code:
500 Server Error
 chdir failed - the server is not configured correctly


According to what I've found on the 'net so far, this indicates that the swat HTML files have not been installed.

The main Gentoo-specific suggestion that I have found was to make sure that "swat" and "doc" are set as USEflags, and I have confirmed that they are set on my system.

Does anyone know
a) Where these swat HTML files are supposed to go and
b) Where I can get them from?

I think this is a bug in the ebuild as I can see mention of swat directories, but frankly I don't understand where it's going wrong.
It has worked on older versions, e.g. on my previous server, but the version on my old server was a 3.0.x series, so somewhere between there and the 3.6.x series it has been broken!
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1126
Location: Baden / Germany

PostPosted: Tue May 12, 2015 8:55 pm    Post subject: Reply with quote

Had the same some time ago.

https://bugs.gentoo.org/show_bug.cgi?id=529602

Maybe you could confirm this bug.
I think when we have enough people on our side maybe some developer will have mercy with us.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum