Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome (Gentoo 2.2) install error & circular dependencies
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sseguron
n00b
n00b


Joined: 31 Mar 2015
Posts: 23

PostPosted: Tue Apr 07, 2015 11:25 am    Post subject: Gnome (Gentoo 2.2) install error & circular dependencies Reply with quote

Hi,

I am trying to install Gnome on my new server, Gentoo is fully new (only apache, php and mysql added so far).

emerge gnome-base/gnome


I get circular dependencies error

Calculating dependencies... done!
[ebuild N ] gnome-base/gnome-3.14.0:2.0 USE="bluetooth cdr classic cups extras -accessibility" 0 KiB
[ebuild N ] gnome-base/gnome-core-apps-3.14.0:3.0 USE="bluetooth cdr cups" 0 KiB
[ebuild N ] x11-terms/gnome-terminal-3.14.2-r2 USE="gnome-shell nautilus -debug" 1,744 KiB
[ebuild N ] gnome-extra/gnome-shell-extensions-3.14.3 USE="-examples" 223 KiB
[ebuild N ] app-eselect/eselect-gnome-shell-extensions-20120911 3 KiB
[ebuild N ] gnome-base/gnome-extra-apps-3.14.0-r1:3.0 USE="games shotwell tracker" 0 KiB
[ebuild N ] gnome-extra/gnome-tweak-tool-3.14.2 PYTHON_TARGETS="python2_7" 237 KiB
[nomerge ] x11-terms/gnome-terminal-3.14.2-r2 USE="gnome-shell nautilus -debug"
[nomerge ] gnome-base/gnome-shell-3.14.3 USE="bluetooth i18n networkmanager (-openrc-force)" PYTHON_TARGETS="python2_7"
[ebuild N ] gnome-base/gnome-control-center-3.14.2-r1:2 USE="bluetooth colord cups gnome-online-accounts i18n -debug -kerberos -v4l" INPUT_DEVICES="-wacom" 6,776 KiB
[ebuild N ] gnome-extra/nm-applet-1.0.0 USE="bluetooth introspection -modemmanager" 1,282 KiB
[ebuild N ] virtual/notification-daemon-0 USE="gnome" 0 KiB
[ebuild N ] gnome-base/gdm-3.14.1-r1 USE="branding introspection ipv6 systemd tcpd -accessibility -audit -debug -fprint -plymouth (-selinux) -smartcard {-test} -wayland -xinerama" 1,497 KiB
[ebuild N ] gnome-base/gnome-shell-3.14.3 USE="bluetooth i18n networkmanager (-openrc-force)" PYTHON_TARGETS="python2_7" 1,555 KiB

Total: 12 packages (12 new), Size of downloads: 13,315 KiB

* Error: circular dependencies:

(virtual/notification-daemon-0:0/0::gentoo, ebuild scheduled for merge) depends on
(gnome-base/gnome-shell-3.14.3:0/0::gentoo, ebuild scheduled for merge) (runtime)
(gnome-base/gnome-control-center-3.14.2-r1:2/2::gentoo, ebuild scheduled for merge) (runtime)
(gnome-extra/nm-applet-1.0.0:0/0::gentoo, ebuild scheduled for merge) (buildtime)
(virtual/notification-daemon-0:0/0::gentoo, ebuild scheduled for merge) (buildtime)

Then following a post in the forum, I installed virtual/notification-daemon with USE=-gnome, this way


USE=-gnome emerge --oneshot virtual/notification-daemon


after again

emerge gnome-base/gnome


I get new errors as follows


.../...
[ebuild N ] gnome-base/gnome-3.14.0 USE="bluetooth cdr classic cups extras -accessibility"
[blocks B ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-216-r3, sys-apps/gentoo-systemd-integrat ion-4)
[blocks B ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/ud ev-216)
[blocks B ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-216)
[blocks B ] sys-power/upower ("sys-power/upower" is blocking sys-power/upower-pm-utils-0.9.23-r2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

(dev-libs/openssl-1.0.1l-r1:0/0::gentoo, installed) pulled in by
>=dev-libs/openssl-0.9.6d:0[bindist=] required by (net-misc/openssh-6.7_p1:0/0::gentoo, installed)
^^^^^^^^

(dev-libs/openssl-1.0.1l-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/openssl-0.9.8g:0[-bindist] required by (net-voip/telepathy-gabble-0.18.3:0/0::gentoo, ebuild sched uled for merge)

^^^^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-power/upower-0.99.1:0/3::gentoo, ebuild scheduled for merge) pulled in by
>=sys-power/upower-0.99[introspection] required by (gnome-base/gnome-shell-3.14.3:0/0::gentoo, ebuild schedul ed for merge)
>sys-power/upower-0.99:= required by (x11-wm/mutter-3.14.3:0/0::gentoo, ebuild scheduled for merge)
>=sys-power/upower-0.99:= required by (gnome-base/gnome-settings-daemon-3.14.2:0/0::gentoo, ebuild scheduled for merge)
>=sys-power/upower-0.9:= required by (app-misc/tracker-1.2.5:0/100::gentoo, ebuild scheduled for merge)
>=sys-power/upower-0.99:= required by (gnome-base/gnome-control-center-3.14.2-r1:2/2::gentoo, ebuild schedule d for merge)
sys-power/upower required by (net-misc/networkmanager-1.0.0:0/0::gentoo, ebuild scheduled for merge)
>=sys-power/upower-0.99:= required by (gnome-extra/gnome-power-manager-3.14.1:0/0::gentoo, ebuild scheduled f or merge)

(sys-apps/systemd-216-r3:0/2::gentoo, ebuild scheduled for merge) pulled in by
sys-apps/systemd:0= required by (sys-apps/dbus-1.8.16:0/0::gentoo, ebuild scheduled for merge)
>=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.14.2-r1:2/2::gentoo, ebuild scheduled fo r merge)
>=sys-apps/systemd-44-r1[pam] required by (sys-auth/pambase-20120417-r3:0/0::gentoo, ebuild scheduled for mer ge)
>=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4:0/0::gentoo, ebuild scheduled for m erge)
>=sys-apps/systemd-186:0=[pam] required by (gnome-base/gdm-3.14.1-r1:0/0::gentoo, ebuild scheduled for merge)
sys-apps/systemd required by (x11-wm/mutter-3.14.3:0/0::gentoo, ebuild scheduled for merge)
>=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.14.3:0/0::gentoo, ebuild scheduled for merge)
sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.14.2:0/0::gentoo, ebuild scheduled for merge )

(sys-power/upower-pm-utils-0.9.23-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=sys-power/upower-pm-utils-0.9.23 required by (net-im/telepathy-mission-control-5.16.3:0/0::gentoo, ebuild s cheduled for merge)

(sys-fs/udev-216:0/0::gentoo, installed) pulled in by
>=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_ mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs?] (>= sys-fs/udev-208-r1:0/0[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-215-r1:0/0::gentoo, inst alled)
>=sys-fs/udev-208-r1 required by (virtual/udev-215:0/0::gentoo, installed)
>=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_ mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/ 0[abi_x86_64(-)]) required by (virtual/libudev-215-r1:0/1::gentoo, installed)
sys-fs/udev required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by x11-drivers/xf86-video-vmware-13.1.0
# required by x11-base/xorg-drivers-1.16[video_cards_vmware]
# required by x11-base/xorg-server-1.16.4[xorg]
# required by x11-drivers/xf86-video-glint-1.2.8-r1
=media-libs/mesa-10.3.7-r1 xa
# required by sys-apps/systemd-216-r3
# required by gnome-base/gdm-3.14.1-r1[systemd]
# required by gnome-base/gnome-3.14.0
# required by gnome-base/gnome (argument)
>=sys-apps/dbus-1.8.16 systemd
# required by net-voip/telepathy-gabble-0.18.3[-gnutls]
# required by net-im/telepathy-connection-managers-2-r2[-msn,xmpp]
# required by net-im/empathy-3.12.7
# required by gnome-base/gnome-core-apps-3.14.0
# required by gnome-base/gnome-3.14.0
# required by gnome-base/gnome (argument)
=dev-libs/openssl-1.0.1l-r1 -bindist
# required by media-libs/clutter-1.20.0[egl]
# required by media-libs/clutter-gtk-1.6.0
# required by net-im/empathy-3.12.7[map]
# required by gnome-base/gnome-core-apps-3.14.0
# required by gnome-base/gnome-3.14.0
# required by gnome-base/gnome (argument)
>=media-libs/cogl-1.18.2-r1 gles2
# required by gnome-base/gdm-3.14.1-r1
# required by gnome-base/gnome-3.14.0
# required by gnome-base/gnome (argument)
=sys-auth/pambase-20120417-r3 systemd
# required by media-gfx/gnome-photos-3.14.2
# required by gnome-base/gnome-extra-apps-3.14.0-r1[tracker]
# required by gnome-base/gnome-3.14.0[extras]
# required by gnome-base/gnome (argument)
>=media-plugins/grilo-plugins-0.2.13 upnp-av tracker
# required by x11-wm/mutter-3.14.3[kms]
# required by gnome-base/gnome-3.14.0
# required by gnome-base/gnome (argument)
>=media-libs/clutter-1.20.0 egl
# required by x11-drivers/xf86-video-vmware-13.1.0
# required by x11-base/xorg-drivers-1.16[video_cards_vmware]
# required by x11-base/xorg-server-1.16.4[xorg]
# required by x11-drivers/xf86-video-glint-1.2.8-r1
=x11-libs/libdrm-2.4.59 libkms

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

emerge: there are no ebuilds built with USE flags to satisfy "media-libs/cogl[gles2,kms]".
!!! One of the following packages is required to complete your request:
- media-libs/cogl-1.18.2::gentoo (Missing IUSE: kms)
(dependency required by "media-libs/clutter-1.20.0[egl]" [ebuild])
(dependency required by "media-libs/clutter-gst-2.0.14" [ebuild])
(dependency required by "net-im/empathy-3.12.7" [ebuild])
(dependency required by "gnome-base/gnome-core-apps-3.14.0" [ebuild])
(dependency required by "gnome-base/gnome-3.14.0" [ebuild])
(dependency required by "gnome-base/gnome" [argument])


I AM A BIT LOST. Can you help me pls.
Back to top
View user's profile Send private message
sseguron
n00b
n00b


Joined: 31 Mar 2015
Posts: 23

PostPosted: Mon Apr 13, 2015 8:40 am    Post subject: Sad... Reply with quote

Hi, I just chose Gentoo for its efficiency, I counted on the support of other fellows to build my system, but sadly I receive no help from others...
It is sad, I was very keen to using this new system.
Back to top
View user's profile Send private message
lovelytux
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2013
Posts: 93
Location: Westwoods of Germany

PostPosted: Mon Apr 13, 2015 8:53 am    Post subject: Reply with quote

Hey,

your title says you will install gentoo-2, although you tried to install gnome-3. What do you want really?

lovelytux
Back to top
View user's profile Send private message
sseguron
n00b
n00b


Joined: 31 Mar 2015
Posts: 23

PostPosted: Mon Apr 13, 2015 9:21 am    Post subject: Hello Reply with quote

I have installed gentoo a week ago, my version is:

# uname -r
3.14.32-xxxx-grs-ipv6-64

# cat /etc/gentoo-release
Gentoo Base System release 2.2

regarding Gnome, I don't mean any specific version, I just wanted to install it, and for that I just followed the gentoo online doc (https://wiki.gentoo.org/wiki/GNOME/Configuration),

but I ran into circular dependencies problems, that I am unable to solve myself.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Mon Apr 13, 2015 9:40 am    Post subject: Reply with quote

:roll: Here, let me give you a hanky...

Nah, I don't give those to crybabies.

On a serious note:
- as one of the messages says, 'bindist' useflag on openssl and openssh needs to match (which for most people means '-bindist')
- as for media-libs/cogl, this seems to be a mixing problem; you might need to keyword media-libs/cogl-1.18.2-r1
- as one of the remaining messages suggests, you need to run 'emerge --deselect sys-fs/udev' to trim the block list (drop sys-fs/udev from your world file - in fact, you might simply remove that entry manually)

Some blocks may still occur - systemd migration might be a bit tricky.


...though something about that output looks fishy; what did you set VIDEO_CARDS to ?
Back to top
View user's profile Send private message
sseguron
n00b
n00b


Joined: 31 Mar 2015
Posts: 23

PostPosted: Mon Apr 13, 2015 12:35 pm    Post subject: Reply with quote

Hi,

My server is hosted in a datacenter, not sure about the video card. Can this be a blocking factor ?

I planned to use Gnome from remote. Will i be able to do that ?

Rgds
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Mon Apr 13, 2015 2:18 pm    Post subject: Reply with quote

I didn't ask "what's your video card ?" (though that's somewhat important too), I asked "what did you set VIDEO_CARDS to ?".
Back to top
View user's profile Send private message
sseguron
n00b
n00b


Joined: 31 Mar 2015
Posts: 23

PostPosted: Mon Apr 13, 2015 7:37 pm    Post subject: Reply with quote

Hi, I did not set it at all (nothing in make.conf(s)).

So far, I only followed GNOME gentoo entry, which did not mention anything related to X11.

BTW I reinstalled the system to have something clean after my tries.

So ready to follow your advice.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Mon Apr 13, 2015 8:19 pm    Post subject: Reply with quote

Well, set that var to something that makes sense, otherwise x11-base/xorg-drivers pulls all available.
Back to top
View user's profile Send private message
sseguron
n00b
n00b


Joined: 31 Mar 2015
Posts: 23

PostPosted: Mon Apr 13, 2015 8:22 pm    Post subject: Reply with quote

So should I start by installing Xorg before installing Gnome ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum