Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SCSI AHA-1505
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Alexco
n00b
n00b


Joined: 07 Jul 2002
Posts: 23
Location: Coruscant

PostPosted: Tue Jul 30, 2002 11:15 am    Post subject: SCSI AHA-1505 Reply with quote

Hi !!
I am trying to get this thing to work, but without luck. It ´s a PNP ISA SCSI card, and the aha152x module should support it.
The only thing attached to it is my scanner.
If I try 'modprobe aha152x' I get an error stating that the hardware was not found. With 'modprobe aha152x io=0x140 irq=11' syslog entries state that the hardware was found, the card Bios made some inits, the bus is resetted but the irq fails and the module does not load.
I tried the isa-pnp tools, and they successfully enabled the card, but this irq thingy still does not work.

Any tips ??
Hardware:
Asus P2b-s with Intel 600Mhz P III, 256 MB Ram
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16090
Location: Colorado

PostPosted: Tue Jul 30, 2002 12:51 pm    Post subject: Reply with quote

I would go through rebuilding the kernel to make sure SCSI is compiled properly.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
Alexco
n00b
n00b


Joined: 07 Jul 2002
Posts: 23
Location: Coruscant

PostPosted: Tue Jul 30, 2002 4:37 pm    Post subject: no new kernel needed... Reply with quote

I think, this can not be the problem since I boot from an Adaptec 78U2W without probs...
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16090
Location: Colorado

PostPosted: Tue Jul 30, 2002 4:45 pm    Post subject: Reply with quote

Is anything else using the port/irq? For ports:
Code:
cat /proc/ioports

For IRQ:
Code:
cat /proc/interrupts

_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
Alexco
n00b
n00b


Joined: 07 Jul 2002
Posts: 23
Location: Coruscant

PostPosted: Wed Jul 31, 2002 11:12 am    Post subject: No Conflict Reply with quote

Sorry , all is OK.

But a cat /proc/isapnp shows some bogus (0xffff) io bases and irqs.
But isapnp claims that all is enabled.
If I disable the PNP on the card, and set it to a fixed irq and base, the
module can not be installed, too. So there has to be a general thing that I have missed.....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum