Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ec.h not found error in dev-lang/R [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
astaines
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2004
Posts: 91
Location: Ireland

PostPosted: Tue Feb 02, 2016 10:14 pm    Post subject: ec.h not found error in dev-lang/R [SOLVED] Reply with quote

Hi,

I recently tried to add the rvest package to my R installation. This in turn requires the R openssl package to be added. This failed with the following error :-
Code:

ec.h not found


I took me a while to find the source of the error, so I'll put what I found here.

ec.h is the piece of openssl that does elliptic curve cryptography.
In Gentoo this piece is not complied in the default dev-libs/openssl-1.0.2f configuration, for patent reasons. Specifically the USE flag
Code:

bindist

is set, and this switches off the elliptic curve functions, so there is no ec.h for the R package opensll (See https://cran.r-project.org/web/packages/openssl/index.html ) to find.

To fix this, I added the line
Code:

#
dev-libs/openssl -bindist

to /etc/portage/package.use/manual.

Re-emerging threw up two further error messages, as both net-misc/openssh and dev-qt/qtnetwork depended on having a version of openssl with the bindist use flag set. Adding the lines
Code:

#
net-misc/openssh -bindist
dev-qt/qtnetwork -bindist
#

to /etc/portage/package.use/manual fixed those promptly. R happily installed the necessary packages.

Regards,
Anthony Staines
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum