Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
how to disable systemd-efi-boot-generator?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fpemud
Apprentice
Apprentice


Joined: 15 Feb 2012
Posts: 277

PostPosted: Sun Apr 05, 2015 2:57 am    Post subject: how to disable systemd-efi-boot-generator? Reply with quote

systemd-efi-boot-generator generates "boot.automount" for my ESP partition, but I don't like this behavior because I want my ESP partition be mounted directly when system starts up.

Is there any way to disable this generator?

Surely I can use INSTALL_MASK="/usr/lib/systemd/system-generators/systemd-efi-boot-generator", but I don't think its a good method.
Back to top
View user's profile Send private message
poncho
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2011
Posts: 88

PostPosted: Sun Apr 05, 2015 7:46 am    Post subject: Reply with quote

Put an entry for your ESP partition with the options you would like into your fstab.
fstab should override the systemd automount logic.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1379

PostPosted: Sun Apr 05, 2015 7:08 pm    Post subject: Reply with quote

Confirm solution above:
Never experienced this problem, but I have in /etc/fstab:
/dev/sda1 /boot/efi vfat noauto,defaults,rw 0 0
noauto!
_________________
fun2gen2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum