Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X11 - no screens found in KVM guest
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
M51
n00b
n00b


Joined: 29 Mar 2015
Posts: 11

PostPosted: Fri Apr 03, 2015 1:35 am    Post subject: X11 - no screens found in KVM guest Reply with quote

This is my first Gentoo install. I am installing X11 as described here: https://wiki.gentoo.org/wiki/Xorg/Configuration

After installing, startx exits with an error: no screens found. I'm running this under KVM and have tried all the different video hardware available for the VM, e.g. Cirrus, QXL, VGA, etc. I've also tried enabling the virtual Cirrus and QXL drivers in my kernel but that had no noticeable effect.

I can't get to the machine at the moment to get my kernel config (i'll post it later if needed), and was asking this in the hope that someone would be able to answer off the top of their head.

Thanks
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 210
Location: Rosario, Argentina

PostPosted: Sat Jan 23, 2016 9:25 pm    Post subject: Reply with quote

I have the same issue, can you solved?
Back to top
View user's profile Send private message
zino
n00b
n00b


Joined: 14 Jan 2016
Posts: 21
Location: Switzerland

PostPosted: Sat Jan 23, 2016 11:16 pm    Post subject: Reply with quote

Just enabling cirrus or qxl support in the kernel isn't enough. You also have to set the VIDEO_CARDS variable in your make.conf file accordingly, i.e.

Code:
VIDEO_CARDS="qxl"


for enabling qxl support. You can also set multiple values for this variable.

Check the available video card drivers with

Code:
equery u xorg-drivers | egrep video_cards


After adjusting your make.conf file you have to run

Code:
# emerge -avuND @world


in order for the changes to take effect.

Also make sure you compile the x11-base/xorg-server package with the udev use flag enabled. This should allow you to run the X server without a configuration file.
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 210
Location: Rosario, Argentina

PostPosted: Sun Jan 24, 2016 2:05 pm    Post subject: Reply with quote

Thanks for response zino, case solved for me.


Regards.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum