Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Removing abi_x86_32 following true multilib news...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jhon987
Apprentice
Apprentice


Joined: 18 Nov 2013
Posts: 225

PostPosted: Mon Mar 30, 2015 2:37 pm    Post subject: Removing abi_x86_32 following true multilib news... Reply with quote

Hi,
since my machine is 64-bit capable I've decided to try removing 32-bit multilib and see if 2015 is capable of managing without it.
Now, there's a common error I get when running some applications, all seems to lead to a similar problem which revolves around this: ASSERT: "!themeName.isEmpty()"
here's the full error I get when running from terminal:

Code:
$ qbittorrent
ASSERT: "!themeName.isEmpty()" in file image/qiconloader.cpp, line 238


*************************************************************
Catching SIGABRT, please report a bug at http://bug.qbittorrent.org
and provide the following backtrace:
qBittorrent version: v3.1.9.2
stack trace:
  /lib64/libc.so.6 : gsignal()+0x37  [0x7f8c7b4e0e47]
  /lib64/libc.so.6 : abort()+0x16a  [0x7f8c7b4e21aa]
  /usr/lib64/qt4/libQtCore.so.4 : qt_message_output(QtMsgType, char const*)+0x64  [0x7f8c7c2e44f4]
  /usr/lib64/qt4/libQtCore.so.4 : ()+0x71679  [0x7f8c7c2e4679]
  /usr/lib64/qt4/libQtCore.so.4 : qFatal(char const*, ...)+0x9c  [0x7f8c7c2e4efc]
  /usr/lib64/qt4/libQtGui.so.4 : ()+0x27c6ba  [0x7f8c7cd426ba]
  /usr/lib64/qt4/libQtGui.so.4 : ()+0x27d46e  [0x7f8c7cd4346e]
  /usr/lib64/qt4/libQtGui.so.4 : ()+0x27ddc1  [0x7f8c7cd43dc1]
  /usr/lib64/qt4/libQtGui.so.4 : ()+0x27df87  [0x7f8c7cd43f87]
  /usr/lib64/qt4/libQtGui.so.4 : ()+0x27e13b  [0x7f8c7cd4413b]
  /usr/lib64/qt4/libQtGui.so.4 : QIconEngineV2::availableSizes(QIcon::Mode, QIcon::State)+0x37  [0x7f8c7cd76b27]
  /usr/lib64/qt4/libQtGui.so.4 : QIcon::availableSizes(QIcon::Mode, QIcon::State) const+0x2a  [0x7f8c7cd3b49a]
  /usr/lib64/qt4/libQtGui.so.4 : QIcon::fromTheme(QString const&, QIcon const&)+0xf6  [0x7f8c7cd3bb56]
  qbittorrent : IconProvider::getIcon(QString const&)+0xf0  [0x5e30c0]
  qbittorrent : MainWindow::MainWindow(QWidget*, QStringList const&)+0x481  [0x5b5031]
  qbittorrent : main()+0xfb5  [0x4704e5]
  /lib64/libc.so.6 : __libc_start_main()+0xf5  [0x7f8c7b4cdad5]
  qbittorrent() [0x473409]
Aborted

user@Gentoo ~ $ qupzilla
QupZilla: 2 extensions loaded
Fatal: ASSERT: "!themeName.isEmpty()" in file image/qiconloader.cpp, line 238
Aborted


I understand this is some C++ error, my question is can it be easily fixed without knowing C++ or should I revert to using multilib again and re-emerge 164 packages??

Edit: on second thought, this question is probably more suitable for "Portage & Programming" is it possible for me to move it there?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Mon Mar 30, 2015 2:45 pm    Post subject: Re: Removing abi_x86_32 following true multilib news... Reply with quote

jhon987 wrote:
Hi,
since my machine is 64-bit capable I've decided to try removing 32-bit multilib and see if 2015 is capable of managing without it.

That has been possible for several years, if you could do without e.g. wine and the 32-bit dependencies that naturally come with it.

But, what exactly have you done?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jhon987
Apprentice
Apprentice


Joined: 18 Nov 2013
Posts: 225

PostPosted: Mon Mar 30, 2015 2:56 pm    Post subject: Re: Removing abi_x86_32 following true multilib news... Reply with quote

genstorm wrote:

But, what exactly have you done?


So there was those news about true-multilib which suggested removing emul-linux-x86 and then use abi_x86_32 instead, what I did was removing emul... and moving to a no multilib profile (eselect profile set 9), followed by emerge -auND @world.
Have dealt with preserved-libs issues by manually re-emerging some packages (didn't want to give in to any 32-bit necessity), restarted my PC and then got these errors...

So, I've noticed I don't have any "image/qiconloader.cpp" file, could that be the culprit?
Back to top
View user's profile Send private message
jhon987
Apprentice
Apprentice


Joined: 18 Nov 2013
Posts: 225

PostPosted: Mon Mar 30, 2015 3:12 pm    Post subject: Reply with quote

Now that's interesting - when running those apps as root they execute fine...

What can it be??
Back to top
View user's profile Send private message
jhon987
Apprentice
Apprentice


Joined: 18 Nov 2013
Posts: 225

PostPosted: Mon Mar 30, 2015 3:42 pm    Post subject: Reply with quote

OK I've solved it, while avoiding using preserved-libs portage suggested me to install all kinds of Qt packages with some weird use flags:
Quote:

It might be possible to solve these slot collisions
by applying all of the following changes:
- dev-qt/qtcore-4.8.5-r2 (Change USE: +aqua)
- dev-qt/qtsql-4.8.5 (Change USE: +aqua)
- dev-qt/qttest-4.8.5 (Change USE: +debug +aqua)
- dev-qt/qtdeclarative-4.8.5 (Change USE: +debug +qt3support +aqua)
- dev-qt/qtsql-4.8.5 (Change USE: +debug +qt3support +aqua)
- dev-qt/qtxmlpatterns-4.8.5 (Change USE: +debug +aqua)
- dev-qt/qtwebkit-4.8.5 (Change USE: +debug +aqua)
- dev-qt/qtopengl-4.8.5 (Change USE: +debug +qt3support +aqua)


and that's what caused the problems! re-emerged manually without them...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum