Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema kde dopo aggiornamento
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Genkoo
n00b
n00b


Joined: 27 Mar 2015
Posts: 7

PostPosted: Fri Mar 27, 2015 8:10 pm    Post subject: Problema kde dopo aggiornamento Reply with quote

Salve ragazzi!
Ho avuto un po' di tempo fa un problema con l'ambiente desktop, dopo aver eseguito l'aggiornamento con il successivo deepclean. Più esattamente parlo dei comandi:
Code:
# emerge --update --deep --with-bdeps=y --newuse world

e
Code:
# emerge --depclean

Seguito poi da un:
Code:
# revdep-rebuild

Il problema consiste nel fatto che dopo aver dato questi comandi, non mi é stato più possibile avviare il login managar(sono infatti ritornato alla modalità testuale), e non so quale fra i primi due mi abbia causato questo problema(suppongo il secondo).
Dal momento che io ho necessità di tenere il mio sistema sempre aggiornato, potreste darmi qualche dritta se foste riusciti ad individuare quale possa essere il problema(so che é molto vaga la descrizione del problema)?
Scrivo questo topic per prevenire un altro aggiornamento andato " a male"
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 151
Location: Osimo(AN)

PostPosted: Sat Mar 28, 2015 2:08 am    Post subject: Reply with quote

prova a dare
Code:
emerge @module-rebuild

_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.30.2
Back to top
View user's profile Send private message
Genkoo
n00b
n00b


Joined: 27 Mar 2015
Posts: 7

PostPosted: Sat Mar 28, 2015 1:27 pm    Post subject: Reply with quote

Massimog wrote:
prova a dare
Code:
emerge @module-rebuild

Nulla, ho fatto l'aggiornamento e di nuovo mi é ritornato alla schermata testuale. Andando nel file log di kdm, é presente un errore riguardante dbus.
Code:
kdelauncher(2997) kdemain: No DBUS session-bus found. Check if you have started the DBUS server

Code:
kdeinit4: Communication error with launcher. Exiting!
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sat Mar 28, 2015 5:12 pm    Post subject: Reply with quote

Per prima cosa --with-bdeps=y va usato anche con il depclean altrimenti vengono piallate le dipendenze necessarie al build. Come consigliato nel man è bene metterlo in default.

Forse è il caso che rilanci un update per ripristinare e che provi a lanciare un emerge -1 per dbus, qtdbus e le altre sue dipendenze. si sarà scombinato qualcosa.
Forse se cerchi nei log un suo crash potresti avere qualche informazione in più.
/etc/portage/make.conf wrote:
EMERGE_DEFAULT_OPTS="--with-bdeps y --quiet-build=y"
INSTALL_MASK="AUTHORS.* HACKING.* INSTALL.* LICENSE.* TODO.* Changes.* ChangeLog.* NEWS.* THANKS.* COPYNG.*"
PKG_INSTALL_MASK="${INSTALL_MASK}"
AUTOCLEAN="yes"
FEATURES="assume-digests binpkg-logs -candy -ccache collision-protect news"
FEATURES="${FEATURES} compress-build-logs distlocks fixlafiles protect-owned"
FEATURES="${FEATURES} sfperms strict unmerge-logs unmerge-orphans userfetch usersync"
FEATURES="${FEATURES} sandbox -userpriv usersandbox"
#FEATURES="${FEATURES} -fail-clean noclean keeptemp keepwork"
#FEATURES="${FEATURES} fixpackages getbinpkg"
FEATURES="${FEATURES} parallel-fetch"

_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Genkoo
n00b
n00b


Joined: 27 Mar 2015
Posts: 7

PostPosted: Sat Mar 28, 2015 5:41 pm    Post subject: Reply with quote

djinnZ wrote:
Per prima cosa --with-bdeps=y va usato anche con il depclean altrimenti vengono piallate le dipendenze necessarie al build. Come consigliato nel man è bene metterlo in default.

Forse è il caso che rilanci un update per ripristinare e che provi a lanciare un emerge -1 per dbus, qtdbus e le altre sue dipendenze. si sarà scombinato qualcosa.
Forse se cerchi nei log un suo crash potresti avere qualche informazione in più.
/etc/portage/make.conf wrote:
EMERGE_DEFAULT_OPTS="--with-bdeps y --quiet-build=y"
INSTALL_MASK="AUTHORS.* HACKING.* INSTALL.* LICENSE.* TODO.* Changes.* ChangeLog.* NEWS.* THANKS.* COPYNG.*"
PKG_INSTALL_MASK="${INSTALL_MASK}"
AUTOCLEAN="yes"
FEATURES="assume-digests binpkg-logs -candy -ccache collision-protect news"
FEATURES="${FEATURES} compress-build-logs distlocks fixlafiles protect-owned"
FEATURES="${FEATURES} sfperms strict unmerge-logs unmerge-orphans userfetch usersync"
FEATURES="${FEATURES} sandbox -userpriv usersandbox"
#FEATURES="${FEATURES} -fail-clean noclean keeptemp keepwork"
#FEATURES="${FEATURES} fixpackages getbinpkg"
FEATURES="${FEATURES} parallel-fetch"


Sono riuscito a ripristinare il login manager andando di emerge xdm. Il problema adesso é che kde non vuole saperne di partire. Non é presente nemmeno tra le opzioni di kdm.
Come da te consigliato provo ad eseguire un altro update
Aggiornamento....
Nada, niente da fare, kde non vuole saperne di partire

Aggiornamento-----
Sono riuscito a ripristinare kde tramitei il pacchetto:
Code:
kde-base/kdebase-meta

La cosa strana é che quello standard non veniva riconosciuto(nel senso che nelle opzioni di kdm non mi permetteva di selezionare la voce kde workspace proprio perché non era presente).
Ora che ho aggiunto quest'opzione, in teoria non mi dovrebbe più dare il problema del desktop?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Apr 03, 2015 2:29 pm    Post subject: Reply with quote

ma la variabile XSESSION è valorizzata correttamente ed è impostata in env.d?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Genkoo
n00b
n00b


Joined: 27 Mar 2015
Posts: 7

PostPosted: Tue Apr 07, 2015 3:55 pm    Post subject: Reply with quote

djinnZ wrote:
ma la variabile XSESSION è valorizzata correttamente ed è impostata in env.d?

Intendi /etc/env.d? Se sì, é vuoto il file.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum