Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Best way to replace KDE with XFCE4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
amaltheia
n00b
n00b


Joined: 03 Dec 2014
Posts: 55

PostPosted: Thu Mar 26, 2015 3:42 am    Post subject: Best way to replace KDE with XFCE4 Reply with quote

Hello,

I initially installed Gentoo with KDE but I am now ready to dump it in favor of XFCE4. I installed XFCE along side KDE in order to try it out and I have really liked it. I have KDM installed and XFCE is the default DE, but I can choose to run KDE at the login window. I am just wondering what the most efficient way is to purge my system of KDE and KDM.

I am thinking about simply unmerging KDE and KDM and then installing and configuring SLiM following the Gentoo wiki. Are there any other steps that I may be missing?
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Thu Mar 26, 2015 3:02 pm    Post subject: Reply with quote

You could use emerge --depclean (and --ask or --pretend to make sure it doesn't get too greedy) to delete excess packages.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Mar 26, 2015 3:23 pm    Post subject: Reply with quote

As long as you do not need any kde apps and please consider qt apps too you can remove those kde stuff.

Please note you can have several desctop environments and apps installed along and just load the desctop environment of your choice ... When you have the space and the compile time you can keep kde and just ignore the fact that its on your box at all. K3b is kinda a nice software and needs a lot of those kde-stuff installed.
Back to top
View user's profile Send private message
amaltheia
n00b
n00b


Joined: 03 Dec 2014
Posts: 55

PostPosted: Sat Mar 28, 2015 2:10 am    Post subject: Reply with quote

Thank you tw04l124 and eccerr0r for your suggestions. The reason that I want to remove KDE is because I like the idea of a more minimalistic DE and not all of the bloat that comes with KDE. The reason that I liked KDE was the look of it, but I have been able to make XFCE do everything that I want it to and I am very happy with it. There seems to be good alternatives for everything that I used in KDE with no need to keep it anymore.

With that said, I now come to a problem that I am having now that I removed un-installed KDE and KDM. I could not figure out how to get --depclean to work, so I just removed KDE and KDM using --unmerge. I changed my use flags in make.conf to -kde4 and -qt. I then ran a --sync and then emerge --update --newuse --deep @world and ran into some problems with blocked packages. I removed the offending packages (I don't remember what they were) and then got it to work. When I ran emerge --depclean I got a very long list of packages that were going to be removed (152 total). There are a number of things on the list that I don't think should be removed, but I am not sure what why they are on the list. The following list are all the packages that it wants to remove. Are there any packages that are on this list that I should be concerned about? If so, what do I do about it?

    All selected packages: =dev-util/automoc-0.9.88 =app-pda/libplist-1.11 =app-text/libspectre-0.2.7 =dev-libs/hyphen-2.8.6 =net-libs/libnm-qt-0.9.8.3 =dev-db/mysql-init-scripts-2.0-r1 =x11-libs/libkscreen-1.0.5 =media-libs/libdvdnav-4.2.1 =media-sound/cdparanoia-3.10.2-r6 =net-libs/neon-0.30.1 =net-misc/mobile-broadband-provider-info-20120614 =app-text/mythes-1.2.3 =media-gfx/optipng-0.7.3 =virtual/perl-Sys-Syslog-0.330.0-r1 =sys-libs/libutempter-1.1.6-r1 =dev-qt/qtwebkit-4.8.5 =dev-db/unixODBC-2.3.2-r1 =media-libs/libvisio-0.1.1 =dev-qt/qttest-4.8.5 =x11-apps/scripts-1.0.1-r1 =dev-python/PyQt4-4.11.1 =dev-util/mdds-0.10.3 =sys-kernel/gentoo-sources-3.18.7 =sci-libs/suitesparseconfig-4.2.1 =media-libs/glm-0.9.6.1 =virtual/libusb-0-r2 =dev-libs/libusb-compat-0.1.5-r2 =media-libs/libdvdread-4.2.1 =media-libs/libdvdcss-1.2.13-r1 =app-text/libexttextcat-3.4.0 =media-libs/x264-0.0.20140308 =dev-libs/libksba-1.3.2 =dev-qt/qtmultimedia-4.8.5 =app-admin/gam-server-0.1.10-r2 =virtual/cdrtools-0 =dev-cpp/libcmis-0.4.1 =media-libs/libwebp-0.4.0 =media-libs/faad2-2.7-r3 =app-admin/gamin-0.1.10-r1 =x11-libs/libXScrnSaver-1.2.2-r1 =app-crypt/gnupg-2.0.26-r3 =www-misc/htdig-3.2.0_beta6-r3 =media-libs/taglib-1.9.1-r2 =dev-python/notify-python-0.1.1-r3 =sys-auth/polkit-kde-agent-0.99.0-r1 =media-libs/mutagen-1.22 =dev-perl/libxml-perl-0.80.0-r1 =dev-python/sip-4.16.2 =app-text/enchant-1.6.0 =dev-libs/qjson-0.8.1 =sci-libs/colamd-2.8.0 =media-video/vlc-2.1.2 =app-admin/eselect-pinentry-0.4 =dev-python/dbus-python-1.2.0-r1 =dev-libs/libaio-0.3.110 =net-misc/wicd-1.7.2.4-r3 =virtual/mysql-5.6-r2 =dev-perl/Archive-Zip-1.370.0 =app-text/liblangtag-0.5.1 =dev-perl/DBI-1.628.0 =virtual/perl-Term-ANSIColor-4.20.0-r2 =app-text/libmspub-0.1.2 =media-libs/phonon-vlc-0.7.2 =app-misc/strigi-0.7.8 =app-text/libwps-0.3.1 =dev-perl/DBD-mysql-4.20.0-r1 =dev-perl/Net-Daemon-0.480.0-r1 =media-libs/libdca-0.0.5-r3 =media-libs/faac-1.28-r4 =x11-apps/xsetroot-1.1.1 =x11-apps/xmessage-1.0.4 =media-libs/phonon-4.7.2 =dev-qt/qtdbus-4.8.5 =media-libs/libmp4v2-2.0.0 =media-libs/libgpod-0.8.3 =net-libs/libssh-0.6.4 =dev-libs/libattica-0.4.2 =media-libs/xine-lib-1.2.6 =media-libs/libfreehand-0.1.0 =dev-qt/qtdeclarative-4.8.5 =dev-qt/qtxmlpatterns-4.8.5 =sys-devel/ucpp-1.3.4 =app-cdr/cdrtools-3.01_alpha17 =dev-libs/libassuan-2.1.1 =dev-qt/qtopengl-4.8.5 =media-libs/libmpeg2-0.5.1-r2 =virtual/perl-Time-HiRes-1.972.600-r1 =media-video/transcode-1.1.7-r3 =dev-cpp/gstreamermm-0.10.11 =media-libs/libart_lgpl-2.3.21-r2 =dev-util/cppunit-1.13.2-r2 =dev-libs/libgamin-0.1.10-r5 =app-text/libetonyek-0.1.1 =sys-apps/accountsservice-0.6.39 =app-crypt/qca-2.0.3 =dev-python/urwid-1.2.2 =app-text/libwpd-0.10.0-r1 =net-wireless/bluedevil-2.0_rc1 =x11-libs/qtscriptgenerator-0.2.0 =app-text/libodfgen-0.1.3 =media-libs/qimageblitz-0.0.6-r1 =dev-cpp/eigen-2.0.17 =dev-libs/rasqal-0.9.29 =net-misc/npapi-sdk-0.27.2 =dev-libs/libxdg-basedir-1.2.0-r1 =app-arch/advancecomp-1.15 =dev-libs/redland-1.0.16 =media-libs/glew-1.10.0-r2 =x11-apps/setxkbmap-1.3.0 =dev-qt/designer-4.8.5 =dev-libs/pth-2.0.7-r3 =dev-libs/libnatspec-0.2.6 =x11-misc/makedepend-1.0.5 =media-libs/taglib-extras-1.0.1 =virtual/ffmpeg-9-r1 =media-libs/libao-1.2.0 =dev-python/pytz-2014.10 =virtual/fam-0-r1 =dev-libs/libixion-0.7.0 =dev-perl/XML-DOM-1.440.0-r1 =dev-python/Babel-1.3-r1 =sci-mathematics/lpsolve-5.5.2.0 =media-libs/raptor-2.0.9 =app-text/libabw-0.1.1 =app-cdr/dvd+rw-tools-7.1-r1 =x11-apps/xrandr-1.4.3 =dev-python/pyudev-0.16.1-r1 =app-text/libebook-0.1.2 =net-libs/libbluedevil-2.0_rc1 =media-libs/xvid-1.3.3 =media-gfx/exiv2-0.24-r1 =media-libs/libcdr-0.1.1 =media-fonts/libertine-5.1.3.20110615 =dev-libs/libatomic_ops-7.4.2 =dev-perl/XML-RegExp-0.40.0-r1 =media-libs/libdvbpsi-0.2.2 =app-crypt/pinentry-0.9.0 =dev-cpp/clucene-2.3.3.4-r5 =dev-libs/librevenge-0.0.2 =dev-libs/libdbusmenu-qt-0.9.2 =app-cdr/cdrdao-1.2.3-r1 =dev-perl/PlRPC-0.202.0-r2 =app-text/libmwaw-0.3.4 =dev-libs/liborcus-0.7.0 =app-text/libwpg-0.3.0 =sys-auth/polkit-qt-0.112.0-r1 =app-misc/media-player-info-21-r1 =app-crypt/mhash-0.9.9.9-r1 =media-libs/a52dec-0.7.4-r7 =media-libs/vo-aacenc-0.1.3 =dev-db/mariadb-10.0.16 =media-libs/freeglut-2.8.1-r1
Back to top
View user's profile Send private message
amaltheia
n00b
n00b


Joined: 03 Dec 2014
Posts: 55

PostPosted: Sat Mar 28, 2015 2:12 am    Post subject: Reply with quote

In case you need some more information about my computer, here are the results from emerge --info:

Code:
emerge --info
Portage 2.2.14 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop, gcc-4.8.3, glibc-2.20-r2, 3.17.7-gentoo x86_64)
=================================================================
System uname: Linux-3.17.7-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T5250_@_1.50GHz-with-gentoo-2.2
KiB Mem:     2039412 total,     91668 free
KiB Swap:     524284 total,    518784 free
Timestamp of tree: Fri, 27 Mar 2015 22:00:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9-r1, 3.3.5-r1, 3.4.1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.11
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.6
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.18 (virtual/os-headers)
sys-libs/glibc:           2.20-r2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.cites.uiuc.edu/pub/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="X a52 aac acl acpi alsa amd64 anacron berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cupsdvd cxx dbus dri dts dvd dvdr embedded emboss encode exif extraengine fam firefox flac fortran ftp gdbm gif gimp glamor gpm gtk iconv icu ipod ipv6 jpeg lcms ldap libav libkms libnotify lock mad mmx mmxext mng modules mozilla mp3 mp4 mpeg multilib ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf plymouth png policykit ppds pyqt4 python qstreamer qt3support readline sdl session spell sqlite sse sse2 ssl startup-notification svg symlink tcpd thunar tiff truetype udev udisks unicode upower usb vorbis wifi wxwidgets x x264 xcb xfce xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Back to top
View user's profile Send private message
amaltheia
n00b
n00b


Joined: 03 Dec 2014
Posts: 55

PostPosted: Sat Mar 28, 2015 2:23 am    Post subject: Reply with quote

Here is one last thing that may figure out what is wrong. I ran emerge @preserved-rebuild and got the following results:

Code:
emerge @preserved-rebuild

 * IMPORTANT: 12 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
Calculating dependencies... done!
[ebuild  N     ] kde-base/kde-env-4.14.3  USE="(-aqua)"
[ebuild   R    ] sys-libs/zlib-1.2.8-r1  USE="minizip*"
[ebuild  N     ] kde-base/oxygen-icons-4.14.3  USE="(-aqua) -sources"
[ebuild  N     ] media-video/libav-9.17  USE="X aac alsa bzip2 encode gpl hardcoded-tables mp3 network sdl ssl truetype vorbis x264 xvid zlib (-altivec) -amr -cdio -cpudetection -custom-cflags -debug -doc -faac -fdk -frei0r -gsm -ieee1394 -jack -jpeg2k (-neon) -openssl -opus -oss -pic -pulseaudio -rtmp -schroedinger -speex -static-libs {-test} -theora -threads -tools -v4l -vaapi -vdpau (-vis) -vpx" ABI_X86="(64) (-32) (-x32)" CPU_FLAGS_X86="mmx mmxext -3dnow -3dnowext -avx -ssse3"
[ebuild  N     ] media-libs/libpostproc-10.20140517-r1  USE="(-altivec) -pic -static-libs" ABI_X86="(64) (-32) (-x32)" CPU_FLAGS_X86="mmx mmxext -3dnow"
[ebuild   R    ] media-libs/xine-lib-1.2.6  USE="-xinerama*"
[ebuild   R    ] media-video/transcode-1.1.7-r3
[ebuild     U  ] media-video/vlc-2.1.5-r1 [2.1.2] USE="libav%* -kde* -qt4* -vnc%"
[ebuild  N     ] kde-base/kdelibs-4.14.3-r1  USE="acl alsa bzip2 crypt fam handbook nls opengl policykit spell ssl udev udisks upower (-altivec) (-aqua) -debug -doc -jpeg2k -kerberos -lzma -nepomuk -openexr {-test} -zeroconf" CPU_FLAGS_X86="mmx sse sse2 -3dnow"
[ebuild  N     ] kde-base/katepart-4.14.3  USE="handbook (-aqua) -debug"
[ebuild  N     ] kde-base/kdesu-4.14.3  USE="handbook (-aqua) -debug"
[ebuild  N     ] kde-base/khelpcenter-4.14.3  USE="(-aqua) -debug"
[ebuild     U  ] sys-auth/polkit-kde-agent-0.99.1-r1 [0.99.0-r1] USE="-minimal%" LINGUAS="-ar% -bs% -el% -kk% -mr% -pl% -sl% -ug% -vi% -zh_CN%"
[ebuild   R    ] x11-libs/libkscreen-1.0.5
[ebuild   R    ] net-wireless/bluedevil-2.0_rc1

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-video/vlc-2.1.5-r1
# required by @preserved-rebuild (argument)
>=sys-libs/zlib-1.2.8-r1 minizip

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum