Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
media-libs/netpbm-10.51.00-r2 fails to compile [Fixed]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
bjdacre
n00b
n00b


Joined: 25 Nov 2014
Posts: 22
Location: Whangarei, NZ

PostPosted: Wed Mar 25, 2015 1:20 am    Post subject: media-libs/netpbm-10.51.00-r2 fails to compile [Fixed] Reply with quote

Hi,

I am building my last laptop and everything I want compiles except media-libs/netpbm-10.51.00-r2.

This is apparently a dependency of xfce4-meta so this is a blocker (I assume) to getting my laptop working.

Here is some info;

The bottom of the build log;
Code:
...
x86_64-pc-linux-gnu-gcc -Wall -o cameratopam \
          util.o identify.o cameratopam.o camera.o foveon.o decode.o canon.o ljpeg.o dng.o  -L/var/tmp/portage/media-libs/netpbm-10.51.00-r2/work/netpbm-10.51.00/lib -lnetpbm \
  -lm -Wl,-O1 -Wl,--as-needed   \
   
make[3]: Leaving directory '/var/tmp/portage/media-libs/netpbm-10.51.00-r2/work/netpbm-10.51.00/converter/other/cameratopam'
make[2]: Leaving directory '/var/tmp/portage/media-libs/netpbm-10.51.00-r2/work/netpbm-10.51.00/converter/other'
make[1]: Leaving directory '/var/tmp/portage/media-libs/netpbm-10.51.00-r2/work/netpbm-10.51.00/converter'
/var/tmp/portage/media-libs/netpbm-10.51.00-r2/work/netpbm-10.51.00/common.mk:530: recipe for target 'converter/all' failed
make: *** [converter/all] Error 2
emake failed
 * ERROR: media-libs/netpbm-10.51.00-r2::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 1951:  Called die
 * The specific snippet of code:
 *       emake || die
 *
 * If you need support, post the output of `emerge --info '=media-libs/netpbm-10.51.00-r2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/netpbm-10.51.00-r2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-libs/netpbm-10.51.00-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/netpbm-10.51.00-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/netpbm-10.51.00-r2/work/netpbm-10.51.00'
 * S: '/var/tmp/portage/media-libs/netpbm-10.51.00-r2/work/netpbm-10.51.00'


Code:
emerge --info media-libs/netpbm
Portage 2.2.14 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop, gcc-4.8.3, glibc-2.20-r2, 3.18.9-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.18.9-gentoo-x86_64-AMD_A6-6310_APU_with_AMD_Radeon_R4_Graphics-with-gentoo-2.2
KiB Mem:     3478924 total,   2333648 free
KiB Swap:    2654204 total,   2560924 free
Timestamp of tree: Tue, 24 Mar 2015 21:15:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9-r1, 3.3.5-r1, 3.4.1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.11
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.4
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.18 (virtual/os-headers)
sys-libs/glibc:           2.20-r2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=btver2 -mtune=btver2 -mfpmath=sse -mrdrnd -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=btver2 -mtune=btver2 -mfpmath=sse -mrdrnd -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.swin.edu.au/gentoo ftp://ftp.swin.edu.au/gentoo http://mirrors.163.com/gentoo/ http://mirrors.sohu.com/gentoo/ ftp://mirrors.stuhome.net/gentoo/ http://mirrors.stuhome.net/gentoo/ rsync://mirrors.xmu.edu.cn/gentoo/ ftp://mirrors.xmu.edu.cn/gentoo http://mirrors.xmu.edu.cn/gentoo http://gentoo.aditsu.net:8000/ http://gentoo.gg3.net/ ftp://gg3.net/pub/linux/gentoo/ http://ftp.iij.ad.jp/pub/linux/gentoo/ rsync://ftp.iij.ad.jp/pub/linux/gentoo/ ftp://ftp.iij.ad.jp/pub/linux/gentoo/ http://ftp.jaist.ac.jp/pub/Linux/Gentoo/ rsync://ftp.jaist.ac.jp/pub/Linux/Gentoo/ ftp://ftp.jaist.ac.jp/pub/Linux/Gentoo/ http://ftp.daum.net/gentoo/ ftp://ftp.kaist.ac.kr/gentoo/ http://ftp.kaist.ac.kr/pub/gentoo/ ftp://ftp.lecl.net/pub/gentoo/ http://ftp.lecl.net/pub/gentoo/ http://ftp.twaren.net/Linux/Gentoo/ ftp://ftp.twaren.net/Linux/Gentoo/"
LANG="en_NZ.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aes alsa amd64 avx berkdb bindist branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvb dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg lcms ldap libnotify lock mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit popcnt ppds qt3support readline sdl session spell sse sse2 sse3 sse4_1 sse4_2 sse4a ssl ssse3 startup-notification svg tcpd threads thunar tiff truetype udev udisks unicode upower usb v4l vdpau vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


This is a view of the outstanding packages preventing xfce4-meta from installing;

Code:
sudo emerge --quiet --ask --tree xfce-base/xfce4-meta
Password:
[ebuild  N    ] xfce-base/xfce4-meta-4.10
[ebuild  N    ]  xfce-base/xfce4-session-4.10.1-r2
[ebuild  N    ]   x11-misc/xscreensaver-5.32
[ebuild  NS   ]  x11-themes/gtk-engines-xfce-3.0.1-r201 [3.0.1-r300]
[nomerge      ] x11-misc/xscreensaver-5.32
[ebuild  N    ]  media-libs/netpbm-10.51.00-r2

Would you like to merge these packages? [Yes/No] No


As you can see meta needs session needs screensaver which needs netpbm. When I actually try to start xfce, it fails as you would expect. I could probably get windowed apps from the command line because I managed to install the window manager, but I am not inclined at this stage to try and make that work.

I have three other laptops and a desktop with successful xfce installs, at least two of which successfully built this version of netpbm.

I am loading lxde to see how that goes, but I have tried lxde in the past and found I preferred xfce, but that, of course, was in the context of both of them working.

I can provide the full build file if necessary, but it is large and full of warnings. I don't particularly want netpbm, but I can't, as a relative gentoo beginner, see a way around it.

Brendan


Last edited by bjdacre on Tue Mar 31, 2015 9:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 896
Location: US-FL-EST

PostPosted: Wed Mar 25, 2015 7:03 pm    Post subject: Reply with quote

The snip of your build log doesn't actually have the part that failed. It's further up the log so trying to give you advice is a bit difficult.

FWIW - I have netpbm-10.66.0 built on my systems. You can enable just netpbm for ~amd64 and try that.

Or, you can try disabling some of the USE flags for netpbm. Example:
Code:
# equery uses netpbm
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for media-libs/netpbm-10.66.00:
 U I
 + + X                  : Add support for X11
 + + cpu_flags_x86_sse2 : Use the SSE2 instruction set
 - - doc                : Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
 + + jbig               : Enable jbig-kit support for tiff, Hylafax, ImageMagick, etc
 + + jpeg               : Add JPEG image support
 + + jpeg2k             : Support for JPEG 2000, a wavelet-based image compression format
 + + png                : Add support for libpng (PNG images)
 + + rle                : Build converters for the RLE format (utah raster toolkit)
 - - static-libs        : Build static versions of dynamic libraries as well
 + + tiff               : Add support for the TIFF image format
 + + xml                : Add support for XML files
 + + zlib               : Add support for zlib (de)compression

You can compare the USE flags you have enabled to where the compile error actually occured. If it occured in code turned on by a USE flag, you can disable that flag and try again. The general form is:
Code:
# USE="-flag1 -flag2" emerge -1 netpbm"

Good luck!
_________________
People whom think M$ is mediocre, don't know the half of it.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6968
Location: Saint Amant, Acadiana

PostPosted: Wed Mar 25, 2015 7:12 pm    Post subject: Reply with quote

Can you reproduce it with CFLAGS="-O2 -march=native -pipe" and MAKEOPTS="-j1".
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Thu Mar 26, 2015 4:55 am    Post subject: Reply with quote

Much hints, that this is the same problem as here.
Back to top
View user's profile Send private message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 896
Location: US-FL-EST

PostPosted: Fri Mar 27, 2015 2:32 am    Post subject: Reply with quote

VoidMage wrote:
Much hints, that this is the same problem as here.

What VoidMage said.

If you're having the same issue as in the indicated thread, disabling USE flags won't do it for you and you'll have to keyword for version 10.66.0.

You can do this:
Code:
# echo "media-libs/netpbm ~amd64" >> /etc/portage/package.keywords/netpbm

Note: Check if /etc/portage/package.keywords is a file or a directory first! If it isn't a directory like in my example or doesn't exist, then do this:
Code:
# echo "media-libs/netpbm ~amd64" >> /etc/portage/package.keywords

Then run a test emerge to see if the correct version comes up:
Code:
# emerge -pv media-libs/netpbm

If it displays something similar:
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/netpbm-10.66.00::gentoo  USE="X jbig jpeg jpeg2k png rle tiff xml zlib -doc -static-libs (-svga)" CPU_FLAGS_X86="sse2" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
then you're good to go.

My example reflects the fact I alread have it installed. The important part is that it be version 10.66.0.

Note: It's generally not recommended to override the default keyword just because you want to. For media-libs/netpbm, this instance should not lead to problems. ;)


Good Luck!
_________________
People whom think M$ is mediocre, don't know the half of it.
Back to top
View user's profile Send private message
bjdacre
n00b
n00b


Joined: 25 Nov 2014
Posts: 22
Location: Whangarei, NZ

PostPosted: Tue Mar 31, 2015 9:05 pm    Post subject: Reply with quote

Thanks for the replies.

Did a sync and world update and got an update to media-libs/netpbm-10.66.00 which then successfully compiled... :D

Brendan
Back to top
View user's profile Send private message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 896
Location: US-FL-EST

PostPosted: Wed Apr 01, 2015 5:37 pm    Post subject: Reply with quote

bjdacre wrote:
Thanks for the replies.

Did a sync and world update and got an update to media-libs/netpbm-10.66.00 which then successfully compiled... :D

Brendan

You're welcome.
_________________
People whom think M$ is mediocre, don't know the half of it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum