Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
AR9285 PCI card frequent disconnection issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
gsra99
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2008
Posts: 84

PostPosted: Tue Mar 24, 2015 9:56 pm    Post subject: AR9285 PCI card frequent disconnection issues Reply with quote

I am trying to connect to my router with wpa_supplocant, and it works but I seem to get frequently disconnected. I think this a problem with the 80211n mode on the wireless card. I have patched my kernel to allow we to pass the 11n_disable option to the ath9k module, and everything now works perfectly without any disconnection issues. I have seen people suggesting using the module option of nohwcrypt=1, but this does nothing to solve my problem. I wanted to know if there was a way of limiting wpa_supplicant to only using g-mode or another solution for the frequent disconnection issues. If not is there a patch for 11n_disable for newer kernels 3.16 onwards as the patch I am currently using does not work for newer kernels.

Last edited by gsra99 on Sun Mar 29, 2015 11:11 am; edited 1 time in total
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Tue Mar 24, 2015 10:22 pm    Post subject: Reply with quote

Have you checked the webinterface of your router to disable the n-mode?

I tried to check the manpage of wpa_supplicant but i was unable to find a quick solution.
Back to top
View user's profile Send private message
gsra99
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2008
Posts: 84

PostPosted: Tue Mar 24, 2015 10:30 pm    Post subject: Reply with quote

Sorry. I should have said that disabling n-mode on the router is an option that I considered, but would rather not do as I have other devices which connect to it using n-mode. Hence I would like to leave it on if possible.
Back to top
View user's profile Send private message
gsra99
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2008
Posts: 84

PostPosted: Sun Mar 29, 2015 11:14 am    Post subject: Reply with quote

Does anyone else suffer from the same disconnection issues using n-mode with this wireless chip? I really can't believe I am the only person suffering from this disconnection issue with this chip.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum