Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] unable to start kdm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mlybarger
Guru
Guru


Joined: 04 Sep 2002
Posts: 463

PostPosted: Tue Mar 17, 2015 12:17 am    Post subject: [SOLVED] unable to start kdm Reply with quote

i can use startx, and the xsession starts ok, but kdm doens't seem to want to start. this was working. not sure what was changed..?

Quote:

lightning ~ # cat /etc/conf.d/xdm
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ? [ xdm | gdm | kdm | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
DISPLAYMANAGER="kdm"
lightning ~ # /etc/init.d/xdm restart
* Stopping xdm ...
* start-stop-daemon: no matching processes found [ ok ]
ERROR: Please set your DISPLAYMANAGER variable in /etc/conf.d/xdm,
or install x11-apps/xdm package [ !! ]
* Setting up xdm ...
* start-stop-daemon: /usr/bin/xdm does not exist
* ERROR: could not start the Display Manager [ ok ]


Last edited by mlybarger on Tue Mar 17, 2015 5:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
Astronaut
n00b
n00b


Joined: 06 Oct 2012
Posts: 38
Location: RA 14h 15m 40s | Dec 19° 10.932'

PostPosted: Tue Mar 17, 2015 10:23 am    Post subject: Reply with quote

From the looks of the error message, I'd assume that you didn't install xdm properly

Try rebuilding xorg-server, hope it helps
Back to top
View user's profile Send private message
mlybarger
Guru
Guru


Joined: 04 Sep 2002
Posts: 463

PostPosted: Tue Mar 17, 2015 11:23 am    Post subject: Reply with quote

i've started an "emerge -e world"... so... i'm off to the office.

i am not using xdm, so it's not installed. i'm using kdm and the xdm init.d script which proxies to my specific DISPLAYMANAGER.
Back to top
View user's profile Send private message
mlybarger
Guru
Guru


Joined: 04 Sep 2002
Posts: 463

PostPosted: Tue Mar 17, 2015 5:27 pm    Post subject: Reply with quote

found out my system was compromised by something like this:

http://superuser.com/questions/863997/ddos-virus-infection-as-a-unix-service-on-a-debian-8-vm-webserver

i had a cron.sh in /etc/cron.hourly that was running and a 10 character service in /etc/init.d that was causing havoc. i cleaned that up and reinstalled kdm and it starts again. in the background, i still have the emerge -e world running, but that should be fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum