Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
URLs won't open anymore in Firefox (Xfce)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 516

PostPosted: Sun Mar 01, 2015 6:52 am    Post subject: URLs won't open anymore in Firefox (Xfce) Reply with quote

Since the update to Firefox-36, links opened in other applications (or just by issuing exo-open http://foo.com (or xdg-open)) result in Firefox spawning a new window, but with the default page and not with the URL in question.

Firefox is still set as the "preferred" webbrowser. I suspect that this is the reason: https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options#-remote_remote_command
Quote:
-remote remote_command

This feature has been removed in Firefox 36.


How do I make it possible to open URLs via exo-open again?


Last edited by haarp on Fri Mar 06, 2015 5:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 516

PostPosted: Thu Mar 05, 2015 9:21 pm    Post subject: Reply with quote

Found the cause: https://bugzilla.mozilla.org/show_bug.cgi?id=1080319

There's relevant discussion in there. Seems this got reverted in 36.0.1.
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 545
Location: France

PostPosted: Fri Mar 06, 2015 5:01 pm    Post subject: Reply with quote

The workaround described in comment 39 works. May a "xfce-base/exo" package update be relevant ?

Code:
$ equery b /usr/share/xfce4/helpers/firefox.desktop
 * Searching for /usr/share/xfce4/helpers/firefox.desktop ...
xfce-base/exo-0.10.2-r1 (/usr/share/xfce4/helpers/firefox.desktop)
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 516

PostPosted: Fri Mar 06, 2015 5:04 pm    Post subject: Reply with quote

CneGroumF wrote:
The workaround described in comment 39 works. May a "xfce-base/exo" package update be relevant ?

Code:
$ equery b /usr/share/xfce4/helpers/firefox.desktop
 * Searching for /usr/share/xfce4/helpers/firefox.desktop ...
xfce-base/exo-0.10.2-r1 (/usr/share/xfce4/helpers/firefox.desktop)


Yes, that modification seems to work. Maybe it should be pitched to Xfce upstream? The remote option (even though it will be re-added in 36.0.1) seems to have a sort-of deprecated status after all.
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 545
Location: France

PostPosted: Fri Mar 06, 2015 5:06 pm    Post subject: Reply with quote

haarp wrote:
Maybe it should be pitched to Xfce upstream?

Already done : https://bugzilla.xfce.org/show_bug.cgi?id=11601 :D
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 516

PostPosted: Fri Mar 06, 2015 5:12 pm    Post subject: Reply with quote

Sweet! Yeah, a bump is probably in order. I imagine other users are equally puzzled by this bug.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7894
Location: ~Brussels - Belgique

PostPosted: Fri Mar 06, 2015 7:21 pm    Post subject: Reply with quote

Yeah, I got that problem too, but I thought it was due to my mail client (claws-mail).

Finally, I changed the settings in my mail client, and I will watch the next release of xfce (hoping it will be the brand new 4.12 :8))
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Sat Mar 07, 2015 9:13 pm    Post subject: Reply with quote

xaviermiller wrote:
Yeah, I got that problem too, but I thought it was due to my mail client (claws-mail).

Finally, I changed the settings in my mail client, and I will watch the next release of xfce (hoping it will be the brand new 4.12 :8))


I'm waiting and syncing every day, since the new release has been announced, but its still not in the tree. :cry:
http://www.xfce.org/about/news/?post=1425081600


Hard delay for gentoo, compared to other DEs I'm using on other machines, that makes me really sad.
Lets hope there is a responsible mantainer for this packages still existent.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7894
Location: ~Brussels - Belgique

PostPosted: Sat Mar 07, 2015 9:21 pm    Post subject: Reply with quote

Randy Andy,

Watch bug 541962 then ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Mon Mar 09, 2015 4:46 pm    Post subject: Reply with quote

Hi Xavier,

on my yesterdays syncing, I've seen its coming into the tree.
So I start to compile it, tell the Box to fall in sleep afterwards, and went to bed by myself.

Today I found my box updated and running the new Xfce4 Version fine, as it should be, before reading your post now.
Nevertheless thanks for your hint and giving this additional reference info too.

Best regards, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum