Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
System not loading Centrino Adv-N 6200 wireless driver
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message

Joined: 12 Nov 2012
Posts: 32

PostPosted: Fri Mar 06, 2015 4:50 pm    Post subject: System not loading Centrino Adv-N 6200 wireless driver Reply with quote

I have a used Lenovo Thinkpad T410 laptop with Gentoo (kernel 3.19.0) installed. I had initially installed it with few problems, but for unrelated reasons ended up doing a reinstall of the the system from the stage3 tarball. Since the, it will load the Ethernet correctly but not the wireless drivers. Running lspci does show the wireless device (an Intel Centrino Advanced-N 6200), but does not show a loaded driver. Running lsmod shows no loaded modules, period. rfkill displays only the information about the Bluetooth subsystem.

I have the kernel set to load the iwlwifi driver as a module, but it does not seem to do so. In the original installation, I had used sys-firmware/linux-firmware and set the fallback firmware option in the kernel configuration, which seemed to work. I have tried this in te current installation, despite knowing that it is deprecated, but it did not work. I then tried setting the kernel to load the firmware blob from /lib/firmware (first I tried sys-firmware/linux-firmware, and when that didn't work, I replaced it with sys-firmware/iwl-6000-ucode), with no success.

The system is using systemd for initialization and device management, and loads initramfs via dracut. Both the netctl and wpa_supplicant services are enabled. I am using iproute2 and netctl for network management.



# Exact list of dracut modules to use.  Modules not listed here are not going
# to be included.  If you only want to add some optional modules use
# add_dracutmodules option instead.
dracutmodules+="kernel-modules udev-rules usrmount base systemd "
dracutmodules+="rootfs-block fs-lib fstab-sys plymouth shutdown "

# dracut modules to omit
omit_dracutmodules+="caps crypt dmraid mdraid "

# dracut modules to add to the default
add_dracutmodules+="bash i18n img-lib "

# additional kernel modules to the default
#add_drivers+=" "

# list of kernel filesystem modules to be included in the generic initramfs

# build initrd only to boot current hardware

# install local /etc/mdadm.conf

# install local /etc/lvm/lvm.conf

# A list of fsck tools to install. If it's not specified, module's hardcoded
# default is used, currently: "umount mount /sbin/fsck* xfs_db xfs_check
# xfs_repair e2fsck jfs_fsck reiserfsck btrfsck". The installation is
# opportunistic, so non-existing tools are just ignored.

# inhibit installation of any fsck tools

# mount / and /usr read-only by default

# set the directory for temporary files
# default: /var/tmp

add_device+="/dev/sda1 /dev/sda5 /dev/sda7 "

Please let me know what other details would be needed to help troubleshoot this issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum