Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with IR Input in X
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
laizzn
n00b
n00b


Joined: 24 Feb 2015
Posts: 24

PostPosted: Tue Feb 24, 2015 9:40 am    Post subject: Problems with IR Input in X Reply with quote

HI all,
Lately I am having weird issues with the IR remote control: When i first login (after reboot) in SLIM and start a Xfce or XBMC session the remote control does not work. However Xfce recognizes the IR device as an input device under Settings>Mouse & Touchpads. ALSO 'ir-keytable -t' shows all the key strokes with the corresponding binding (e.g. KEY_UP, KEY_DOWN,..) correctly!! But neither in Xfce nor XBMC the remote control does work...

BUT when I log out and log back in the remote control WORKS FINE AGAIN.

What is also weird is that the rc-rc6-mce module is not found even though it should be compiled into the kernel

Code:

 kernel: [    1.212126] IR keymap rc-rc6-mce not found

CONFIG_IR_RC6_DECODER=y
and
CONFIG_IR_MCEUSB=y


Log:
Code:
lbase slim: pam_unix(slim:session): session closed for user tv
Feb 23 23:14:17 lbase kernel: [  230.836552] nvidia 0000:01:00.0: irq 31 for MSI/MSI-X
Feb 23 23:14:18 lbase acpid: client 2623[0:0] has disconnected
Feb 23 23:14:18 lbase acpid: client connected from 3382[0:0]
Feb 23 23:14:18 lbase acpid: 1 client rule loaded
Feb 23 23:14:28 lbase slim: pam_unix(slim:session): session opened for user tv by (uid=0)
Feb 23 23:14:28 lbase slim: pam_ck_connector(slim:session): nox11 mode, ignoring PAM_TTY :0.0
Feb 23 23:14:32 lbase dbus[1886]: [system] Activating service name='org.freedesktop.UDisks2' (using servicehelper)
Feb 23 23:14:32 lbase udisksd[3487]: udisks daemon version 2.1.3 starting
Feb 23 23:14:32 lbase dbus[1886]: [system] Successfully activated service 'org.freedesktop.UDisks2'
Feb 23 23:14:32 lbase udisksd[3487]: Acquired the name org.freedesktop.UDisks2 on the system message bus
Feb 23 23:14:33 lbase polkitd[2501]: Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session2 (system bus name :1.29 [/usr/libexec/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)


I have no idea why that is happening.. !! For now i just log out and log in which fixes the problem..

BR
Back to top
View user's profile Send private message
rh
n00b
n00b


Joined: 19 Sep 2006
Posts: 57

PostPosted: Wed Mar 04, 2015 3:46 pm    Post subject: Reply with quote

I had the same issue. It turned out to be having ir-keytable loading after xserver start. For some reason X couldn't pick up the keys, unless xserver was restarted. Before updating the system it used to work, and I didn't find out which update broke it, since I have few more issues to look at.

Anyway, I worked around by moving my ir-keytable loading script from /etc/local.d to run earlier in boot process, so it's run before starting slim. Hope this helps.
Back to top
View user's profile Send private message
laizzn
n00b
n00b


Joined: 24 Feb 2015
Posts: 24

PostPosted: Tue Apr 07, 2015 6:20 pm    Post subject: Reply with quote

rh wrote:
I had the same issue. It turned out to be having ir-keytable loading after xserver start. For some reason X couldn't pick up the keys, unless xserver was restarted. Before updating the system it used to work, and I didn't find out which update broke it, since I have few more issues to look at.

Anyway, I worked around by moving my ir-keytable loading script from /etc/local.d to run earlier in boot process, so it's run before starting slim. Hope this helps.


Thank you!! that fixed my problem :) I finally got time to take care of it.

Not sure which broke it either.. I'm guessing... latest xf86-input-* (2.9.1) or xorg-server 1.16.4
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum