Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qtopengl - couldn't find glext.h
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 946
Location: Greece

PostPosted: Mon Feb 23, 2015 11:08 pm    Post subject: qtopengl - couldn't find glext.h Reply with quote

I get this weird error when trying to compile dev-qt/qtopengl-4.8.6-r1:
Code:
OpenGL auto-detection... ()
x86_64-pc-linux-gnu-g++ -c -pipe -march=core2 -msse4 -mcx16 -msahf -O2 -pipe -O2 -Wall -W  -I../../../../qt-everywhere-opensource-src-4.8.6/mkspecs/linux-g++ -I../../../../qt-everywhere-opensource-src-4.8.6/config.tests/x11/opengl -I/usr/X11R6/include -I/usr/X11R6/include -I../../../../qt-everywhere-opensource-src-4.8.6/config.tests/x11/opengl -I. -o opengl.o ../../../../qt-everywhere-opensource-src-4.8.6/config.tests/x11/opengl/opengl.cpp
In file included from ../../../../qt-everywhere-opensource-src-4.8.6/config.tests/x11/opengl/opengl.cpp:42:0:
/usr/include/GL/gl.h:2055:22: fatal error: GL/glext.h: No such file or directory
 #include <GL/glext.h>
                      ^
compilation terminated.
Makefile:190: recipe for target 'opengl.o' failed
gmake: *** [opengl.o] Error 1
OpenGL disabled.
OpenGL ES 2.x auto-detection... ()
x86_64-pc-linux-gnu-g++ -c -pipe -march=core2 -msse4 -mcx16 -msahf -O2 -pipe -O2 -Wall -W  -I../../../../qt-everywhere-opensource-src-4.8.6/mkspecs/linux-g++ -I../../../../qt-everywhere-opensource-src-4.8.6/config.tests/unix/opengles2 -I/usr/X11R6/include -I../../../../qt-everywhere-opensource-src-4.8.6/config.tests/unix/opengles2 -I. -o opengles2.o ../../../../qt-everywhere-opensource-src-4.8.6/config.tests/unix/opengles2/opengles2.cpp
../../../../qt-everywhere-opensource-src-4.8.6/config.tests/unix/opengles2/opengles2.cpp:45:25: fatal error: GLES2/gl2.h: No such file or directory
   #include <GLES2/gl2.h>
                         ^
compilation terminated.
Makefile:181: recipe for target 'opengles2.o' failed
gmake: *** [opengles2.o] Error 1
OpenGL ES 2.x disabled.
OpenGL ES 1.x auto-detection... ()
x86_64-pc-linux-gnu-g++ -c -pipe -march=core2 -msse4 -mcx16 -msahf -O2 -pipe -O2 -Wall -W  -I../../../../qt-everywhere-opensource-src-4.8.6/mkspecs/linux-g++ -I../../../../qt-everywhere-opensource-src-4.8.6/config.tests/unix/opengles1 -I/usr/X11R6/include -I../../../../qt-everywhere-opensource-src-4.8.6/config.tests/unix/opengles1 -I. -o opengles1.o ../../../../qt-everywhere-opensource-src-4.8.6/config.tests/unix/opengles1/opengles1.cpp
../../../../qt-everywhere-opensource-src-4.8.6/config.tests/unix/opengles1/opengles1.cpp:45:23: fatal error: GLES/gl.h: No such file or directory
   #include <GLES/gl.h>
                       ^
compilation terminated.
Makefile:181: recipe for target 'opengles1.o' failed
gmake: *** [opengles1.o] Error 1
OpenGL ES 1.x disabled.
All the OpenGL functionality tests failed!
 You might need to modify the include and library search paths by editing
 QMAKE_INCDIR_OPENGL, QMAKE_LIBDIR_OPENGL and QMAKE_LIBS_OPENGL in
 /var/tmp/portage/dev-qt/qtopengl-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/mkspecs/linux-g++.

I have the feeling that I shouldn't need to manually modify those files. glext.h is in the same directory as gl.h actually. Also, earlier in the build process it says:
Code:
PulseAudio auto-detection... ()
x86_64-pc-linux-gnu-g++ -c -pipe -D_REENTRANT -march=core2 -msse4 -mcx16 -msahf -O2 -pipe -O2 -Wall -W  -I../../../../qt-everywhere-opensource-src-4.8.6/mkspecs/linux-g++ -I../../../../qt-everywhere-opensource-src-4.8.6/config.tests/unix/pulseaudio -I/usr/include/glib-2.0 -I/usr/lib32/glib-2.0/include -I../../../../qt-everywhere-opensource-src-4.8.6/config.tests/unix/pulseaudio -I. -o pulseaudio.o ../../../../qt-everywhere-opensource-src-4.8.6/config.tests/unix/pulseaudio/pulseaudio.cpp
x86_64-pc-linux-gnu-g++ -Wl,-O1 -Wl,--as-needed -Wl,-O1 -o pulseaudio pulseaudio.o     -L/usr/lib32 -lpulse-mainloop-glib -lpulse -lglib-2.0
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib32/libpulse-mainloop-glib.so when searching for -lpulse-mainloop-glib
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib32/libpulse.so when searching for -lpulse
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib32/libglib-2.0.so when searching for -lglib-2.0
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib32/libm.so when searching for -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib32/libm.a when searching for -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib32/libc.so when searching for -lc
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib32/libc.a when searching for -lc
PulseAudio enabled.

when pulseaudio is actually disabled via USE flag (the library is installed because sometimes I test some things with it). Shouldn't the ebuild follow that?

Here is my emerge --info
http://pastebin.com/eEKEfDc4

Thanks in advance!
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
Kyeno
n00b
n00b


Joined: 17 Feb 2011
Posts: 27
Location: PL

PostPosted: Sat Apr 15, 2017 10:58 am    Post subject: Reply with quote

Hey,
Did you manage to solve this problem? I just ran into it and this post was the best I was able to google out.
My only solution for now was
Code:
-qt4 qt5
in global make.conf,
Code:
dev-qt/qtopengl-4.8.6-r1
in package.mask and
Code:
>=dev-libs/libdbusmenu-qt-0.9.3_pre20160218 qt4
in package.use, but it seems quite lame though...
Back to top
View user's profile Send private message
Kyeno
n00b
n00b


Joined: 17 Feb 2011
Posts: 27
Location: PL

PostPosted: Sat Apr 15, 2017 11:30 am    Post subject: Reply with quote

OKay, there's probably a good answer https://forums.gentoo.org/viewtopic-t-1034406-start-0.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum