Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Blocked pakcages dev/qtchooser. Kde-plasma install.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sapnesh
n00b
n00b


Joined: 17 Feb 2015
Posts: 14
Location: India

PostPosted: Sat Feb 21, 2015 12:52 pm    Post subject: [SOLVED] Blocked pakcages dev/qtchooser. Kde-plasma install. Reply with quote

Hello guys
I tried intsalling kde-frameworks and plasma by following the kde/overlay guide(linked keywords accepted configs during install,which modified my pakcage.use)
but i get this during the install
Code:

These are the packages that would be merged, in order:

Calculating dependencies  ... done!
[ebuild  N     ] dev-qt/qtcore-4.8.5-r2:4  USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch" 0 KiB
[ebuild  N     ] dev-qt/qtscript-4.8.5:4  USE="exceptions iconv jit (-aqua) -debug -pch" 0 KiB
[ebuild  N     ] dev-qt/qtgui-4.8.5-r3:4  USE="accessibility cups exceptions glib mng qt3support tiff xinerama xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace" 0 KiB
[ebuild  N     ] dev-qt/qtsvg-4.8.5:4  USE="accessibility exceptions (-aqua) -debug -pch" 0 KiB
[ebuild  N     ] dev-qt/qttest-4.8.5:4  USE="exceptions (-aqua) -debug -pch" 0 KiB
[ebuild  N     ] dev-qt/qtxmlpatterns-4.8.5:4  USE="(-aqua) -debug -pch" 0 KiB
[ebuild  N     ] dev-qt/qtwebkit-4.8.5:4  USE="exceptions gstreamer jit (-aqua) -debug -icu -pch" 0 KiB
[ebuild  N     ] dev-qt/qtsql-4.8.5:4  USE="exceptions mysql qt3support sqlite (-aqua) -debug (-firebird) -freetds -oci8 -odbc -pch -postgres" 0 KiB
[ebuild  N     ] dev-qt/qt3support-4.8.5:4  USE="accessibility exceptions (-aqua) -debug -pch" 0 KiB
[ebuild  N     ] dev-qt/qtdbus-4.8.5:4  USE="exceptions (-aqua) -debug -pch" 0 KiB
[ebuild  N     ] dev-qt/qtopengl-4.8.5:4  USE="exceptions qt3support (-aqua) -debug -egl -pch" 0 KiB
[ebuild  N     ] dev-qt/qtdeclarative-4.8.5:4  USE="accessibility exceptions qt3support (-aqua) -debug -pch -webkit" 0 KiB
[ebuild  N     ] dev-qt/designer-4.8.5:4  USE="declarative exceptions qt3support (-aqua) -debug -pch (-phonon) -webkit" 0 KiB
[ebuild     U  ] sys-apps/openrc-0.13.11 [0.13.9] USE="ncurses netifrc pam unicode -debug -newnet (-prefix) (-selinux) -static-libs -tools" 148 KiB
[blocks B      ] <dev-qt/qtsvg-4.8.6:4 ("<dev-qt/qtsvg-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtscript-4.8.6:4 ("<dev-qt/qtscript-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtwebkit-4.8.6:4 ("<dev-qt/qtwebkit-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtxmlpatterns-4.8.6:4 ("<dev-qt/qtxmlpatterns-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtdbus-4.8.6:4 ("<dev-qt/qtdbus-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qttest-4.8.6:4 ("<dev-qt/qttest-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/designer-4.8.6:4 ("<dev-qt/designer-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtdeclarative-4.8.6:4 ("<dev-qt/qtdeclarative-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qt3support-4.8.6:4 ("<dev-qt/qt3support-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtopengl-4.8.6:4 ("<dev-qt/qtopengl-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtcore-4.8.6:4 ("<dev-qt/qtcore-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtsql-4.8.6:4 ("<dev-qt/qtsql-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtgui-4.8.6:4 ("<dev-qt/qtgui-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)

Total: 14 packages (1 upgrade, 13 new), Size of downloads: 148 KiB
Conflict: 13 blocks (13 unsatisfied)

so i tried unmerging all the 13 packages and tried installing frameworks again but it gave the same error!.
So i tried updating my system using
Code:
 emerge -uDav

but it failed with the same error.
So i tried deleting all keyword links in /etc/portage/package.accept_keywords and resetting my package.use.
But I still have the same error.
Code:
 -uDav,revdep-rebuild,@preserved-rebuild
all throw the same error.
These are my USE flags :
Code:
USE='' qt5 kde bindist mmx sse sse2 -gnome -gtk -ipv6''
CPU_FLAGS_X86='' bindist avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3 qt4 qt5 kde dvd alsa cdr X samba bzip2 java wifi audiofile''

This is my first gentoo install so I don't have any DE/DM yet and I want to install Plasma5.
Please help!
_________________
I solemnly swear that I am upto no good.


Last edited by sapnesh on Sun Feb 22, 2015 9:29 am; edited 2 times in total
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Sat Feb 21, 2015 1:12 pm    Post subject: Re: Blocked pakcages dev/qtchooser. Kde-plasma install. Reply with quote

sapnesh wrote:
These are my USE flags :
Code:
USE='' qt5 kde bindist mmx sse sse2 -gnome -gtk -ipv6''
CPU_FLAGS_X86='' bindist avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3 qt4 qt5 kde dvd alsa cdr X samba bzip2 java wifi audiofile''

That's all messed-up. It should read something like this:
Code:
USE="qt5 kde bindist mmx sse sse2 -gnome -gtk -ipv6
  qt4 dvd alsa cdr X samba bzip2 java wifi audiofile"
CPU_FLAGS_X86="avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"

Note: you were using doubled single-quotes, instead of " -- you can use either form, but you don't want to close the quotes before the string data.

I'm not that clued-up on the newer CPU_FLAGS_X86 (I actually think it's horrible) but those are all x86-related.

ISTR you need them in USE too for a while, but I'll let someone else comment on that (or you can sort it out;)

FTR, we normally use ufed when we first install (well, most everyone I know.)

Here's some tips you might find useful.
Back to top
View user's profile Send private message
sapnesh
n00b
n00b


Joined: 17 Feb 2015
Posts: 14
Location: India

PostPosted: Sat Feb 21, 2015 1:30 pm    Post subject: Reply with quote

Ok. I thought CPU_FLAGS_x86 was meant to replace USE when i read the news element. Thats why I've been adding new USEs to x86 and if anything needs decrementing I add it to USE as x86 doesnt support decremental use flags. And im not using doubled single quotes,I just typed it here.
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Sat Feb 21, 2015 2:31 pm    Post subject: Reply with quote

OK well a rule we have in #awk is: "fake data gets you fake answers" ;)
Back to top
View user's profile Send private message
sapnesh
n00b
n00b


Joined: 17 Feb 2015
Posts: 14
Location: India

PostPosted: Sat Feb 21, 2015 2:39 pm    Post subject: Reply with quote

steveL wrote:
OK well a rule we have in #awk is: "fake data gets you fake answers" ;)

If you're talking about the single quotes then I'm sorry for that. Its kinda tough here coz Im currently on a not so good Symbian mobile( I dont have anyother means to post and ofcourse I haven't a GUI on my laptop).
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Sat Feb 21, 2015 3:50 pm    Post subject: Reply with quote

Ah OK, fair enough. Well, so long as your USE is sorted, post any new error message.
Back to top
View user's profile Send private message
sapnesh
n00b
n00b


Joined: 17 Feb 2015
Posts: 14
Location: India

PostPosted: Sat Feb 21, 2015 4:17 pm    Post subject: Reply with quote

I sorted out the USE flags and did
Code:
emerge --update --newuse --with-bdeps=y --deep @world

and I still get the same error. I've set up X and other tools with the previous use flags setup and havnt had any package blocks like this. This is happened ever since I linked kde-frameworks and plasma keyword files from
Code:
/var/lib/layman/kde/Documentation/package.keywords
to
Code:
/etc/portage/package.accept_keywords
while follwing kde/overlay guide.I also accepted configuration changes to package.use file and as I've mentioned above I've tried deleting all the links in
Code:
/etc/portage/package.accept_keywords
and resetting my package.use to as it was before and that hasn't solved the problem.
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Sun Feb 22, 2015 3:31 am    Post subject: Reply with quote

Try keywording dev-qt/*-4.8.6 too. Lower versions are indirectly blocked by qt5.
Back to top
View user's profile Send private message
sapnesh
n00b
n00b


Joined: 17 Feb 2015
Posts: 14
Location: India

PostPosted: Sun Feb 22, 2015 9:27 am    Post subject: Reply with quote

I solved the problem. It seemed like kde-base was pulling in most of the packages which were causing blocks.(I think kde base was pulled in by some app coz I've had kde use flag from as soon as I set up gentoo)
I did
Code:
emerge --unmerge --ask kde-base/*

and then I did
Code:
emerge @preserved-rebuild

(took a long time!) and after that
Code:
emerge --update --changed-use --with-bdeps=y --deep @world

and it finished without any errors.
I think I'l install kdebase-meta now and wait for Plasma 5 to get stable.
Thank You steveL and kensington.
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Sun Feb 22, 2015 11:35 am    Post subject: Reply with quote

You're welcome; glad it got sorted.

Please do check out the maintenance basics.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum