Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]characters messed up in firefox, thunderbird, office
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
freifunk_connewitz
Apprentice
Apprentice


Joined: 08 Feb 2006
Posts: 192

PostPosted: Fri Feb 20, 2015 4:38 pm    Post subject: [SOLVED]characters messed up in firefox, thunderbird, office Reply with quote

hi,

for those of you that run into the same problem: I made a world update yesterday where libreoffice, xorg-server, many x11-libs, mesa and other stuff got updated. after boot today and some minutes of working suddenly thunderbird started to show a strange GUI: missing menu and folder text that reappeared after mouse-over, changed colors after mouseover, and after restarting it all menu titles/entries and notifications went completely mad: randomly missing characters, chars half above the line. the same in firefox, which BTW displayed websites correctly. same problem in libreoffice and openoffice, where also the displayed document went completely unreadable: chars missing or replaced by black boxes.

restarting programs and X session didnt help.

since I wondered if it's font problem, I had a look at my installed fonts:
Code:
eix -I font

and there I saw an "U" for update marked for dev-java/fontbox

that update was NOT pulled in by
Code:
emerge -uaDvN world
(I issued that again, got "nothing to merge")

so I manually updated fontbox which installed version 1.7.1 in a new slot beside the existing 0.1.0.

logout-login: all the programs work again.

is that a problem with update dependencies of fontbox or any of the affected programs? however, I hope this helps anybody with the same problem.

PS.: all KDE applications and opera were not affected.


Last edited by freifunk_connewitz on Sat Feb 21, 2015 12:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
freifunk_connewitz
Apprentice
Apprentice


Joined: 08 Feb 2006
Posts: 192

PostPosted: Fri Feb 20, 2015 5:09 pm    Post subject: Reply with quote

edit: this is not completely solved. after half an hour working, thunderbird starts to misbehave again: grey fields that get not redrawn where there is no active field like a menu in it.
BUT because the character problem has gone: marking solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum