Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(Solv) OpenGL-programs with dark backgroun black after upgr.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
runem
n00b
n00b


Joined: 08 Sep 2006
Posts: 39

PostPosted: Fri Feb 20, 2015 3:31 pm    Post subject: (Solv) OpenGL-programs with dark backgroun black after upgr. Reply with quote

Hi

After a recent upgrade of X/Mesa/drivers I have trouble with OpenGl-programs with dark background running in full screen mode. If the picture is too dark then the entire screen will fade to black.
A simple testcase is to start sci-astronomy/celestia and zoom to a star a long way off. While zooming the screen will go dark as if switched off until the selected start comes into view.
With Flightgear the problem is that if you start at an airport with little light at night hen the menus will fade and the only workaround to get them back for short while was to switch o another program and back.

There seems to be some kind of "auto-dim" at play. If I maximize a terminal window with black background then the frame and menubar fades but not to the point that it is unusable.

Currently I have these versions installed:

x11-drivers/nvidia-drivers-346.35
media-libs/mesa-10.3.7-r1
x11-base/xorg-server-1.16.4:0/1.16.1
xfce-base/xfce4-meta-4.10 <-- Not updated tis time around

Is there a way to turn off the "fade to black" feature ?
If yes, how?

What other kind of info should I post?

Kind regards Rune


Last edited by runem on Sat Feb 21, 2015 10:53 am; edited 1 time in total
Back to top
View user's profile Send private message
runem
n00b
n00b


Joined: 08 Sep 2006
Posts: 39

PostPosted: Sat Feb 21, 2015 10:50 am    Post subject: OpenGL-programs with dark backgroun goes black after upgrade Reply with quote

OK. It turned out not to be a software issue. My not so user friendly monitor has a "magic power save" option witch causes almost black images to fade even further.
I seem to have managed to turn it off again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum