Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cursor suddenly changed while running X, won't go back
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
entropicaccess
n00b
n00b


Joined: 27 Jun 2003
Posts: 8
Location: Second star to the right, and straight on 'till morning

PostPosted: Thu Oct 30, 2003 3:31 am    Post subject: Cursor suddenly changed while running X, won't go back Reply with quote

Very randomly my root cursor changed from the nice default to something that looks like it crawled out from a bad Star Trek knock off (image). I have no clue how to change it back, fully. I've tried xsetroot -cursor left_ptr left_ptrmask, but that only changes the root cursor, nothing else. I've also looked into /usr/share/cursors/xfree to no avail, along with playing with (and creating for the first time) ~/.Xdefaults. I even tried shuting down on the chance that something got borked in the video card's memory. I am totally out of ideas, so any help would be welcome.
_________________
"The greatest dangers to liberty lurk in insidious encroachment by men of zeal, well-meaning but without understanding."
-- Justice Louis O. Brandeis (Olmstead vs. United States)
Lead developer, RTLAD Dryad
Back to top
View user's profile Send private message
meowsqueak
Veteran
Veteran


Joined: 26 Aug 2003
Posts: 1549
Location: New Zealand

PostPosted: Thu Oct 30, 2003 3:40 am    Post subject: Reply with quote

I've had this problem on older nvidia hardware - usually when messing around with dual head and GLX. Are you doing anything unusual with your set-up?

[EDIT - DISREGARD THIS]


Last edited by meowsqueak on Thu Oct 30, 2003 3:41 am; edited 1 time in total
Back to top
View user's profile Send private message
meowsqueak
Veteran
Veteran


Joined: 26 Aug 2003
Posts: 1549
Location: New Zealand

PostPosted: Thu Oct 30, 2003 3:40 am    Post subject: Reply with quote

Oh, THAT! I just looked at the image. That's an artwiz cursor. I enabled that (since I use it and like it) by putting this line:

/usr/share/fonts/artwiz:unscaled,

in /etc/X11/fs/config near the top.
Back to top
View user's profile Send private message
entropicaccess
n00b
n00b


Joined: 27 Jun 2003
Posts: 8
Location: Second star to the right, and straight on 'till morning

PostPosted: Thu Oct 30, 2003 3:46 am    Post subject: Reply with quote

Well I'll be... removing the artwiz fonts from my font path did the trick. Thanks meowsqueak!
What I don't get is why it took about three days for the change to take effect... *shrugs* silly X...
_________________
"The greatest dangers to liberty lurk in insidious encroachment by men of zeal, well-meaning but without understanding."
-- Justice Louis O. Brandeis (Olmstead vs. United States)
Lead developer, RTLAD Dryad
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum