Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem setting up pxe server[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun Feb 15, 2015 7:28 pm    Post subject: problem setting up pxe server[solved] Reply with quote

I'm having problems when trying to configure a pxe server
I have configured the dhcp server (dhcp package):

dhcpd.conf:
ddns-update-style none;

subnet 10.0.0.0 netmask 255.0.0.0 {
#match if substring(option vendor-class-identifier, 0, 9) = "PXEClient";
range 10.0.0.100 10.0.0.150;
vendor-option-space PXE;
#option PXE.mtftp-ip 0.0.0.0;
#filename "/pxelinux.0";
#next-server 10.0.0.2 ;
}
subnet 192.168.122.0 netmask 255.255.255.0 {
range 192.168.122.2 192.168.122.3 ;
}
allow booting;
allow bootp;
option option-128 code 128 = string;
option option-129 code 129 = text;
filename "/pxelinux.0:";
next-server 192.168.122.1 ;

hpa tftp
/etc/conf.d/in.tftpd:
INTFTPD_PATH="/media/pxe"
INTFTPD_USER="nobody"
INTFTPD_OPTS="-u ${INTFTPD_USER} -l -vvvvvv -p -c -s ${INTFTPD_PATH}"

copied the pxelinux.0 file to /media/pxe, created pxelinux.cfg directory, default file
default:
DEFAULT /kernel
APPEND ip=dhcp

when I boot the client I get the following erro:
filename: /pxelinux.0:
nothing to boot: no such file or directory
I have connected to the tftp server and was able to get the file from the tftp root, I have activated the tftpd socket

I'm new to PXE configuration so excuse any beginner mistakes

thanks


Last edited by Adel Ahmed on Sun Feb 15, 2015 10:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13509

PostPosted: Sun Feb 15, 2015 7:44 pm    Post subject: Reply with quote

You have a literal colon in your quoted string for the DHCP options and in your error message. You say you copied pxelinux.0 to /media/pxe, but not whether you changed its name to include the trailing colon. You say you checked that the file is fetchable, but not whether you included the colon in your test fetch. I suggest removing the literal colon and trying again.
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun Feb 15, 2015 10:25 pm    Post subject: Reply with quote

yikes, I had a feeling I was doing something stupid, just not THAT stupid :D


thanks removing the colon fixed things, I did not inted to place that colon there
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum