Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
urxvt cannot work properly
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
stephan-t
Tux's lil' helper
Tux's lil' helper


Joined: 12 May 2014
Posts: 118

PostPosted: Sun Feb 15, 2015 1:07 pm    Post subject: urxvt cannot work properly Reply with quote

After i update whole system with emerge -ave world urxvt terminal cannot work as well.

Video demonstration

What i'm doing?
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Feb 15, 2015 1:32 pm    Post subject: Re: urxvt cannot work properly Reply with quote

stephan-t wrote:
After i update whole system with emerge -ave world urxvt terminal cannot work as well.

stephan-t ... did that update happen to include dev-lang/perl? If so, did you run 'perl-cleaner --all' subsequently?

best ... khay
Back to top
View user's profile Send private message
stephan-t
Tux's lil' helper
Tux's lil' helper


Joined: 12 May 2014
Posts: 118

PostPosted: Sun Feb 15, 2015 2:14 pm    Post subject: Re: urxvt cannot work properly Reply with quote

khayyam wrote:
stephan-t wrote:
After i update whole system with emerge -ave world urxvt terminal cannot work as well.

stephan-t ... did that update happen to include dev-lang/perl? If so, did you run 'perl-cleaner --all' subsequently?

best ... khay


Code:

Can't open machine/ansi.h: No such file or directory
Can't open sys/_types.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Feb 15, 2015 2:28 pm    Post subject: Re: urxvt cannot work properly Reply with quote

stephan-t wrote:
khayyam wrote:
stephan-t wrote:
After i update whole system with emerge -ave world urxvt terminal cannot work as well.

stephan-t ... did that update happen to include dev-lang/perl? If so, did you run 'perl-cleaner --all' subsequently?

Code:
Can't open machine/ansi.h: No such file or directory
[...]

stephan-t ... this doesn't give me any kind of idea of what your problem is, so rather than provide videos, or contextless errors, explain the problem.

best ... khay
Back to top
View user's profile Send private message
stephan-t
Tux's lil' helper
Tux's lil' helper


Joined: 12 May 2014
Posts: 118

PostPosted: Sun Feb 15, 2015 2:41 pm    Post subject: Reply with quote

@khayyam

I cannot use regular commands in terminal and cannot open my favorite applications like command-like interfaces: ranger,ncmpcpp,htop,mc etc. or doesn't type correctly, because i hit backspace leap characters like hitting many space.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Feb 15, 2015 2:50 pm    Post subject: Reply with quote

stephan-t wrote:
I cannot use regular commands in terminal and cannot open my favorite applications like command-like interfaces: ranger,ncmpcpp,htop,mc etc. or doesn't type correctly, because i hit backspace leap characters like hitting many space.

stephan-t ... ok, urxvt isn't functioning ... but you can access a console and see the errors urxvt is writing to tty1, and get a shell in tty2 and so be able to see why that might be the case and fix it (ie running 'perlcleaner --all' ... if that is indeed the issue ... hard to tell from the above), or provide information for me to go on (like 'emerge --info', the packages updated, etc).

best ... khay
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sun Feb 15, 2015 2:54 pm    Post subject: Reply with quote

If rxvt doesn't work, use xterm.

If you haven't xterm, use control+alt+f1 and user pure VT.

If that doesn't work, your system is completely broken and you should be using a livecd to chroot and fix whatever needs fixing there.

In any case, a couple of things you can try is re-emerging terminfo (useful if you broke stuff in /etc/terminfo) and try to use something plain such as "rxvt-unicode" or "xterm" as your $TERM (or some other that's listed when you do "ls -ls /etc/terminfo/*").

I see you are using TERM=urxvt-256color or something like that. I've never seen that, and it certainly is not under my /etc/terminfo, so double check that.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5912

PostPosted: Sun Feb 15, 2015 5:04 pm    Post subject: Re: urxvt cannot work properly Reply with quote

stephan-t wrote:
Code:

Can't open machine/ansi.h: No such file or directory
Can't open sys/_types.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory

Can you confirm that this was the line immediately above those:
Code:
 * Ignore all "No such file..." messages!
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sun Feb 15, 2015 5:09 pm    Post subject: Reply with quote

Yeah, that can be solved by reading the output :lol: his problem has nothing to do with that, though. His problem is that he has an incorrect $TERM that can't be found. That's my guess, anyway.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5912

PostPosted: Sun Feb 15, 2015 6:01 pm    Post subject: Reply with quote

You're probably right; mine uses TERM=rxvt-unicode-256color and I've had no problems with it.
Back to top
View user's profile Send private message
stephan-t
Tux's lil' helper
Tux's lil' helper


Joined: 12 May 2014
Posts: 118

PostPosted: Mon Feb 16, 2015 8:32 pm    Post subject: Reply with quote

The status not changed urxvt totally crap. I tried the stable end development version, instead of perl or urxvt-perl packages.

Probably try the another terminal emulator this time.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum