Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] evdev - waiting for uevents to be processed
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
DeszczyK
n00b
n00b


Joined: 13 Sep 2006
Posts: 64
Location: GDYNIA

PostPosted: Sun Feb 15, 2015 12:31 pm    Post subject: [SOLVED] evdev - waiting for uevents to be processed Reply with quote

Witam,

trochę tu pusto ostatnio. Dawnymi czasy dziennie min. naście postów przybywało. Any way - mam problem. Podczas uruchamiania Gentoo na takim jak w temacie komunikacie system się zatrzymuje.
Ale od początku. Postawiłem świeżą instalkę, zainstalowałem Xy - podniosły się, zainstalowałem kde - podniósł się kdm, ale nie działały mysz i klawiatura. Zacząłem rozkminiać z evdev i gdzieś natrafiłem na instrukcję, by usunąć udev z sysinit, przekompilować je i dodać na powrót.

Potem podczas startu systemu zaczęło się pojawiać:
Code:
waiting for uevents to be processed
.

Sprawdziłem czy wszystko z udev w porządku i zgodnie z podręcznikiem na http://wiki.gentoo.org/wiki/Udev - wszystko ok. Dodałem do "make.conf" firmware-loader, introspection, kmod (brakowało), potem
Code:
emerge @world -uDUva


Nic.
Potem sprawdziłem poprawność instalacji X wg poradnika na http://wiki.gentoo.org/wiki/Xorg/Configuration.
Następnie to samo z instalacją sterowników zgodnie z http://wiki.gentoo.org/wiki/NVidia/nvidia-drivers.
Też wszystko OK.

Szukam, szukam i nie mogę rozkminić. Niby wszystko ok, ale udev się zacina podczas startu systemu, jak i podczas ręcznego uruchamiania. Dodam, że nie startują mi teraz X'y.

Niżej zapodaję emerge --info i log startu X'ów.
Pytajcie, co potrzeba, to podeślę. Sam nie poradzę.

emerge --info:
Code:
Tredstone71 / # emerge --info
Portage 2.2.14 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.19-r1, 3.13.0-35-generic x86_64)
=================================================================
System uname: Linux-3.13.0-35-generic-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E6550_@_2.33GHz-with-gentoo-2.2
KiB Mem:     2049436 total,     84648 free
KiB Swap:    3170300 total,   2717812 free
Timestamp of tree: Sat, 14 Feb 2015 12:30:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9-r1, 3.3.5-r1, 3.4.1
dev-util/ccache:          3.1.9-r4
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.9
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.7.3-r1, 4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.4
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo enlightenment-niifaq
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="pl_PL.utf8"
LC_ALL="pl_PL"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/enlightenment-niifaq"
USE="X a52 aac acl acpi aiglx alsa amd64 amr apache2 ape asf audio berkdb branding bzip2 cairo calendar cdda cddb cdr cli consolekit cracklib crypt cups curl cxx dbus declarative dga dri dts dvb dvd dvdr dvdread egl emboss encode exif fam ffmpeg firefox firmware-loader flac fortran gdbm gif glamor glitz gpm gtk3 hal iconv imagemagick introspection ipv6 java jpeg kde kipi kmod lcms libav libnotify libwww lirc mad matroska midi mmx mng modules mp3 mp4 mpeg multilib musepack mysql mysqli ncurses nls nptl nptl_only nsplugin ntfs nvidia ogg opengl openmp openrc pam pango pcre pdf phonon plasma png policykit posix ppds pulseaudio python qt qt3support qt4 readline real sdl semantic-desktop session skins spell sse sse2 ssl startup-notification stream svg tcpd theora threads tiff truetype udev udisks unicode upower usb v4l v4l2 vcd vorbis win32codecs wxwidgets x264 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ABI_X86="64" ALSA_CARDS="ca0106" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON


/var/log/Xorg.0.log:
Code:
Tredstone71 / # cat /var/log/Xorg.0.log
[    10.730]
X.Org X Server 1.15.2
Release Date: 2014-06-27
[    10.730] X Protocol Version 11, Revision 0
[    10.730] Build Operating System: Linux 3.13.0-35-generic x86_64 Gentoo
[    10.730] Current Operating System: Linux localhost 3.12.21-gentoo-r1 #10 SMP Sat Feb 14 13:00:19 CET 2015 x86_64
[    10.730] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.12.21-gentoo-r1 root=UUID=a3e9a1c6-5249-4244-b0fa-33e203f8fab9 ro splash quiet
[    10.730] Build Date: 13 February 2015  09:41:02PM
[    10.730] 
[    10.730] Current version of pixman: 0.32.4
[    10.730]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    10.730] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    10.730] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 14 14:09:21 2015
[    10.749] (==) Using config file: "/etc/X11/xorg.conf"
[    10.749] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    10.749] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    10.752] (==) ServerLayout "X.org Configured"
[    10.752] (**) |-->Screen "Screen0" (0)
[    10.752] (**) |   |-->Monitor "Monitor0"
[    10.752] (**) |   |-->Device "Card0"
[    10.752] (**) |-->Input Device "Mouse0"
[    10.753] (**) |-->Input Device "Keyboard0"
[    10.753] (==) Automatically adding devices
[    10.753] (==) Automatically enabling devices
[    10.753] (==) Automatically adding GPU devices
[    10.753] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[    10.753]    Entry deleted from font path.
[    10.753] (**) FontPath set to:

[    10.753] (**) ModulePath set to "/usr/lib64/xorg/modules"
[    10.753] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    10.753] (WW) Disabling Mouse0
[    10.753] (WW) Disabling Keyboard0
[    10.753] (II) Loader magic: 0x803c60
[    10.753] (II) Module ABI versions:
[    10.753]    X.Org ANSI C Emulation: 0.4
[    10.753]    X.Org Video Driver: 15.0
[    10.753]    X.Org XInput driver : 20.0
[    10.753]    X.Org Server Extension : 8.0
[    10.755] (--) PCI:*(0:1:0:0) 10de:0402:1462:0910 rev 161, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000bc00/128, BIOS @ 0x????????/131072
[    10.756] Initializing built-in extension Generic Event Extension
[    10.756] Initializing built-in extension SHAPE
[    10.756] Initializing built-in extension MIT-SHM
[    10.756] Initializing built-in extension XInputExtension
[    10.756] Initializing built-in extension XTEST
[    10.756] Initializing built-in extension BIG-REQUESTS
[    10.756] Initializing built-in extension SYNC
[    10.756] Initializing built-in extension XKEYBOARD
[    10.756] Initializing built-in extension XC-MISC
[    10.756] Initializing built-in extension XINERAMA
[    10.756] Initializing built-in extension XFIXES
[    10.756] Initializing built-in extension RENDER
[    10.756] Initializing built-in extension RANDR
[    10.756] Initializing built-in extension COMPOSITE
[    10.756] Initializing built-in extension DAMAGE
[    10.756] Initializing built-in extension MIT-SCREEN-SAVER
[    10.756] Initializing built-in extension DOUBLE-BUFFER
[    10.756] Initializing built-in extension RECORD
[    10.756] Initializing built-in extension DPMS
[    10.756] Initializing built-in extension Present
[    10.756] Initializing built-in extension DRI3
[    10.756] Initializing built-in extension X-Resource
[    10.756] Initializing built-in extension XVideo
[    10.756] Initializing built-in extension XVideo-MotionCompensation
[    10.756] Initializing built-in extension XFree86-VidModeExtension
[    10.756] Initializing built-in extension XFree86-DGA
[    10.756] Initializing built-in extension XFree86-DRI
[    10.756] Initializing built-in extension DRI2
[    10.756] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    10.756] (II) LoadModule: "glx"
[    10.766] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    10.870] (II) Module glx: vendor="NVIDIA Corporation"
[    10.870]    compiled for 4.0.2, module version = 1.0.0
[    10.870]    Module class: X.Org Server Extension
[    10.872] (II) NVIDIA GLX Module  346.35  Sat Jan 10 20:53:39 PST 2015
[    10.872] Loading extension GLX
[    10.872] (II) LoadModule: "nvidia"
[    10.874] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    10.919] (II) Module nvidia: vendor="NVIDIA Corporation"
[    10.919]    compiled for 4.0.2, module version = 1.0.0
[    10.919]    Module class: X.Org Video Driver
[    10.936] (II) NVIDIA dlloader X Driver  346.35  Sat Jan 10 20:32:18 PST 2015
[    10.936] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    10.936] (++) using VT number 7

[    10.945] (II) Loading sub module "fb"
[    10.945] (II) LoadModule: "fb"
[    10.945] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    10.951] (II) Module fb: vendor="X.Org Foundation"
[    10.951]    compiled for 1.15.2, module version = 1.0.0
[    10.951]    ABI class: X.Org ANSI C Emulation, version 0.4
[    10.951] (II) Loading sub module "wfb"
[    10.951] (II) LoadModule: "wfb"
[    10.951] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    10.956] (II) Module wfb: vendor="X.Org Foundation"
[    10.956]    compiled for 1.15.2, module version = 1.0.0
[    10.956]    ABI class: X.Org ANSI C Emulation, version 0.4
[    10.956] (II) Loading sub module "ramdac"
[    10.956] (II) LoadModule: "ramdac"
[    10.956] (II) Module "ramdac" already built-in
[    10.958] (WW) NVIDIA(0): The NVIDIA GeForce 8600 GT GPU installed in this system is
[    10.958] (WW) NVIDIA(0):     supported through the NVIDIA 340.xx Legacy drivers. Please
[    10.958] (WW) NVIDIA(0):     visit http://www.nvidia.com/object/unix.html for more
[    10.958] (WW) NVIDIA(0):     information.  The 346.35 NVIDIA driver will ignore this
[    10.958] (WW) NVIDIA(0):     GPU.  Continuing probe...
[    10.958] (EE) No devices detected.
[    10.958] (EE)
Fatal server error:
[    10.958] (EE) no screens found(EE)
[    10.958] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[    10.958] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    10.958] (EE)[/code
]
_________________
...ale ja się nie znam.
Pozdrowienia, niemcu!, >>Piszę poprawnie po polsku
- a przynajmniej się staram ;)


Last edited by DeszczyK on Sun May 03, 2015 7:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
Garrappachc
Guru
Guru


Joined: 26 Dec 2008
Posts: 362
Location: Kraków

PostPosted: Sun Feb 15, 2015 10:27 pm    Post subject: Reply with quote

Czy masz włączone
Code:
Device Drivers  --->
    Generic Driver Options  --->
        ()  path to uevent helper
        [*] Maintain a devtmpfs filesystem to mount at /dev

w jajku?
_________________
De profundis clamavi ad Te, Domine

emerge --info | virtual aviation
Back to top
View user's profile Send private message
DeszczyK
n00b
n00b


Joined: 13 Sep 2006
Posts: 64
Location: GDYNIA

PostPosted: Mon Feb 16, 2015 7:55 am    Post subject: Reply with quote

Hej, mam acz nie "[*]", tylko "-*-" zaznaczony i nie da się zmienić:
Code:
 Device Drivers  --->
    Generic Driver Options  --->
        ()  path to uevent helper
        -*- Maintain a devtmpfs filesystem to mount at /dev

Co dalej?


Zapomniałem bodaj o najważniejszym - wieczorem dokleję log samego udev.

Edit at 20:59 on 16-02-2015r:
No nie mam w /var/log/... - ratujcie! Co sprawdzić. Jak przywrócić udev, by się uruchamiał jak trza?
_________________
...ale ja się nie znam.
Pozdrowienia, niemcu!, >>Piszę poprawnie po polsku
- a przynajmniej się staram ;)
Back to top
View user's profile Send private message
Garrappachc
Guru
Guru


Joined: 26 Dec 2008
Posts: 362
Location: Kraków

PostPosted: Mon Feb 16, 2015 10:35 pm    Post subject: Reply with quote

Logi udeva masz w dmesgu.

Próbowałeś rozwiązania z tego wątku: https://forums.gentoo.org/viewtopic-p-7279970.html ?
_________________
De profundis clamavi ad Te, Domine

emerge --info | virtual aviation
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 657
Location: /dev/null

PostPosted: Mon Feb 23, 2015 9:19 pm    Post subject: Reply with quote

Code:
[    10.958] (WW) NVIDIA(0): The NVIDIA GeForce 8600 GT GPU installed in this system is
[    10.958] (WW) NVIDIA(0):     supported through the NVIDIA 340.xx Legacy drivers. Please
[    10.958] (WW) NVIDIA(0):     visit http://www.nvidia.com/object/unix.html for more
[    10.958] (WW) NVIDIA(0):     information.  The 346.35 NVIDIA driver will ignore this
[    10.958] (WW) NVIDIA(0):     GPU.  Continuing probe...
[    10.958] (EE) No devices detected.


Nvidia przestała wspierać jakiś czas temu wszystko poniżej 9xxx GT.

Pobierz sterowniki w wersji NVIDIA 340.XX


U mnie na starym kompie się sprawdza. Miałem to samo, przeoczyłem komunikat portage, nie zmaskowałem nowych dirverów i system stawał w tym samym momencie co Twój.
Back to top
View user's profile Send private message
DeszczyK
n00b
n00b


Joined: 13 Sep 2006
Posts: 64
Location: GDYNIA

PostPosted: Sun May 03, 2015 7:35 pm    Post subject: Reply with quote

Dzieki Pryka, dziala! :) Cofnalem stery do v340.76 i hula az milo :D

P.S.
wybaczcie brak ogonkow, ale za mna dopiero pierwsze logowanie na X'ach.
_________________
...ale ja się nie znam.
Pozdrowienia, niemcu!, >>Piszę poprawnie po polsku
- a przynajmniej się staram ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum