Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
upgrade of lxqt 0.7 to 0.9 can't be made due to qt5 flag
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3648
Location: Hamburg

PostPosted: Tue Feb 10, 2015 9:54 pm    Post subject: upgrade of lxqt 0.7 to 0.9 can't be made due to qt5 flag Reply with quote

whatever I tried, I do always run into :
Code:
# emerge --update @world --newuse --changed-use --with-bdeps=y --ask

These are the packages that would be merged, in reverse order:

Calculating dependencies  ..... done!

emerge: there are no ebuilds to satisfy "sys-auth/polkit-qt[qt5(-)]".
(dependency required by "lxqt-base/lxqt-policykit-0.9.0" [ebuild])
(dependency required by "lxqt-base/lxqt-meta-0.9.0[policykit]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
I do not use any overlays - just straight portage tree and have a hardened Gentoo here.
Update: this in /etc/portage/package.use/misc helped :
Code:
~lxqt-base/lxqt-meta-0.9.0 -policykit
but is it recommended ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7899
Location: ~Brussels - Belgique

PostPosted: Wed Feb 11, 2015 11:32 am    Post subject: Reply with quote

You can also enable QT5 and it's qt5 USE flag on needed dependancies.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3648
Location: Hamburg

PostPosted: Wed Feb 11, 2015 7:21 pm    Post subject: Reply with quote

Tried all combination, I eventualla removed it :
Code:
emerge -C lxqt-base/lxqt-policykit
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Fri Feb 13, 2015 10:53 am    Post subject: Reply with quote

Since LXQt 0.9.0 is Qt5-based, you should enable the qt5 useflag on sys-auth/polkit-qt. (Or, as you did, disable policykit support.)
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3648
Location: Hamburg

PostPosted: Sat Feb 21, 2015 9:47 am    Post subject: Reply with quote

yngwin wrote:
Since LXQt 0.9.0 is Qt5-based, you should enable the qt5 useflag on sys-auth/polkit-qt. (Or, as you did, disable policykit support.)
The 1st never worked - so I choosed the 2nd.
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Sat Feb 21, 2015 11:49 am    Post subject: Reply with quote

qt5 USE flag exists in >=sys-auth/polkit-qt-0.112.0 only.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum