Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can not emerge gnome because of media-libs/flac
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ackasia
n00b
n00b


Joined: 09 Feb 2015
Posts: 2

PostPosted: Tue Feb 10, 2015 5:49 pm    Post subject: can not emerge gnome because of media-libs/flac Reply with quote

Hello,

everytime I try to emerge gome I get:

Code:

amd64-3 ~ # emerge gnome
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.40.2:2/2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/glib-2.42.1:2/2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/glib:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                 
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-libs/libsoup-2.48.1:2.4/2.4::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                               
    >=dev-libs/glib-2.42:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-libs/glib-networking-2.42.1:0/0::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^                                                                                                                                                                                                                                                                                                                               
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/libcroco-0.6.8-r1:0.6/0.6::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                 
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-plugins/gst-plugins-resindvd-1.4.5:1.0/1.0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                   
    >=dev-libs/glib-2.32:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (app-accessibility/at-spi2-atk-2.14.1:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                     
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-libs/libproxy-0.4.11-r2:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                               
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/gst-plugins-bad-1.4.5:1.0/1.0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                       
    >=dev-libs/glib-2.36:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (app-accessibility/at-spi2-core-2.14.1:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                       
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/pango-1.36.8:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                         
    >=dev-libs/glib-2.28:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/libgusb-0.2.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                       
    dev-libs/glib:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                               
    >=dev-libs/glib-2.37.6:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/gdk-pixbuf-2.30.8:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                             
    >=dev-libs/glib-2.36:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-misc/colord-1.2.8:0/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                       
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/atk-2.14.0:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                       
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/cairo-1.12.18:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                         
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/gtk+-2.24.25-r1:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                           
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/gst-plugins-bad-1.4.5:1.0/1.0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                           
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/gstreamer-1.4.5:1.0/1.0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                 
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (gnome-base/librsvg-2.40.6:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                             
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/harfbuzz-0.9.37:0/0.9.18::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                   
    (and 1 more with the same problems)

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.2:2/2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libxml2-2.9.2:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libxml2-2.9.1-r4:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-libs/libsoup-2.48.1:2.4/2.4::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                   
    >=dev-libs/libxml2-2.9.1-r4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/libcroco-0.6.8-r1:0.6/0.6::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                     
    >=dev-libs/libxml2-2.9.1-r4:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (gnome-base/librsvg-2.40.6:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                 

sys-apps/dbus:0

  (sys-apps/dbus-1.8.10:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-apps/dbus-1.8.12:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/dbus-1.6.18-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-print/cups-2.0.1-r1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                           
    >=sys-apps/dbus-1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (app-accessibility/at-spi2-core-2.14.1:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                 
    sys-apps/dbus[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdbus-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                               
    >=sys-apps/dbus-1.5[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (app-accessibility/at-spi2-atk-2.14.1:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                   

media-libs/freetype:2

  (media-libs/freetype-2.5.3-r1:2/2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/freetype-2.5.5:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/freetype-2.5.3-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/fontconfig-2.11.1-r2:1.0/1.0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                             
    >=media-libs/freetype-2.5.0.1:2=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/harfbuzz-0.9.37:0/0.9.18::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                           
    >=media-libs/freetype-2.5.0.1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/cairo-1.12.18:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                 
    >=media-libs/freetype-2.5.0.1:2=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/pango-1.36.8:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                 
    >=media-libs/freetype-2.4.11-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                 
    >=media-libs/freetype-2.5.0.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/libXft-2.3.2:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                             

media-libs/libpng:0

  (media-libs/libpng-1.6.16:0/16::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/libpng-1.6.16:0/16::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libpng-1.4:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/gdk-pixbuf-2.30.8:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                               
    media-libs/libpng:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                     
    >=media-libs/libpng-1.6.10:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/cairo-1.12.18:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                               
    >=media-libs/libpng-1.2.51[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/freetype-2.5.5:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                               

dev-libs/expat:0

  (dev-libs/expat-2.1.0-r3:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/expat-2.1.0-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/expat-2.1.0-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-gfx/exiv2-0.24-r1:0/13::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                             
    >=dev-libs/expat-2.1.0-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/fontconfig-2.11.1-r2:1.0/1.0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                       
    >=dev-libs/expat-2.1.0-r3:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/mesa-10.4.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                             

dev-db/sqlite:3

  (dev-db/sqlite-3.8.7.4:3/3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-db/sqlite-3.8.8.1:3/3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-db/sqlite-3.8.2:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-libs/libsoup-2.48.1:2.4/2.4::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                             
    >=dev-db/sqlite-3.8.3:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                           
    >=dev-db/sqlite-3.8.3:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                       

sys-libs/readline:0

  (sys-libs/readline-6.2_p5-r1:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/readline-6.2_p5-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-libs/readline:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-db/sqlite-3.8.8.1:3/3::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                     

sys-libs/ncurses:5

  (sys-libs/ncurses-5.9-r3:5/5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/ncurses-5.9-r3:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.9-r3:5=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/llvm-3.5.1:0/3.5::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                             
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-libs/readline-6.2_p5-r1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                               

dev-libs/libtasn1:0

  (dev-libs/libtasn1-4.2:0/6::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libtasn1-4.2:0/6::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libtasn1-3.9[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-libs/gnutls-3.3.12:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                         

dev-libs/openssl:0

  (dev-libs/openssl-1.0.1k:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/openssl-1.0.2-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.1h-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/cyrus-sasl-2.1.26-r9:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                     
    >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                               

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.5:4/4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtsql-4.8.5:4[mysql?,postgres?] required by (app-office/akonadi-server-1.13.0:0/0::gentoo, ebuild scheduled for merge)
                           ^^^^^^                                                                                                                                     
    ~dev-qt/qtsql-4.8.6[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                               

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.5-r2:4/4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                           
    (and 11 more with the same problem)

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.5-r3:4/4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtgui-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                   
    (and 5 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.5:4/4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtscript-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                                                                                                                                                                                               
    (and 1 more with the same problem)

sys-devel/bison:0

  (sys-devel/bison-2.4.3:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-devel/bison-3.0.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-devel/bison-3 required by (dev-libs/rasqal-0.9.32:0/0::gentoo, ebuild scheduled for merge)
    ^^                ^                                                                                                                                   
    (and 1 more with the same problem)

x11-proto/xf86vidmodeproto:0

  (x11-proto/xf86vidmodeproto-2.3.1-r1:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-proto/xf86vidmodeproto-2.3.1-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/xf86vidmodeproto-2.3.1-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/mesa-10.4.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                         
    >=x11-proto/xf86vidmodeproto-2.3.1-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/libXxf86vm-1.1.3:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                         


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy ">=media-libs/flac-1.2.1-r5[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
(dependency required by "media-plugins/gst-plugins-flac-1.4.5::gentoo" [ebuild])
(dependency required by "media-plugins/gst-plugins-meta-1.0-r3::gentoo[flac]" [ebuild])
(dependency required by "media-libs/phonon-gstreamer-4.8.2::gentoo" [ebuild])
(dependency required by "media-libs/phonon-4.8.3::gentoo[gstreamer]" [ebuild])
(dependency required by "kde-base/kdelibs-4.14.3-r1::gentoo" [ebuild])
(dependency required by "net-libs/libproxy-0.4.11-r2::gentoo[kde]" [ebuild])
(dependency required by "net-libs/glib-networking-2.42.1::gentoo[libproxy]" [ebuild])
(dependency required by "net-libs/libsoup-2.48.1::gentoo" [ebuild])
(dependency required by "gnome-base/gvfs-1.22.3::gentoo[http]" [ebuild])
(dependency required by "gnome-base/gnome-3.14.0::gentoo" [ebuild])
(dependency required by "gnome" [argument])


So I emerged flac and installed it. After that I wanted to emerge gnome, but I still get:
Code:

there are no ebuilds to satisfy ">=media-libs/flac-1.2.1-r5[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Tue Feb 10, 2015 8:58 pm    Post subject: Reply with quote

Most likely it's a package.use.stable.mask problem - see if unmasking that useflag helps.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum