Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Radeon:xorg won't start: failed to set drm interf..
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mr-simon
Guru
Guru


Joined: 22 Nov 2002
Posts: 362
Location: Leamington Spa, Warks, UK

PostPosted: Sun Feb 08, 2015 10:29 am    Post subject: [solved] Radeon:xorg won't start: failed to set drm interf.. Reply with quote

I've installed gentoo on my machine with two HD 7970 Radeon cards.

I'm having trouble getting xorg to start. KMS is working OK (I had trouble with that and needed 'nomodeset' until I realised I needed the firmware installed) and the 'radeon' module is loaded

I've set VIDEO_CARDS="radeon radeonsi"

I'm running a genkernel-next kernel (boooo) and I am using systemd.

This is what lspci says I have:
Code:

frey ~ # lspci | grep radeon -i
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT HDMI Audio [Radeon HD 7970 Series]
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X]
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT HDMI Audio [Radeon HD 7970 Series]


The relevant part of the Xorg.0.log appears to be:
Code:

[    29.439] (--) RADEON(G0): Chipset: "TAHITI" (ChipID = 0x6798)
[    29.439] (EE) RADEON(G0): [drm] failed to set drm interface version.
[    29.439] (EE) RADEON(G0): Kernel modesetting setup failed
[    29.439] (II) UnloadModule: "radeon"
[    29.439] (EE) Screen(s) found, but none have a usable configuration.


Full output is rather long, but I've posted it here: http://cxg.de/_59be93.htm

dmesg output is here: http://cxg.de/_1c9b82.htm

And emerge --info is here: http://cxg.de/_dccf90.htm

`eselect opengl list` only lists xorg-x11 as an option.

I'm running ~amd64 xf86-video-ati, mesa and xorg-server. I tried the stable version first and I got a different error. (I forget what it was.) Here's what portage has to say about those things:
Code:

frey ~ # emerge -pv mesa xorg-server xf86-video-ati

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] media-libs/mesa-10.4.3  USE="classic dri3 egl gallium gbm llvm nptl opencl r600-llvm-compiler udev xa xvmc -bindist -debug -gles1 -gles2 -openmax -osmesa -pax_kernel -pic (-selinux) -vaapi -vdpau -wayland" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="radeon radeonsi (-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -vmware" 0 KiB
[ebuild   R   ~] x11-base/xorg-server-1.16.3-r1:0/1.16.1  USE="glamor ipv6 kdrive nptl suid systemd udev xorg -dmx -doc -minimal (-selinux) -static-libs -tslib -unwind -wayland -xnest -xvfb" 0 KiB
[ebuild   R   ~] x11-drivers/xf86-video-ati-7.5.0  USE="glamor udev" 0 KiB


I'd rather not try the closed-source drivers if I can avoid it.

Any ideas, folks? :?
_________________
"Pokey, are you drunk on love?"
"Yes. Also whiskey. But mostly love... and whiskey."


Last edited by mr-simon on Thu Feb 19, 2015 9:51 am; edited 1 time in total
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sun Feb 08, 2015 4:14 pm    Post subject: Reply with quote

May I ask why you do not use the binary ati-drivers? And yes I know you maybe want the open source drivers ..
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Sun Feb 08, 2015 4:43 pm    Post subject: Reply with quote

It appears that you have vesafb enabled. Although radeon implements handover from vesafb, sometimes this does not work properly. Better disable all fb hardware drivers.

Also if you use systemd, then you need >=xinit-1.3.4 if you want to use startx.

EDIT:
Some fdo bugs seem to suggest that you need to use BusID parameter in xorg.conf, or disable AutoAddGPU:
https://bugs.freedesktop.org/show_bug.cgi?id=63576
https://bugs.freedesktop.org/show_bug.cgi?id=56435
Back to top
View user's profile Send private message
grumblebear
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2008
Posts: 134

PostPosted: Sun Feb 08, 2015 10:07 pm    Post subject: Reply with quote

I got exactly the same error as I tried xorg-server-1.16.3-r1 a few days ago and was unable to find a solution, so I had to go back to stable. You will have better luck with that, too.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Mon Feb 09, 2015 12:52 am    Post subject: Reply with quote

dmesg says one card (03:00.0) is headless, I wonder if that's confusing it? You might have better luck not letting X autodetect everything.
Back to top
View user's profile Send private message
mr-simon
Guru
Guru


Joined: 22 Nov 2002
Posts: 362
Location: Leamington Spa, Warks, UK

PostPosted: Thu Feb 19, 2015 9:52 am    Post subject: Reply with quote

Apologies for going quiet. I ran out of time for this so parked it for a bit.

I looked at it again yesterday and noticed there was an update to Xorg 1.16.4. I installed that and the problem went away.
_________________
"Pokey, are you drunk on love?"
"Yes. Also whiskey. But mostly love... and whiskey."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum