Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
new KDE install: mariadb has unmet requirements [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Spanik
Guru
Guru


Joined: 12 Dec 2003
Posts: 454
Location: Belgium

PostPosted: Sat Feb 07, 2015 1:52 pm    Post subject: new KDE install: mariadb has unmet requirements [solved] Reply with quote

I'm re-installing from scratch and now I'm going to install kde-base/kdebase-meta and it doesn't start because mariadb has "unmet requirements". I selected the profile /kde (no systemd) and the X server starts.

When I try to emerge mariadb apart it gives this:
Code:

!!! The ebuild selected to satisfy "mariadb" has unmet requirements.
- dev-db/mariadb-10.0.15-r1::gentoo USE="bindist community pam perl ssl xml -cluster -debug -embedded -extraengine -jemalloc -latin1 -minimal -odbc oqgraph -profiling (-selinux) -sphinx -static -static-libs -systemtap -tcmalloc -test -tokudb" ABI_X86="64 -32 -x32"

 The following REQUIRED_USE flag constraints are unsatisfied:
  xml? ( extraengine )

 The above contraints are a subset of the following complete expression:
  odbc? ( extraengine !minimal ) xml? ( extraengine !minimal) minimal? ( !oqgraph ! sphinx) tokudb? ( jemalloc ) tcmalloc? ( !jemalloc ) jemalloc? ( !tcalloc ) minimal? ( ! cluster !extraengine ! embedded ) static? ( !ssl )


Sorry but this is chines to me. I cannot see what are the missing requirements. If it are some USE flags, surely those should be added automatically?
_________________
Expert in non-working solutions


Last edited by Spanik on Sun Feb 08, 2015 12:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Sat Feb 07, 2015 3:04 pm    Post subject: Reply with quote

Code:
 The following REQUIRED_USE flag constraints are unsatisfied:
  xml? ( extraengine )

You have xml enabled, so you also need to enable the extraengine useflag.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 808

PostPosted: Sat Feb 07, 2015 3:04 pm    Post subject: Reply with quote

Quote:
if it are some USE flags, surely those should be added automatically?

i don't think so.
Code:
The following REQUIRED_USE flag constraints are unsatisfied:
  xml? ( extraengine )


if you are certain that you need/want to run an xml-db with kde on your system, the database needs an extra-engine enabled to be able to run an xml-db.
on the other hand you could disable the sql/mysql-useflag somewhere deep in the djungles of kde/qt (i think it's qtsql)
this issue has been treated at length somewhere in there: https://forums.gentoo.org/viewtopic-t-1009552.html
GOOD LUCK!
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
Spanik
Guru
Guru


Joined: 12 Dec 2003
Posts: 454
Location: Belgium

PostPosted: Sat Feb 07, 2015 3:22 pm    Post subject: Reply with quote

Doesn't sound hopeful...

I have no idea why I would need a db at all. I enabled the xml flag as I'm regulary mucking with it in Eagle. I tried a few dependencies for KDE like polkit and the same mariadb turned up. So it looks as if it is anywhere.

EDIT: just ran "USE="-xml" emerge mariadb" and this sems to emerge. I hope the rest of KDE will follow.Otherwise I'll make the -xml global. I'll wait before flaging this as solved until KDE is compiling.
_________________
Expert in non-working solutions
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 808

PostPosted: Sat Feb 07, 2015 3:56 pm    Post subject: Reply with quote

Quote:
I have no idea why I would need a db at all.

so why install one? you can find out with
Code:
equery h mysql
and then check the deps.

Quote:
just ran "USE="-xml" emerge mariadb" and this sems to emerge. I hope the rest of KDE will follow.Otherwise I'll make the -xml global.

it's much more flexible to set the use-flags on a per-pkg-base in package.use

Quote:
I'll wait before flaging this as solved

the "solution" is installing the deps or dis/enabling the specific use-flags to control their behavior.

on my desktop-system i do not use kde but have some of its progs installed; also qtsql. the mysql-useflag is globally disabled and only enabled for a couple of specific pkgs in package.use. my currently installed version of qtsql (4.8.6-something) has all db-specific use-flags disabled, but newer versions require at least one of them:

Code:
USE="-mysql -sqlite" emerge -pv1 qtsql
The ebuild selected to satisfy "qtsql" has unmet requirements.
- dev-qt/qtsql-4.8.5::gentoo USE="exceptions qt3support (-aqua) -debug (-firebird) -freetds -mysql -oci8 -odbc -pch -postgres -sqlite"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( firebird freetds mysql oci8 odbc postgres sqlite )

for a desktop-system sqlite is probably the most lightweight and easy solution. so installing it with
Code:
USE="-mysql sqlite" emerge -pv1 qtsql
should get rid of mysql/mariadb (you might have to recompild some other pks after changing this use-flag)
(yes, taming kde and all its deps can be quite a b.)

GOOD LUCK!
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum