Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to set XMODIFIERS for non-interactive shell? [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
helio
Apprentice
Apprentice


Joined: 08 Apr 2006
Posts: 195

PostPosted: Fri Feb 06, 2015 6:18 am    Post subject: How to set XMODIFIERS for non-interactive shell? [Solved] Reply with quote

I have tried to set

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS="@im=fcitx"

in .xprofile, .xsession, .xinitrc, and .bash_profile files, but when I type "env|grep MOD" I still get

IMSETTINGS_MODULE=X compose table
QT_IM_MODULE=xim
XMODIFIERS=@im=imsettings
GTK_IM_MODULE=xim

So the question is, where are the above environment variables set by the system? How do I change them?


Last edited by helio on Sat Feb 07, 2015 4:25 am; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri Feb 06, 2015 12:40 pm    Post subject: Reply with quote

helio ...

I don't see why setting the variable via .xinitrc doesn't pass this on to the session, perhaps xim starts prior, and/or your using a login manager (so nothing from your "login shell" is setup), anyhow, does this answer your questions?

best ... khay
Back to top
View user's profile Send private message
helio
Apprentice
Apprentice


Joined: 08 Apr 2006
Posts: 195

PostPosted: Fri Feb 06, 2015 9:01 pm    Post subject: Reply with quote

khayyam wrote:
helio ...

I don't see why setting the variable via .xinitrc doesn't pass this on to the session, perhaps xim starts prior, and/or your using a login manager (so nothing from your "login shell" is setup), anyhow, does this answer your questions?

best ... khay


Yes, Khay, I use kdm as the login manager. But which file scripts set up the login shell?
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri Feb 06, 2015 9:38 pm    Post subject: Reply with quote

helio wrote:
khayyam wrote:
I don't see why setting the variable via .xinitrc doesn't pass this on to the session, perhaps xim starts prior, and/or your using a login manager (so nothing from your "login shell" is setup), anyhow, does this answer your questions?

Yes, Khay, I use kdm as the login manager. But which file scripts set up the login shell?

helio ... if you use a DM then you don't get a "login shell", because the DE replaces that altogether. There are probably mechanisms the DM uses for setting the env but its not those of 'login' (or rather, the 'shell' provided subsequent to login). Not having ever used a DM I can't tell you what does what, but from the link above it looked to me like this was a gtk+/qt thing, and so configured via the UI, or provided tools, rather than via a config file (but I may be wrong). Sorry I couldn't be of more help.

best ... khay
Back to top
View user's profile Send private message
helio
Apprentice
Apprentice


Joined: 08 Apr 2006
Posts: 195

PostPosted: Sat Feb 07, 2015 4:25 am    Post subject: Reply with quote

Thanks Khay.

It turned out the "imsettings" package was installed and blocking fcitx. After removing it, fcitx works as it should now with kdm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum