Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox profile missing error[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 639

PostPosted: Wed Feb 04, 2015 10:04 am    Post subject: Firefox profile missing error[solved] Reply with quote

Hi,
I can't start firefox (Aurora), I get "Your Firefox profile cannot be loaded. It may be missing or inaccessible"

I've tried uninstalling firefox, removing .mozilla but I can't get anything to work. It occurred after the system powered down, so I think something's gotten corrupted, but I can't think what. I've searched for a profiles.ini, but none seems to exist. I've googled this, but can't find anything,

Thanks,
James

tl;dr make sure you delete .cache/mozilla as well as .mozilla
_________________
Intel 2.2 Core 2 Duo, 4Gb Ram, 320GB Sata Drive and Nvidia card.


Last edited by BrummieJim on Wed Feb 04, 2015 10:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2561

PostPosted: Wed Feb 04, 2015 10:29 am    Post subject: Reply with quote

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 639

PostPosted: Wed Feb 04, 2015 10:44 am    Post subject: Reply with quote

I've tried all the things listed. firefox -P just returns the same error. There seem no profiles to fix or delete.
_________________
Intel 2.2 Core 2 Duo, 4Gb Ram, 320GB Sata Drive and Nvidia card.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2561

PostPosted: Wed Feb 04, 2015 10:53 am    Post subject: Reply with quote

Would you mind posting the full message like
Quote:
$ firefox

(process:12986): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 639

PostPosted: Wed Feb 04, 2015 10:57 am    Post subject: Reply with quote

The actual error appears in a XFCE message box window. I'm using firefox 31.3.0

Quote:
$ firefox -P

(process:5225): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed


Once I press ok in the message box, the terminal prompt comes back like it's finished processing.
_________________
Intel 2.2 Core 2 Duo, 4Gb Ram, 320GB Sata Drive and Nvidia card.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2561

PostPosted: Wed Feb 04, 2015 11:27 am    Post subject: Reply with quote

Can you open "$ firefox -ProfileManager"?
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 639

PostPosted: Wed Feb 04, 2015 4:29 pm    Post subject: Reply with quote

Exactly the same error, sorry.
_________________
Intel 2.2 Core 2 Duo, 4Gb Ram, 320GB Sata Drive and Nvidia card.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 701
Location: S.O. France

PostPosted: Wed Feb 04, 2015 6:31 pm    Post subject: Reply with quote

Can you try removing .mozilla and .cache/mozilla

If this don't work post
Quote:
ls -la | grep mozilla
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 639

PostPosted: Wed Feb 04, 2015 10:24 pm    Post subject: Reply with quote

Brilliant, I'd missed the .cache/mozilla directory, deleting that did it!
Thanks!
_________________
Intel 2.2 Core 2 Duo, 4Gb Ram, 320GB Sata Drive and Nvidia card.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum