Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing masked packages
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
craigs
n00b
n00b


Joined: 04 Feb 2015
Posts: 1
Location: United States

PostPosted: Wed Feb 04, 2015 12:55 am    Post subject: Installing masked packages Reply with quote

Hi,
I just successfully installed gentoo-prefix on my macbook pro and a CentOS server. While I can easily install SCons I also need to install dev-util/meld but emerge fails (even with --autounmask-write).

On the macbook pro it results in
Code:
  emerge --ask dev-util/meld                                               

 * IMPORTANT: config file '/Users/craigs/gentoo/etc/portage/package.accept_keywords' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=x11-libs/gtk+-3.6:3[introspection]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/gtk+-3.14.8::gentoo_prefix (masked by: missing keyword)
- x11-libs/gtk+-3.14.7::gentoo_prefix (masked by: missing keyword)
- x11-libs/gtk+-3.12.2-r2::gentoo_prefix (masked by: missing keyword)
- x11-libs/gtk+-3.12.2::gentoo_prefix (masked by: missing keyword)

(dependency required by "dev-util/meld-3.12.3" [ebuild])
(dependency required by "dev-util/meld" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


and on the centos server:
Code:
!!! The ebuild selected to satisfy ">=x11-libs/gtk+-3.6:3[introspection]" has unmet requirements.
- x11-libs/gtk+-3.14.8::gentoo_prefix USE="introspection (prefix) (prefix-guest) -X (-aqua) -cloudprint -colord (-cups) -debug -examples -test -vim-syntax -wayland -xinerama"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( aqua wayland X )

  The above constraints are a subset of the following complete expression:
    any-of ( aqua wayland X ) xinerama? ( X )

(dependency required by "dev-util/meld-3.12.3" [ebuild])
(dependency required by "dev-util/meld" [argument])


I believe both systems need me to set them to use the system X11 server, but I can't find a guide on how to do that. I am very new to gentoo so I would appreciate any suggestions. I've been looking through the AMD64 handbook but I'm not sure how applicable that is to a prefix install.

Thanks,
Craig
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Wed Feb 04, 2015 3:20 am    Post subject: Re: Installing masked packages Reply with quote

craigs wrote:
Code:
 * IMPORTANT: config file '/Users/craigs/gentoo/etc/portage/package.accept_keywords' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

craigs ... this warning is probably due to having used --autounmask-write ... there is a changed config that you are supposed to 'merge' with the current file. You do this by running 'etc-update' or 'dispatch.conf'. Once the changes are merged that should be enough to get the following package(s) 'keyworded', but as this is your first bash at such things I'll provide some extra details, some of which might clarify whats happening, and/or give you some idea of how to do this without using --autounmask-write.

craigs wrote:
Code:
!!! All ebuilds that could satisfy ">=x11-libs/gtk+-3.6:3[introspection]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/gtk+-3.14.8::gentoo_prefix (masked by: missing keyword)
- x11-libs/gtk+-3.14.7::gentoo_prefix (masked by: missing keyword)
- x11-libs/gtk+-3.12.2-r2::gentoo_prefix (masked by: missing keyword)
- x11-libs/gtk+-3.12.2::gentoo_prefix (masked by: missing keyword)

This means that the package that can satisfy the dependency are not keyworded for your arch within the repo ::gentoo_prefix. To illusrate the current keywords for this package, here is the output of eshowkw (app-portage/gentoolkit).

Code:
% eshowkw x11-libs/gtk+
Keywords for x11-libs/gtk+:
               |                             | u   | 
               | a a   a           p     s   | n   | 
               | l m   r h i m m   p s   p   | u s | r
               | p d a m p a 6 i p c 3   a x | s l | e
               | h 6 r 6 p 6 8 p p 6 9 s r 8 | e o | p
               | a 4 m 4 a 4 k s c 4 0 h c 6 | d t | o
---------------+-----------------------------+-----+-------
    1.2.10-r12 | + + + o + + o ~ + + o + + + | o 1 | gentoo
---------------+-----------------------------+-----+-------
[I]2.24.25     | + + + o + + o ~ + + ~ ~ + + | o 2 | gentoo
   2.24.25-r1  | ~ ~ ~ o + ~ o ~ ~ ~ ~ ~ ~ ~ | o   | gentoo
---------------+-----------------------------+-----+-------
    3.12.2     | + + + o + + o ~ + + ~ ~ + + | o 3 | gentoo
    3.12.2-r2  | ~ ~ ~ o + ~ o ~ ~ ~ ~ ~ ~ ~ | o   | gentoo
    3.14.6     | ~ ~ ~ o ~ ~ o ~ ~ ~ ~ ~ ~ ~ | #   | gentoo
    3.14.7     | ~ ~ ~ o ~ ~ o ~ ~ ~ ~ ~ ~ ~ | o   | gentoo

This shows "+" meaning the stable branch/keyword, "~" meaning "~arch" branch/keyword, "o" meaning none. We can also see there are three "slots", these can be installed at the same time (to satisfy the dependencies of package which may only work with one particular slot). In your case dev-util/meld requires a package from slot 3, which is 3.{12,14}.x. As 3.12.2 is stable for most architectures then I would probably select this for keywording ... your /etc/portage/package.accept_keywords would look like:

Code:
=x11-libs/gtk+-3.12.2

That will be enough to resolve the dependency, though it may be different to that written by --autounmask-write, which probably selected the highest unkeyworded package in the slot ... so, 3.14.7. Its up to you which you choose, but notice from the above eshowkw output that 3.14.7 is ~arch (so, in the testing/unstable branch).

craigs wrote:
and on the centos server:

Code:
!!! The ebuild selected to satisfy ">=x11-libs/gtk+-3.6:3[introspection]" has unmet requirements.
- x11-libs/gtk+-3.14.8::gentoo_prefix USE="introspection (prefix) (prefix-guest) -X (-aqua) -cloudprint -colord (-cups) -debug -examples -test -vim-syntax -wayland -xinerama"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( aqua wayland X )

This just states that one or other of 'aqua', 'wayland', or 'X' needs to be enabled on that package to satisfy the useflag 'introspection'. This is bacause 'introspection' is dependent on some feature offered by enabling another useflag. In this case you would do something like the following:

/etc/portage/package.use
Code:
x11-libs/gtk+ X

Why X? Because 'aqua' is in (brackets) so not available for your architecture, and wayland is very much a work in progress.

Hopefully that clears up everything ...

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum