Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Ati-drivers 14.12 fails with "cannot open zipfile"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
heheman3000
n00b
n00b


Joined: 22 Oct 2006
Posts: 32

PostPosted: Tue Feb 03, 2015 8:57 pm    Post subject: [Solved] Ati-drivers 14.12 fails with "cannot open zipf Reply with quote

Over the last month or so I haven't been able to emerge the ATI 14.12 drivers (r2 or r3), which fail with the following error:

The error suggests that something is wrong inside the driver archive. But it does pass all of the file checks.

ati-drivers 14.9 emerges fine, so what could be going on here?

Code:

>>> Emerging (1 of 1) x11-drivers/ati-drivers-14.12-r3::gentoo
 * amd-catalyst-omega-14.12-linux-run-installers.zip SHA256 SHA512 WHIRLPOOL size ;-) ...                                      [ ok ]
 * xvba-sdk-0.74-404001.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                            [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.17.7-gentoo/build
 * Found sources for kernel version:
 *     3.17.7-gentoo
 *
 * Please note that this driver only supports graphic cards based on
 * Evergreen chipset and newer.
 * This includes the AMD Radeon HD 5400+ series at this moment.
 *
 * If your card is older then use x11-drivers/xf86-video-ati
 * For migration informations please refer to:
 * http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
 *
>>> Unpacking source...
>>> Unpacking amd-catalyst-omega-14.12-linux-run-installers.zip to /var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work
error:  cannot open zipfile [ /var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/distdir/amd-catalyst-omega-14.12-linux-run-installers.zip ]
        Permission denied
unzip:  cannot find or open /var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/distdir/amd-catalyst-omega-14.12-linux-run-installers.zip, /var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/distdir/amd-catalyst-omega-14.12-linux-run-installers.zip.zip or /var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/distdir/amd-catalyst-omega-14.12-linux-run-installers.zip.ZIP.
 * ERROR: x11-drivers/ati-drivers-14.12-r3::gentoo failed (unpack phase):
 *   failure unpacking amd-catalyst-omega-14.12-linux-run-installers.zip
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_unpack
 *        environment, line 3842:  Called unpack 'amd-catalyst-omega-14.12-linux-run-installers.zip'
 *   phase-helpers.sh, line  348:  Called die
 * The specific snippet of code:
 *               ( set +x ; while true ; do echo n || break ; done ) | \
 *               unzip -qo "${srcdir}${x}" || die "$myfail"
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/ati-drivers-14.12-r3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/ati-drivers-14.12-r3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work'
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work'


Last edited by heheman3000 on Wed Feb 04, 2015 5:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Feb 04, 2015 12:02 am    Post subject: Reply with quote

what does
Code:
ls -l /var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/distdir/amd-catalyst-omega-14.12-linux-run-installers.zip
produce for owner and group? (If the file still exists.)
Code:
ls -l /usr/portage/distfiles/amd-catalyst-omega-14.12-linux-run-installers.zip
should produce
Quote:
-rw-r--r-- 1 portage portage 155616187 Dec 10 23:11 /usr/portage/distfiles/amd-catalyst-omega-14.12-linux-run-installers.zip
My erretic memory seems to remember needing to change owner and group to portage from root. The ebuild for 14.12.3 makes interesting reading.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
heheman3000
n00b
n00b


Joined: 22 Oct 2006
Posts: 32

PostPosted: Wed Feb 04, 2015 5:35 pm    Post subject: Reply with quote

Hmm, I'm building on tmpfs so that entire directory gets nuked each time. I'll see if I can make the file stick around and try changing permissions.

EDIT: Ah, because I had to manually download the file and copying it to /usr/portage/distfiles, it somehow ended up as being owned by my user (instead of portage or root) and with 640 permissions, so portage couldn't open it. Changing owner to portage:portage and 644 made things work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum