Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PSA: Qt 5.4.0, LXQt 0.8.0, KF5 now in testing (~amd64, ~x86)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Wed Feb 04, 2015 10:53 pm    Post subject: Reply with quote

albright wrote:
Does your systemtray work, because mine does not (this seems to be a common
problem)?

Installing dev-libs/sni-qt solves most of systray problems (only one left is 32bit skype icon missing, but there is a way around it too)
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 528
Location: Venice FL

PostPosted: Wed Feb 04, 2015 10:54 pm    Post subject: Reply with quote

albright wrote:
Quote:
Some minor issues to work through, some plasmoids that I really like are missing, but over all it looks nice, and it handles my high DPI screen better that KDE4 did so I'm happy with it so far.


Does your systemtray work, because mine does not (this seems to be a common
problem)?


Partially, I removed it, and re-added it and somethings seem to show like Kmail, Akregator and clipboard, hplip and kalarm still do not show.

George
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 532

PostPosted: Fri Feb 06, 2015 5:39 pm    Post subject: Reply with quote

Is it possible to install KF5 from the portage tree without the KDE overlay?

I have "kde-base / kdebase-meta-4.14.3" in World and I want to migrate.

Bye!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Fri Feb 06, 2015 6:07 pm    Post subject: Reply with quote

KF5 won't give you a desktop.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
nitm
n00b
n00b


Joined: 27 Dec 2004
Posts: 61

PostPosted: Sat Feb 14, 2015 12:25 pm    Post subject: Reply with quote

I see that you are discussing systray issues.
Do you know what is the status of gtk based apps?
Will they work in appindicator based systrays?

I've started separate topic about this problem, but no one seems to be interested: https://forums.gentoo.org/viewtopic-t-1005808.html
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 532

PostPosted: Tue Feb 17, 2015 4:26 am    Post subject: Reply with quote

KDE F5 fail after login

I emerged:

Code:
@kde-frameworks-5.2
@kde-plasma-5.2
kde-apps/kdebase-meta-14.12.1
kde-base/kdm-4.11.16


KDM because kde5 did not install a login system, it is normal?

I reboot my PC, start kdm, I write my pass, load KDE, and then show a fail about "plasmashell" and I can not do nothing.

How I fix it?
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Tue Feb 17, 2015 12:37 pm    Post subject: Reply with quote

natrix wrote:
KDE F5 fail after login

I emerged:

Code:
@kde-frameworks-5.2
@kde-plasma-5.2
kde-apps/kdebase-meta-14.12.1
kde-base/kdm-4.11.16


KDM because kde5 did not install a login system, it is normal?

I reboot my PC, start kdm, I write my pass, load KDE, and then show a fail about "plasmashell" and I can not do nothing.

How I fix it?


KDM is not compatible with Plasma 5. Use something else - SDDM and lightdm are the two common recommendations.
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Tue Feb 17, 2015 12:49 pm    Post subject: Reply with quote

nitm wrote:
I see that you are discussing systray issues.
Do you know what is the status of gtk based apps?
Will they work in appindicator based systrays?

I've started separate topic about this problem, but no one seems to be interested: https://forums.gentoo.org/viewtopic-t-1005808.html


Current status (in Plasma 5):

  • GTK2: Not functional - requires Gtk2 version of libappindicator which the maintainer doesn't support
  • GTK3: Need to install dev-libs/libappindicator
  • Qt4: Need to install dev-libs/sni-qt
  • Qt5: Just works
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 532

PostPosted: Wed Feb 18, 2015 6:17 pm    Post subject: Reply with quote

Hi!!
I fix the problem: I added the USE “minimal” to “kde-frameworks/*” and “kde-plamsa/*” and I reemerged “plasma-desktop”

@Kensington
Thank for the info!!! I installed SDDM

I like KF5 :) :)
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2539
Location: Near Toronto

PostPosted: Wed Feb 18, 2015 7:39 pm    Post subject: Reply with quote

Quote:
KDM is not compatible with Plasma 5.


I have plasma 5 and kdm works fine with it :?
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
vootey
n00b
n00b


Joined: 24 Jul 2010
Posts: 40
Location: Austria

PostPosted: Thu Feb 19, 2015 5:38 pm    Post subject: Reply with quote

thumper wrote:
Thank you, and yes kontact and friends are working fine, [...]


can you tell me, how you got around this block?
Code:
$ emerge -p kmail

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/grantlee-0.4.0  USE="-debug -doc {-test}"
[ebuild  N     ] kde-base/ktimezoned-4.14.3  USE="(-aqua) -debug"
[ebuild  N     ] kde-base/kdepim-icons-4.14.3  USE="(-aqua)"
[ebuild  N     ] kde-base/kdepim-runtime-4.14.3  USE="(-aqua) -debug -facebook -google -kolab"
[ebuild  N     ] kde-base/kdepim-common-libs-4.14.3  USE="(-aqua) -debug"
[ebuild  N     ] kde-base/kontact-4.14.3  USE="(-aqua) -debug -handbook"
[ebuild  N     ] kde-base/korganizer-4.14.3  USE="kontact (-aqua) -debug -handbook"
[ebuild  N     ] kde-base/kmail-4.14.3  USE="kontact (-aqua) -debug -handbook {-test}"
[blocks B      ] kde-base/ktimezoned ("kde-base/ktimezoned" is blocking kde-apps/ktimezoned-14.12.2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/ktimezoned-14.12.2:4/14.12::kde, installed) pulled in by
    >=kde-apps/ktimezoned-14.12.2 required by (kde-apps/kdebase-runtime-meta-14.12.2:5/5::kde, installed)

  (kde-base/ktimezoned-4.14.3:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/ktimezoned-4.14.3:4[aqua=] (>=kde-base/ktimezoned-4.14.3:4[-aqua]) required by (kde-base/korganizer-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Or does it mean that kmail is not working with kde applications 14.12 ?
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 528
Location: Venice FL

PostPosted: Thu Feb 19, 2015 8:09 pm    Post subject: Reply with quote

vootey wrote:


can you tell me, how you got around this block?


The ktimezoned problem I got around by pointing the RDEPEND to the apps.
Code:

#  diff -u /var/lib/layman/kde/kde-base/korganizer/korganizer-4.14.5.ebuild /usr/local/portage/kde-base/korganizer/korganizer-4.14.5-r1.ebuild
--- /var/lib/layman/kde/kde-base/korganizer/korganizer-4.14.5.ebuild    2015-02-18 15:21:52.325914158 -0500                                                               
+++ /usr/local/portage/kde-base/korganizer/korganizer-4.14.5-r1.ebuild  2015-02-18 17:08:33.792414424 -0500                                                               
@@ -19,7 +19,7 @@
        sys-libs/zlib
 "
 RDEPEND="${DEPEND}
-       $(add_kdebase_dep ktimezoned)
+       $(add_kdeapps_dep ktimezoned)
 "
 
 RESTRICT="test"
@@ -36,14 +36,24 @@
        calendarviews/
        kdgantt2/
        kmail/
-       pimcommon/
        knode/org.kde.knode.xml
        libkdepimdbusinterfaces/
-       korgac/org.kde.korganizer.KOrgac.xml
+       libkleo/
+       libkpgp/
+       messagecomposer/
+       mailimporter/
+       agents/mailfilteragent/org.freedesktop.Akonadi.MailFilterAgent.xml
 "
 
 KMCOMPILEONLY="
-       incidenceeditor-ng/
+       grantleetheme/
+       kaddressbookgrantlee/
+       messagecore/
+       messageviewer/
+       mailcommon/
+       pimcommon/
+       templateparser/
+incidenceeditor-ng/
        calendarsupport/
 "
 


I also needed the patch from comment 24 in this bug, which can be seen in the diff.
https://bugs.gentoo.org/show_bug.cgi?id=538922

I hope that helps.

George
Back to top
View user's profile Send private message
vootey
n00b
n00b


Joined: 24 Jul 2010
Posts: 40
Location: Austria

PostPosted: Fri Feb 20, 2015 11:08 am    Post subject: Reply with quote

Thanks for the hint!
But now I'm getting really confused. Apparently there are 4.14.5 packages in the kde overlay (since ~15 days, not masked). As I wanted to create a manifest file for the patched ebuild I noticed that the package couldn't be downloaded. I looked it up at ftp://kde.mirror.anlx.net/stable/ and http://download.kde.org/stable/ and there really are none. The latest is 4.14.3.

So what am I missing?
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Fri Feb 20, 2015 5:27 pm    Post subject: Reply with quote

vootey wrote:
Thanks for the hint!
But now I'm getting really confused. Apparently there are 4.14.5 packages in the kde overlay (since ~15 days, not masked). As I wanted to create a manifest file for the patched ebuild I noticed that the package couldn't be downloaded. I looked it up at ftp://kde.mirror.anlx.net/stable/ and http://download.kde.org/stable/ and there really are none. The latest is 4.14.3.

So what am I missing?

It's here: http://download.kde.org/stable/applications/14.12.2/src/
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 532

PostPosted: Sun Feb 22, 2015 3:10 pm    Post subject: Reply with quote

Hi!!
What is the mirror to kde-plasma-5.2.1? It is the last update in the overlay but not download tha packages.
Thankl!
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Sun Feb 22, 2015 3:11 pm    Post subject: Reply with quote

natrix wrote:
Hi!!
What is the mirror to kde-plasma-5.2.1? It is the last update in the overlay but not download tha packages


It's not released publicly yet.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 532

PostPosted: Sun Feb 22, 2015 9:28 pm    Post subject: Reply with quote

Ok! Thanks again!
Back to top
View user's profile Send private message
ebast
n00b
n00b


Joined: 02 Nov 2008
Posts: 11

PostPosted: Mon Feb 23, 2015 9:16 pm    Post subject: Reply with quote

I got plasma 5 up and running (very nice btw) ... until i bought a new monitor (DisplayPort, 25", 2560x1440). The problem i have is that as soon as i start plasma, the Xorg.log got spammed with mode settings, the mouse movement stutters, and nothing X-related works anymore (even the plasma splash screen does not disappear). The same is true for the sddm "Failsafe"-session (X, xterm, nothing else) and starting kwin_x11 or dolphin, for example.

Graphics card is a Radeon HD7750 using the open source radeon driver. The previous monitor (DVI, 24", 1920x1200) worked like a charm. Can you point me in the direction how to debug that issue?

I do not know if this is the right place to ask, if not i'd appreciate a hint where to post my issue.

Edit: ah might be related to kwin only. I started dolphin within a xfce session and xfwm4 without problems...
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2539
Location: Near Toronto

PostPosted: Tue Feb 24, 2015 1:52 am    Post subject: Reply with quote

Quote:
Edit: ah might be related to kwin only.


just a shot in the dark, but have you installed the kde5 version of kscreen / libkscreen?
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
ebast
n00b
n00b


Joined: 02 Nov 2008
Posts: 11

PostPosted: Sun Mar 01, 2015 10:14 am    Post subject: Reply with quote

Thanks for the hint but newest versions (and newest versions only) were installed already.

It turned out that i am able to trigger the effect by setting the xorg dpi to 117 via xrandr also (xdpyinfo claims 96x96dpi). So this subject might be off topic and i'll start a separate thread...
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3648
Location: Hamburg

PostPosted: Sun Mar 01, 2015 12:49 pm    Post subject: Re: PSA: Qt 5.4.0, LXQt 0.8.0, KF5 now in testing (~amd64, ~ Reply with quote

yngwin wrote:

I find it helps to use eix, it may show why portage keeps masking it. Or what does
Code:
USE=qt5 emerge -pv sys-auth/polkit-qt
say?
Code:
t44 ~ # USE=qt5 emerge -pv sys-auth/polkit-qt

These are the packages that would be merged, in reverse order:

Calculating dependencies  .... done!
[ebuild   R    ] sys-auth/polkit-qt-0.112.0-r1  USE="qt4 -debug -examples (-qt5)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
qt4 seems to be needed by
Code:
  (app-text/poppler-0.26.5:0/46::gentoo, ebuild scheduled for merge) conflicts with
    >=app-text/poppler-0.20[qt4,-exceptions(-)] required by (kde-base/okular-4.14.3:4/4.14::gentoo, installed)
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Mon Mar 02, 2015 8:20 am    Post subject: Re: PSA: Qt 5.4.0, LXQt 0.8.0, KF5 now in testing (~amd64, ~ Reply with quote

toralf wrote:
yngwin wrote:
what does
Code:
USE=qt5 emerge -pv sys-auth/polkit-qt
say?
Code:
t44 ~ # USE=qt5 emerge -pv sys-auth/polkit-qt

These are the packages that would be merged, in reverse order:

Calculating dependencies  .... done!
[ebuild   R    ] sys-auth/polkit-qt-0.112.0-r1  USE="qt4 -debug -examples (-qt5)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

You're on stable, and didn't unmask and enable the qt5 useflag. (And there is no problem to enable both qt4 and qt5 on polkit-qt, so that's not an issue.)
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3648
Location: Hamburg

PostPosted: Mon Mar 02, 2015 12:41 pm    Post subject: Re: PSA: Qt 5.4.0, LXQt 0.8.0, KF5 now in testing (~amd64, ~ Reply with quote

yngwin wrote:
You're on stable, and didn't unmask and enable the qt5 useflag.
Code:
USE="X aes-ni alsa apache2 avx avx2 corefonts cups custom-cflags
     custom-optimization dbus dnssec drmkms dvd ecc ffmpeg fontconfig fortran
     fpm git gnuplot gtk gudev gui help icu isag jpeg libvirtd logrotate
     macvtap mbox minizip mmx mysql ogg opengl pcre16 plasma png policykit
     qemu qt3support qt5 spice sse sse2 sse4 sse4_1 sse4_2 ssh-askpass ssse3
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Mon Mar 02, 2015 6:58 pm    Post subject: Reply with quote

http://www.gossamer-threads.com/lists/gentoo/user/145239
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Dorsai!
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 276
Location: Bavaria

PostPosted: Mon Mar 09, 2015 2:10 pm    Post subject: Reply with quote

I am unsure if I want to emerge KF5 at this time.

When will kde-applications and kde-plasma hit testing and what use is kde-frameworks without them?

Will I be able to --depclean the corresponding parts of KDE SC 4 afterwards? Like the KDE 4 kwallet packages?

I am still a bit fuzzy about how this split of the kde project is supposed to work.

Edit: Well, I just realized that the whole KF5 was pulled in by "sys-block/partitionmanager" from kde overlay. I masked the partitionmanager:5 set for the time being and will update when either kde-applications or kde-plasma reaches testing.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum