Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Failure install rp-pppoe and cannot "emerge world"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
WvR
Apprentice
Apprentice


Joined: 03 Mar 2011
Posts: 181
Location: Tsuruga, Japan

PostPosted: Sat Jan 31, 2015 3:22 am    Post subject: [SOLVED] Failure install rp-pppoe and cannot "emerge wo Reply with quote

Hi, I have a problem, it has been like this for a couple of weeks now. Lenovo G580 laptop, kernel 3.17.7, gnome-light, profile "default/linux/amd64/13.0/desktop/gnome/systemd"

The problem: when I try to update my system with

Code:
emerge -auvDN world


one of the packages to be built is "rp-pppoe"

Code:
[ebuild  N     ] net-dialup/rp-pppoe-3.8-r2  USE="X" 208 KiB


However, this package fails to build:

Code:
>>> Downloading 'http://www.roaringpenguin.com/penguin/pppoe/rp-pppoe-3.8.tar.gz'
--2015-01-31 21:07:06--  http://www.roaringpenguin.com/penguin/pppoe/rp-pppoe-3.8.tar.gz
Resolving www.roaringpenguin.com... 70.38.112.54
Connecting to www.roaringpenguin.com|70.38.112.54|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://www.roaringpenguin.com/penguin/pppoe/rp-pppoe-3.8.tar.gz [following]
--2015-01-31 21:07:07--  https://www.roaringpenguin.com/penguin/pppoe/rp-pppoe-3.8.tar.gz
Connecting to www.roaringpenguin.com|70.38.112.54|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-01-31 21:07:08 ERROR 404: Not Found.

!!! Couldn't download 'rp-pppoe-3.8.tar.gz'. Aborting.
 * Fetch failed for 'net-dialup/rp-pppoe-3.8-r2', Log file:
 *  '/var/tmp/portage/net-dialup/rp-pppoe-3.8-r2/temp/build.log'


Apparently, the address that is coded into the ebuild is incorrect.

So, I thought I'd just wait a while, at some point the developers would know about the problem and fix the ebuild, but this is not happening. Then I thought, let check the forums, but to my surprise, nobody else is reporting this problem. So I go to Gentoo Bugzilla: no reports about rp-pppoe. So I think: apparently I am the only one with this problem, so it is perhaps due to my settings:

Why do I need rp-pppoe?

Code:
equery depends rp-pppoe
 * These packages depend on rp-pppoe:
net-misc/networkmanager-0.9.10.1_pre20141101 (ppp ? net-dialup/rp-pppoe)


Ahaaa. So I try:

Code:
USE="-ppp" emerge -auvDN world

These are the packages that would be merged, in order:

Calculating dependencies |

!!! Problem resolving dependencies for net-misc/networkmanager from @selected
... done!

!!! The ebuild selected to satisfy "net-misc/networkmanager" has unmet requirements.
- net-misc/networkmanager-0.9.10.1_pre20141101::gentoo USE="bluetooth dhclient introspection modemmanager ncurses nss systemd wext wifi -connection-sharing (-consolekit) -dhcpcd -gnutls -ppp -resolvconf (-selinux) -teamd -test -vala -zeroconf" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    modemmanager? ( ppp )


Mmmm, let's go one step further then:

Code:
USE="-ppp -modemmanager" emerge -auvDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/babl-0.1.10-r1  USE="(-altivec) (-mmx%*) (-sse%*)" CPU_FLAGS_X86="mmx%* sse%*" 440 KiB
[ebuild   R    ] app-misc/geoclue-2.1.10:2.0  USE="-modemmanager*" 0 KiB
[ebuild  N     ] net-dialup/rp-pppoe-3.8-r2  USE="X" 208 KiB
[ebuild     U  ] net-libs/webkit-gtk-2.4.8:3/25 [2.4.7:3/25] USE="X egl geoloc gstreamer introspection jit libsecret opengl spell webgl (-aqua) -coverage -debug -gles2 {-test} -wayland" 0 KiB
[ebuild   R    ] media-libs/gegl-0.2.0-r2  USE="cairo jpeg png sdl svg -debug -ffmpeg -jpeg2k -lensfun -openexr -raw -umfpack (-mmx%*) (-sse%*)" CPU_FLAGS_X86="mmx%* sse%*" 7,327 KiB
[ebuild   R    ] media-gfx/gimp-2.8.10-r1:2  USE="alsa bzip2 dbus exif gnome jpeg lcms mng pdf png svg tiff udev -aalib (-altivec) (-aqua) -curl -debug -doc -jpeg2k -postscript -python -smp -webkit -wmf -xpm (-mmx%*) (-sse%*)" CPU_FLAGS_X86="mmx%* sse%*" LINGUAS="ja -am -ar -ast -az -be -bg -br -ca -ca@valencia -cs -csb -da -de -dz -el -en_CA -en_GB -eo -es -et -eu -fa -fi -fr -ga -gl -gu -he -hi -hr -hu -id -is -it -ka -kk -km -kn -ko -lt -lv -mk -ml -ms -my -nb -nds -ne -nl -nn -oc -pa -pl -pt -pt_BR -ro -ru -rw -si -sk -sl -sr -sr@latin -sv -ta -te -th -tr -tt -uk -vi -xh -yi -zh_CN -zh_HK -zh_TW" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild     U  ] app-office/libreoffice-4.2.8.2 [4.2.6.3] USE="bluetooth branding cups dbus eds gnome gstreamer gtk opengl vba webdav (-aqua) -debug (-firebird) -gtk3 -java -jemalloc -kde -mysql -odk -postgres -telepathy {-test} -vlc" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 0 KiB
[ebuild     U  ] gnome-base/gdm-3.12.2-r2 [3.12.2-r1] USE="branding introspection ipv6 systemd tcpd -accessibility -audit -debug -fprint -plymouth (-selinux) -smartcard {-test} -wayland -xinerama" 0 KiB

Total: 8 packages (3 upgrades, 1 new, 4 reinstalls), Size of downloads: 7,974 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/numpy:0

  (dev-python/numpy-1.9.0-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    <dev-python/numpy-1.9.0[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-)] required by (dev-python/matplotlib-1.3.0-r1:0/0::gentoo, installed)
    ^                 ^^^^^                                                                                                                               

net-misc/networkmanager:0

  (net-misc/networkmanager-0.9.10.1_pre20141101:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=net-misc/networkmanager-0.9.8[modemmanager] required by (gnome-base/gnome-control-center-3.12.1-r1:2/2::gentoo, installed)


Note that the stupid rp-pppoe is back in the list again! Aha, so gnome-control-center requires networkmanager, compiled with modemmanager USE flag and that apparently triggers the ppp USE flag and that causes rp-pppoe to be rebuilt....

Questions:

- apparently I am the only one with this problem. Why? I have done
Code:
emerge --sync
several times over the last weeks and I am still bocked on the rp-pppoe that doesn't download

- is there a replacement package that I can use instead of rp-pppoe?


Last edited by WvR on Mon Feb 02, 2015 4:12 am; edited 1 time in total
Back to top
View user's profile Send private message
jburns
Veteran
Veteran


Joined: 18 Jan 2007
Posts: 1055
Location: Massachusetts USA

PostPosted: Sat Jan 31, 2015 6:06 am    Post subject: Reply with quote

You also need to clear the USE flag modemmanager.

Edit

gnome-base/gnome-control-center requires the USE flag modemmanager and it is not optional. Therefore modemmanager and ppp can not be cleared.
Back to top
View user's profile Send private message
dlaor
n00b
n00b


Joined: 27 Jan 2008
Posts: 55

PostPosted: Sat Jan 31, 2015 12:19 pm    Post subject: Reply with quote

It looks like they've changed the path; I would think that you can now obtain the source from

https://www.roaringpenguin.com/files/download/

If you trust this, then you can copy the "rp-pppoe-3.8.tar.gz" file from there into your "../portage/distfiles" directory; I would expect this to solve your problem.

Hope this helps!
Back to top
View user's profile Send private message
WvR
Apprentice
Apprentice


Joined: 03 Mar 2011
Posts: 181
Location: Tsuruga, Japan

PostPosted: Mon Feb 02, 2015 4:11 am    Post subject: Reply with quote

I "solved" (mwa, worked around) the problem by allowing the ~amd64 keyword on rp-pppoe; it now installs a newer version (3.11) for which the ebuild does provide the correct URL.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum