Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge gnome-base/gnome command unable to install GNOME
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sco1984
n00b
n00b


Joined: 04 Apr 2012
Posts: 16
Location: India

PostPosted: Wed Jan 28, 2015 4:53 pm    Post subject: emerge gnome-base/gnome command unable to install GNOME Reply with quote

Hello,

I installed Gentoo just now using install-amd64-minimal-20141204 iso.
When I am trying to install GNOME I am getting dependancy warnings.

Do I need to add all these mentioned parameters in 'USE' option in make.conf file?
Pls sugest.

Here is the output after running 'emerge gnome-base/gnome' command >>

----------------------------------------------------------------------------

gentoo portage # emerge gnome-base/gnome
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

(dev-libs/glib-2.40.0-r1::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-libs/glib-2.40.2::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/glib-2.40.2:2 required by (dev-util/gdbus-codegen-2.40.2::gentoo, ebuild scheduled for merge)

dev-libs/libxml2:2

(dev-libs/libxml2-2.9.2::gentoo, ebuild scheduled for merge) pulled in by
dev-libs/libxml2[python,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),python_single_target_python2_7(+)] required by (app-admin/system-config-printer-common-1.4.3::gentoo, ebuild scheduled for merge)
dev-libs/libxml2[python,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),python_single_target_python2_7(+)] required by (dev-util/itstool-2.0.2::gentoo, ebuild scheduled for merge)

(dev-libs/libxml2-2.9.1-r4::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by sys-apps/systemd-216-r3
# required by sys-apps/gentoo-systemd-integration-4
=sys-apps/dbus-1.8.10 systemd

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

!!! The ebuild selected to satisfy ">=app-misc/tracker-1" has unmet requirements.
- app-misc/tracker-1.0.6::gentoo USE="exif ffmpeg flac gif gstreamer gtk iso jpeg miner-fs mp3 nautilus pdf tiff upower vorbis xml -cue (-eds) -firefox-bookmarks -gsf -iptc -networkmanager -playlist -rss -test -thunderbird -upnp-av -xmp -xps" ABI_X86="64"

The following REQUIRED_USE flag constraints are unsatisfied:
at-most-one-of ( gstreamer ffmpeg )

The above constraints are a subset of the following complete expression:
at-most-one-of ( gstreamer ffmpeg ) cue? ( gstreamer ) upnp-av? ( gstreamer ) !miner-fs? ( !cue !exif !flac !gif !gsf !iptc !iso !jpeg !mp3 !pdf !playlist !tiff !vorbis !xml !xmp !xps )

(dependency required by "gnome-base/gnome-extra-apps-3.12.0-r1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.12.0[extras]" [ebuild])
(dependency required by "gnome-base/gnome" [argument])
gentoo portage # emerge package.mask gnome-base/gnome
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "package.mask".

emerge: searching for similar names...
emerge: Maybe you meant any of these: app-admin/packagekit, dev-perl/Package-Stash, kde-frameworks/kpackage?
gentoo portage #
--------------------------------------------------------------------------

Regards,
AmeY.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2889
Location: Illinois, USA

PostPosted: Wed Jan 28, 2015 6:08 pm    Post subject: Reply with quote

welcome to the borg
Back to top
View user's profile Send private message
cyrevolt
n00b
n00b


Joined: 10 Jan 2015
Posts: 4

PostPosted: Thu Jan 29, 2015 7:29 am    Post subject: Reply with quote

First do all of what is explained here:
http://wiki.gentoo.org/wiki/Systemd/Installing_Gnome3_from_scratch

You'll need to fight with systemd first before you can stamd before GNOME. Both are quite heavy... but since you're still in the beginning, you won't have to rebuild too many packages. :D

Quick overview: Choose the desktop + GNOME + systemd profile, emerge -DuN @world, emerge xorg and gnome, systemctl enable gdm.

But read the above article carefully! ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum