Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NVIDIA Driver with Optimus Laptops without Bumblebee [SOLVED
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1583
Location: /mnt/Gentoo/Europe

PostPosted: Mon Dec 29, 2014 2:04 pm    Post subject: NVIDIA Driver with Optimus Laptops without Bumblebee [SOLVED Reply with quote

Hi,

I have found this article (updated 2 days ago):
NVIDIA Driver with Optimus Laptops
http://wiki.gentoo.org/wiki/NVIDIA_Driver_with_Optimus_Laptops

At the moment I use nvidia optimus with bumblebee and primusrun & optirun.

My question:
[1] Did anyone had any problems during migration from Optimus support by bumblebee into the proper driver?
[2] Is the performance better than provided by bumblebee - especially in games (supported by steam or wine)?

Update! I did tested, but it did not work.

Code:
$ cat .xinitrc
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto
exec startkde


Code:
# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 630M] (rev ff)


xorg.conf
Code:
Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection


Xorg.0.log
Code:
[  3741.654]
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.
[  3741.654]
X.Org X Server 1.16.2.901 (1.16.3 RC 1)
Release Date: 2014-12-09
[  3741.654] X Protocol Version 11, Revision 0
[  3741.654] Build Operating System: Linux 3.17.4-gentoo x86_64 Gentoo
[  3741.654] Current Operating System: Linux tux 3.18.1-gentoo #2 SMP Tue Dec 23 12:38:48 GMT 2014 x86_64
[  3741.654] Kernel command line: root=/dev/sda2 vga=792
[  3741.654] Build Date: 10 December 2014  09:36:54AM
[  3741.654] 
[  3741.654] Current version of pixman: 0.32.6
[  3741.654]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  3741.654] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3741.654] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Dec 29 21:08:39 2014
[  3741.654] (==) Using config file: "/etc/X11/xorg.conf"
[  3741.654] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3741.654] (==) ServerLayout "layout"
[  3741.654] (**) |-->Screen "nvidia" (0)
[  3741.654] (**) |   |-->Monitor "<default monitor>"
[  3741.654] (**) |   |-->Device "nvidia"
[  3741.654] (==) No monitor specified for screen "nvidia".
   Using a default monitor configuration.
[  3741.655] (**) |-->Inactive Device "intel"
[  3741.655] (==) Automatically adding devices
[  3741.655] (==) Automatically enabling devices
[  3741.655] (==) Automatically adding GPU devices
[  3741.655] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  3741.655]    Entry deleted from font path.
[  3741.655] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  3741.655]    Entry deleted from font path.
[  3741.655] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  3741.655]    Entry deleted from font path.
[  3741.655] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  3741.655]    Entry deleted from font path.
[  3741.655]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  3741.655] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  3741.655]    Entry deleted from font path.
[  3741.655]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  3741.655] (==) FontPath set to:
   /usr/share/fonts/misc/
[  3741.655] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  3741.655] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  3741.655] (II) Loader magic: 0x805c80
[  3741.655] (II) Module ABI versions:
[  3741.655]    X.Org ANSI C Emulation: 0.4
[  3741.655]    X.Org Video Driver: 18.0
[  3741.655]    X.Org XInput driver : 21.0
[  3741.655]    X.Org Server Extension : 8.0
[  3741.655] (II) xfree86: Adding drm device (/dev/dri/card0)
[  3741.656] (--) PCI:*(0:0:2:0) 8086:0126:1558:2703 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[  3741.656] (II) LoadModule: "glx"
[  3741.656] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  3741.658] (II) Module glx: vendor="X.Org Foundation"
[  3741.658]    compiled for 1.16.2.901, module version = 1.0.0
[  3741.658]    ABI class: X.Org Server Extension, version 8.0
[  3741.658] (==) AIGLX enabled
[  3741.658] (II) LoadModule: "nvidia"
[  3741.658] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  3741.658] (II) Module nvidia: vendor="NVIDIA Corporation"
[  3741.658]    compiled for 4.0.2, module version = 1.0.0
[  3741.658]    Module class: X.Org Video Driver
[  3741.658] (II) LoadModule: "modesetting"
[  3741.658] (WW) Warning, couldn't open module modesetting
[  3741.658] (II) UnloadModule: "modesetting"
[  3741.658] (II) Unloading modesetting
[  3741.658] (EE) Failed to load module "modesetting" (module does not exist, 0)
[  3741.658] (II) NVIDIA dlloader X Driver  346.22  Tue Dec  2 09:58:48 PST 2014
[  3741.658] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  3741.658] (--) using VT number 7

[  3741.663] (EE) No devices detected.
[  3741.663] (EE)
Fatal server error:
[  3741.663] (EE) no screens found(EE)
[  3741.663] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  3741.663] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  3741.663] (EE)


Last edited by Xywa on Mon Jan 12, 2015 11:10 am; edited 1 time in total
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Tue Dec 30, 2014 9:36 am    Post subject: Reply with quote

If I understand this article correctly, it means using the nvidia card permanently and just copying its output through the intel card. So actually this renders all battery saving methods useless, right?

However, I guess you have to completely disable bumblebee and bbswitch so the card does not get turned off. Otherwise it wouldn't work if bbswitch is loaded and disables the card.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1583
Location: /mnt/Gentoo/Europe

PostPosted: Fri Jan 09, 2015 11:38 am    Post subject: Reply with quote

The problem in my first topic was with modesetting (Xorg.0.log)
Code:
[  3741.658] (EE) Failed to load module "modesetting" (module does not exist, 0)

and on Arch Wiki manual about Nvidia Optimus I found, the modesetting package MUST be instaled:
https://wiki.archlinux.org/index.php/NVIDIA_Optimus
Quote:
First install the modesetting and nvidia drivers:
Code:
# pacman -S xf86-video-modesetting nvidia

There was no such information on Gento Wiki about Nvidia Optimus, but I found there is such package xf86-video-modesetting in portage, i am missing it, so I have installed it.
Code:
*  x11-drivers/xf86-video-modesetting
      Latest version available: 0.9.0
      Latest version installed: 0.9.0
      Size of files: 298 KiB
      Homepage:      http://xorg.freedesktop.org/
      Description:   Unaccelerated generic driver for kernel modesetting
      License:       MIT


After this my X starts, but... with the blank screen. I was trying 2 times, and with different opengl, the same result - black screen.
Code:
# eselect opengl list
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *


Here my logs:

Xorg.0.log (opengl nvidia)
http://pastebin.com/5iMVeETa

Xorg.0.log (opengl xorg-x11)
http://pastebin.com/Z4FU1k9B

At the end of Xorg.0.log (opengl nvidia) we have
Code:
[  1944.364] (WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0

errors:
Code:
[  1942.496] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Invalid argument

Code:
[  1942.513] (EE) Screen 1 deleted because of no matching config section.

Code:
[  1943.204] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Invalid argument


but at the end of Xorg.0.log (opengl xorg-x11) we have
Code:
[  2370.741] (WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
[  2418.355] (II) NVIDIA(0): Setting mode "CRT-0:nvidia-auto-select"
[  2418.457] (WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
[  2418.730] (II) modesetting(G0): EDID vendor "CMO", prod id 5913
[  2418.730] (II) modesetting(G0): Printing DDC gathered Modelines:
[  2418.730] (II) modesetting(G0): Modeline "1600x900"x0.0  107.80  1600 1648 1680 1940  900 903 908 926 -hsync -vsync (55.6 kHz eP)

so looks like system manage to get EDID, but why the screen is black?
and errors:
Code:
[  2369.092] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Invalid argument

Code:
[  2369.102] (EE) Screen 1 deleted because of no matching config section.

Code:
[  2369.103] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[  2369.103] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[  2369.103] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[  2369.103] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[  2369.103] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.

Code:
[  2369.697] (EE) AIGLX: reverting to software rendering

Code:
[  2369.773] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Invalid argument


...and there is no nvidia here:
Code:
$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x47 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 3 outputs: 5 associated providers: 0 name:Intel
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1583
Location: /mnt/Gentoo/Europe

PostPosted: Mon Jan 12, 2015 11:07 am    Post subject: Reply with quote

This did the job! [SOLVED] :D :D 8) 8) :D :D 8) 8) :P :P

Code:
$ cat /etc/portage/package.mask
>x11-drivers/nvidia-drivers-343.36
>sys-kernel/gentoo-sources-3.17.7


- Some games works better - War Thunder has about 10-15 fps more.
- Eve Online through PlayOnLinux have lost few fps - some problem between nvidia and wine.
- Performance in kde (OpenGL) - very slow in comparation to Intel.
- Noisy in KDE :( - as I use few OpenGL effects, which were very smooth on intel in comparation to nvida, and the laptop was quiet - now I can hear the noise of the graphic card. :( Is it possible to switch between Intel and Nvidia in Gentoo? I know there is such options for Ubuntu
http://i.stack.imgur.com/ovYdQ.png
Back to top
View user's profile Send private message
zebbedi
Tux's lil' helper
Tux's lil' helper


Joined: 05 Sep 2003
Posts: 118

PostPosted: Tue Jan 13, 2015 8:49 am    Post subject: Reply with quote

I've just been through the pain of setting this up also! Instead of manually emerging modesetting, you can add the following line to your make.conf:

VIDEO_CARDS="nvidia intel modesetting"


Then just do an emerge -upDN world. Only problem I've got so far is that I use KDM and so had to put the xrandr lines in my XSetup instead of .xinitrc. At the point of it starting though the screen background image gets repeated across the screen.
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1583
Location: /mnt/Gentoo/Europe

PostPosted: Tue Jan 13, 2015 9:00 pm    Post subject: Reply with quote

zebbedi wrote:
I've just been through the pain of setting this up also! Instead of manually emerging modesetting, you can add the following line to your make.conf:

VIDEO_CARDS="nvidia intel modesetting"


Then just do an emerge -upDN world. Only problem I've got so far is that I use KDM and so had to put the xrandr lines in my XSetup instead of .xinitrc. At the point of it starting though the screen background image gets repeated across the screen.


Have you tried to decrease your kernel to 3.17.7? This fixed my problems so far.
Back to top
View user's profile Send private message
zebbedi
Tux's lil' helper
Tux's lil' helper


Joined: 05 Sep 2003
Posts: 118

PostPosted: Wed Jan 14, 2015 8:09 am    Post subject: Reply with quote

I am using 3.17.7.

I think i may have resolved it. I changed the option in my xorg.conf file under the 'Screen' section from

Code:

Section "Screen"
    Identifier      "nvidia"
    Device          "nvidia"
    Option          "UseDisplayDevice" "none"
EndSection


to

Code:

Section "Screen"
    Identifier      "nvidia"
    Device          "nvidia"
    Option          "AllowEmptyInitialConfiguration"
EndSection



by the way, do you use a docking station?
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1583
Location: /mnt/Gentoo/Europe

PostPosted: Thu Jan 15, 2015 10:07 am    Post subject: Reply with quote

This is my xorg.conf which works fine.
I had downgrade system to x11-drivers/nvidia-drivers-343.36 and sys-kernel/gentoo-sources-3.17.7

1920x1080_Clevo_W670SR.bin -> name of the file comes for Gentoo Wiki, but better should be my_custom_edid.bin. I had to manually make folder /lib/firmware/edid/ (as commend get-edid from Gentoo Wiki could not generate .bin file to the folder, which did not exist).
In my case system was asking for CRT-0 (DFP-0 in Gentoo Wiki example)


Code:
Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    # e.g. BusID "PCI:1:0:0"
    Option "ConnectedMonitor" "CRT-0"
    Option "CustomEDID" "CRT-0:/lib/firmware/edid/1920x1080_Clevo_W670SR.bin"
    Option "UseEDID" "True"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    Option "CustomEDID" "CRT-0:/lib/firmware/edid/1920x1080_Clevo_W670SR.bin"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection
Back to top
View user's profile Send private message
webknjaz
n00b
n00b


Joined: 29 Oct 2014
Posts: 6

PostPosted: Thu Jan 22, 2015 8:55 am    Post subject: Reply with quote

Hi,

I have the same issue (blank screen).

But this
Xywa wrote:
This did the job! [SOLVED] :D :D 8) 8) :D :D 8) 8) :P :P

Code:
$ cat /etc/portage/package.mask
>x11-drivers/nvidia-drivers-343.36
>sys-kernel/gentoo-sources-3.17.7


- Some games works better - War Thunder has about 10-15 fps more.
- Eve Online through PlayOnLinux have lost few fps - some problem between nvidia and wine.
- Performance in kde (OpenGL) - very slow in comparation to Intel.
- Noisy in KDE :( - as I use few OpenGL effects, which were very smooth on intel in comparation to nvida, and the laptop was quiet - now I can hear the noise of the graphic card. :( Is it possible to switch between Intel and Nvidia in Gentoo? I know there is such options for Ubuntu
http://i.stack.imgur.com/ovYdQ.png

doesn't help. If I downgrade kernel and nvidia-drivers I get following API mismatch during boot (dmesg):
Code:
NVRM: API mismatch: the client has the version 343.36, but
NVRM: this kernel module has the version 346.35.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

It looks like I should downgrade kernel module, but what are the steps to do this? I made downgrades w/ emerge and rebuilt kernel with no success.

My env:
Code:
⚡ eix nvidia-drivers             
[I] x11-drivers/nvidia-drivers
     Available versions:  [M]96.43.23^msd [M]173.14.39^msd 304.125^msd 331.113^msd 340.65^msd 343.36^msd [m](~)346.35^msd {+X acpi custom-cflags gtk gtk2 gtk3 multilib pax_kernel (+)tools uvm KERNEL="FreeBSD linux"}
     Installed versions:  343.36^msd(10:35:11 01/22/15)(X acpi multilib tools uvm -pax_kernel KERNEL="linux -FreeBSD")
     Homepage:            http://www.nvidia.com/
     Description:         NVIDIA Accelerated Graphics Driver


Code:
⚡ sudo eselect kernel list       
Available kernel symlink targets:
  [1]   linux-3.16.7-geek
  [2]   linux-3.17.3-gentoo
  [3]   linux-3.17.4-gentoo
  [4]   linux-3.17.7-gentoo *
  [5]   linux-3.18.0-gentoo
  [6]   linux-3.18.1-gentoo


Code:
⚡ uname -a
Linux webknjaz-laptop-wlan 3.18.1-gentoo #1 SMP Wed Jan 21 18:59:57 EET 2015 x86_64 Intel(R) Core(TM) i7-4500U CPU @ 1.80GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
zebbedi
Tux's lil' helper
Tux's lil' helper


Joined: 05 Sep 2003
Posts: 118

PostPosted: Thu Jan 22, 2015 10:45 am    Post subject: Reply with quote

Rebuild your kernel, making it the active one, then compile the nvidia drivers.
Back to top
View user's profile Send private message
webknjaz
n00b
n00b


Joined: 29 Oct 2014
Posts: 6

PostPosted: Thu Jan 22, 2015 9:14 pm    Post subject: Reply with quote

zebbedi wrote:
Rebuild your kernel, making it the active one, then compile the nvidia drivers.


I tried doing this lots of times. It didn't help.
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1583
Location: /mnt/Gentoo/Europe

PostPosted: Thu Jan 22, 2015 9:19 pm    Post subject: Reply with quote

webknjaz wrote:
doesn't help. If I downgrade kernel and nvidia-drivers I get following API mismatch during boot (dmesg):
Code:
NVRM: API mismatch: the client has the version 343.36, but
NVRM: this kernel module has the version 346.35.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

It looks like I should downgrade kernel module, but what are the steps to do this? I made downgrades w/ emerge and rebuilt kernel with no success.


Have you rebuild your modules after changing kernel?
Code:
root #make modules_prepare

Code:
root #emerge --ask @module-rebuild

http://wiki.gentoo.org/wiki/Kernel/Upgrade
Back to top
View user's profile Send private message
webknjaz
n00b
n00b


Joined: 29 Oct 2014
Posts: 6

PostPosted: Thu Jan 22, 2015 11:28 pm    Post subject: Reply with quote

Xywa wrote:
webknjaz wrote:
doesn't help. If I downgrade kernel and nvidia-drivers I get following API mismatch during boot (dmesg):
Code:
NVRM: API mismatch: the client has the version 343.36, but
NVRM: this kernel module has the version 346.35.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

It looks like I should downgrade kernel module, but what are the steps to do this? I made downgrades w/ emerge and rebuilt kernel with no success.


Have you rebuild your modules after changing kernel?
Code:
root #make modules_prepare

Code:
root #emerge --ask @module-rebuild

http://wiki.gentoo.org/wiki/Kernel/Upgrade

Yes. And still same "API mismatch" problem :(
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1583
Location: /mnt/Gentoo/Europe

PostPosted: Fri Jan 23, 2015 8:44 am    Post subject: Reply with quote

webknjaz wrote:
Yes. And still same "API mismatch" problem :(


When is the problem, during system boot?

Have you made
Code:
make install

after kernel compilation?
Back to top
View user's profile Send private message
webknjaz
n00b
n00b


Joined: 29 Oct 2014
Posts: 6

PostPosted: Sat Jan 24, 2015 12:23 am    Post subject: Reply with quote

Xywa wrote:
webknjaz wrote:
Yes. And still same "API mismatch" problem :(


When is the problem, during system boot?

Yes, when systemd loads kernel modules. And if I try doing `modprobe nvidia` I get exactly same output.

Xywa wrote:

Have you made
Code:
make install

after kernel compilation?


I use genkernel, which does this for me. I cannot understand where does system get additional version of nvidia module even if I rebuild kernel and modules.
Back to top
View user's profile Send private message
Astronaut
n00b
n00b


Joined: 06 Oct 2012
Posts: 38
Location: RA 14h 15m 40s | Dec 19° 10.932'

PostPosted: Fri Jan 30, 2015 12:02 am    Post subject: Reply with quote

Hello,

I'd need some help here; I did exactly the same steps as you but I ended up with a black screen upon kdm login, Xorg.0.log shows this error

Code:
"Screen 1 deleted because of no matching section"


Additional info:

Code:
lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 635M] (rev a1)



Code:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    # Uncomment this line if your computer has no display devices connected to
    # the NVIDIA GPU.  Leave it commented if you have display devices
    # connected to the NVIDIA GPU that you would like to use.
    #Option "UseDisplayDevice" "none"
    Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID  "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection



Code:
cat /usr/share/config/kdm/Xsetup
#! /bin/sh

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto


Code:
uname -r
3.17.7-gentoo


Code:
eix -Ic nvidia-drivers
[I] x11-drivers/nvidia-drivers (343.36@01/29/2015): NVIDIA Accelerated Graphics Driver


EDIT: solved by removing xorg.conf! however I noticed that glxspheres are at 60 FPS (using nvidia)!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum