Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Freetype with infinality patches looks weird
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Neg
n00b
n00b


Joined: 26 Jan 2015
Posts: 3

PostPosted: Mon Jan 26, 2015 7:43 pm    Post subject: Freetype with infinality patches looks weird Reply with quote

I used arch before moving to gentoo. I have used freetype-infinality-git patches in it. I have tiny fonts without aliasing which was great to me. Now, after migration something goes bad. I have weird hinting artefacts with goole play and another fonts too. Example: http://i.imgur.com/JZjYiEX.png. I have this artefacts in gtk applications. Also skype use gtk-like theme and looks bad.

Maybe someone share with me better config?

My freetype
Code:

[I] media-libs/freetype
     Available versions:  (2) 2.5.3-r1 ~2.5.4-r1 (~)2.5.5
       {X +adobe-cff auto-hinter bindist bzip2 debug doc fontforge harfbuzz infinality png static-libs utils ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  2.5.5(2)(10:45:35 AM 01/26/2015)(X bzip2 infinality png -adobe-cff -auto-hinter -bindist -debug -doc -fontforge -harfbuzz -static-libs -utils ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Homepage:            http://www.freetype.org/
     Description:         A high-quality and portable font engine


Code:


my infinality lcdfilter conf:

[/etc/fonts] >> s eselect lcdfilter show
Current lcdfilter style symlink:
  /usr/share/eselect-lcdfilter/env.d/custom
[/etc/fonts] >> < /usr/share/eselect-lcdfilter/env.d/custom
INFINALITY_FT_AUTOHINT_HORIZONTAL_STEM_DARKEN_STRENGTH="10"
INFINALITY_FT_AUTOHINT_INCREASE_GLYPH_HEIGHTS="true"
INFINALITY_FT_AUTOHINT_SNAP_STEM_HEIGHT="100"
INFINALITY_FT_AUTOHINT_VERTICAL_STEM_DARKEN_STRENGTH="25"
INFINALITY_FT_BOLD_EMBOLDEN_X_VALUE="0"
INFINALITY_FT_BOLD_EMBOLDEN_Y_VALUE="0"
INFINALITY_FT_BRIGHTNESS="20"
INFINALITY_FT_CHROMEOS_STYLE_SHARPENING_STRENGTH="15"
INFINALITY_FT_CONTRAST="40"
INFINALITY_FT_FILTER_PARAMS="11 22 38 22 11"
INFINALITY_FT_FRINGE_FILTER_STRENGTH="100"
INFINALITY_FT_GAMMA_CORRECTION="1000 80"
INFINALITY_FT_GLOBAL_EMBOLDEN_X_VALUE="0"
INFINALITY_FT_GLOBAL_EMBOLDEN_Y_VALUE="0"
INFINALITY_FT_GRAYSCALE_FILTER_STRENGTH="0"
INFINALITY_FT_STEM_ALIGNMENT_STRENGTH="0"
INFINALITY_FT_STEM_FITTING_STRENGTH="0"
INFINALITY_FT_STEM_SNAPPING_SLIDING_SCALE="18"
INFINALITY_FT_USE_KNOWN_SETTINGS_ON_SELECTED_FONTS="false"
INFINALITY_FT_USE_VARIOUS_TWEAKS="true"
INFINALITY_FT_WINDOWS_STYLE_SHARPENING_STRENGTH="0"


INFINALITY_FT_GLOBAL_EMBOLDEN_X_VALUE=0
INFINALITY_FT_GLOBAL_EMBOLDEN_Y_VALUE=0
INFINALITY_FT_BOLD_EMBOLDEN_X_VALUE=0
INFINALITY_FT_BOLD_EMBOLDEN_Y_VALUE=0


my conf.d:

Code:

[/etc/fonts] >> l conf.d
 ▏-rw-r--r-- ▏  2h │227B│08-munin-font-dir.conf
 ▏lrwxrwxrwx ▏  2h │ 39B│10-powerline-symbols.conf → ../conf.avail/10-powerline-symbols.conf
 ▏lrwxrwxrwx ▏  2h │ 48B│10-scale-bitmap-fonts.conf → /etc/fonts/conf.avail/10-scale-bitmap-fonts.conf
 ▏lrwxrwxrwx ▏  2h │ 46B│20-unhint-small-dejavu-sans.conf → ../conf.avail/20-unhint-small-dejavu-sans.conf
 ▏lrwxrwxrwx ▏  2h │ 51B│20-unhint-small-dejavu-sans-mono.conf → ../conf.avail/20-unhint-small-dejavu-sans-mono.conf
 ▏lrwxrwxrwx ▏  2h │ 47B│20-unhint-small-dejavu-serif.conf → ../conf.avail/20-unhint-small-dejavu-serif.conf
 ▏lrwxrwxrwx ▏  2h │ 47B│20-unhint-small-vera.conf → /etc/fonts/conf.avail/20-unhint-small-vera.conf
 ▏lrwxrwxrwx ▏  2h │ 44B│30-metric-aliases.conf → /etc/fonts/conf.avail/30-metric-aliases.conf
 ▏lrwxrwxrwx ▏  2h │ 41B│30-urw-aliases.conf → /etc/fonts/conf.avail/30-urw-aliases.conf
 ▏lrwxrwxrwx ▏  2h │ 35B│30-win32-aliases.conf → ../conf.avail/30-win32-aliases.conf
 ▏lrwxrwxrwx ▏  2h │ 38B│40-nonlatin.conf → /etc/fonts/conf.avail/40-nonlatin.conf
 ▏lrwxrwxrwx ▏  2h │ 35B│45-latin.conf → /etc/fonts/conf.avail/45-latin.conf
 ▏lrwxrwxrwx ▏  2h │ 39B│49-sansserif.conf → /etc/fonts/conf.avail/49-sansserif.conf
 ▏lrwxrwxrwx ▏  2h │ 34B│50-user.conf → /etc/fonts/conf.avail/50-user.conf
 ▏lrwxrwxrwx ▏  2h │ 35B│51-local.conf → /etc/fonts/conf.avail/51-local.conf
 ▏lrwxrwxrwx ▏  2h │ 32B│52-infinality.conf → ../conf.avail/52-infinality.conf
 ▏lrwxrwxrwx ▏  2h │ 33B│57-dejavu-sans.conf → ../conf.avail/57-dejavu-sans.conf
 ▏lrwxrwxrwx ▏  2h │ 38B│57-dejavu-sans-mono.conf → ../conf.avail/57-dejavu-sans-mono.conf
 ▏lrwxrwxrwx ▏  2h │ 34B│57-dejavu-serif.conf → ../conf.avail/57-dejavu-serif.conf
 ▏lrwxrwxrwx ▏  2h │ 35B│60-latin.conf → /etc/fonts/conf.avail/60-latin.conf
 ▏lrwxrwxrwx ▏  2h │ 43B│65-fonts-persian.conf → /etc/fonts/conf.avail/65-fonts-persian.conf
 ▏lrwxrwxrwx ▏  2h │ 38B│65-nonlatin.conf → /etc/fonts/conf.avail/65-nonlatin.conf
 ▏lrwxrwxrwx ▏  2h │ 37B│69-unifont.conf → /etc/fonts/conf.avail/69-unifont.conf
 ▏lrwxrwxrwx ▏  2h │ 39B│80-delicious.conf → /etc/fonts/conf.avail/80-delicious.conf
 ▏lrwxrwxrwx ▏  2h │ 39B│90-synthetic.conf → /etc/fonts/conf.avail/90-synthetic.conf
 ▏-rw-r--r-- ▏  2h │366B│99pdftoopvp.conf
 ▏-rw-r--r-- ▏  2h │978B│README


infinality config:
Code:

[/etc/fonts] >> l ./infinality/conf.d
 ▏lrwxrwxrwx ▏ 11h │ 28B│conf.d → styles.conf.avail/infinality

[/etc/fonts] >> l infinality/styles.conf.avail/infinality
 ▏lrwxrwxrwx ▏ 11h │ 42B│20-aliases-default-inf.conf → ../../conf.src/20-aliases-default-inf.conf
 ▏lrwxrwxrwx ▏ 11h │ 36B│20-fix-cantarell.conf → ../../conf.src/20-fix-cantarell.conf
 ▏lrwxrwxrwx ▏ 11h │ 44B│21-aliases-wine-win7-inf.conf → ../../conf.src/21-aliases-wine-win7-inf.conf
 ▏lrwxrwxrwx ▏ 11h │ 40B│30-non-latin-inf-win.conf → ../../conf.src/30-non-latin-inf-win.conf
 ▏lrwxrwxrwx ▏ 11h │ 34B│41-repl-os-inf.conf → ../../conf.src/41-repl-os-inf.conf
 ▏lrwxrwxrwx ▏ 11h │ 34B│42-repl-global.conf → ../../conf.src/42-repl-global.conf
 ▏lrwxrwxrwx ▏ 11h │ 44B│43-repl-tt-traced-bitmap.conf → ../../conf.src/43-repl-tt-traced-bitmap.conf
 ▏lrwxrwxrwx ▏ 11h │ 38B│44-repl-corrective.conf → ../../conf.src/44-repl-corrective.conf
 ▏lrwxrwxrwx ▏ 11h │ 49B│50-base-rendering-inf-osx-lin.conf → ../../conf.src/50-base-rendering-inf-osx-lin.conf
 ▏lrwxrwxrwx ▏ 11h │ 41B│60-group-non-tt-fonts.conf → ../../conf.src/60-group-non-tt-fonts.conf
 ▏lrwxrwxrwx ▏ 11h │ 37B│60-group-tt-fonts.conf → ../../conf.src/60-group-tt-fonts.conf
 ▏lrwxrwxrwx ▏ 11h │ 58B│61-group-non-tt-rendering-inf-7-xp-lin.conf → ../../conf.src/61-group-non-tt-rendering-inf-7-xp-lin.conf
 ▏lrwxrwxrwx ▏ 11h │ 50B│61-group-tt-rendering-inf-7-xp.conf → ../../conf.src/61-group-tt-rendering-inf-7-xp.conf
 ▏lrwxrwxrwx ▏ 11h │ 45B│62-tt-monospace-rendering.conf → ../../conf.src/62-tt-monospace-rendering.conf
 ▏lrwxrwxrwx ▏ 11h │ 49B│62-tt-traced-bitmap-rendering.conf → ../../conf.src/62-tt-traced-bitmap-rendering.conf
 ▏lrwxrwxrwx ▏ 11h │ 35B│64-override-inf.conf → ../../conf.src/64-override-inf.conf
 ▏lrwxrwxrwx ▏ 11h │ 31B│65-override.conf → ../../conf.src/65-override.conf
 ▏lrwxrwxrwx ▏ 11h │ 39B│70-forced-synthetic.conf → ../../conf.src/70-forced-synthetic.conf
 ▏lrwxrwxrwx ▏ 11h │ 51B│80-selective-rendering-inf-7-xp.conf → ../../conf.src/80-selective-rendering-inf-7-xp.conf
 ▏lrwxrwxrwx ▏ 11h │ 54B│80-selective-rendering-inf-win-lin.conf → ../../conf.src/80-selective-rendering-inf-win-lin.conf
 ▏lrwxrwxrwx ▏ 11h │ 47B│81-final-rendering-inf-7-xp.conf → ../../conf.src/81-final-rendering-inf-7-xp.conf
 ▏lrwxrwxrwx ▏ 11h │ 35B│90-no-synthetic.conf → ../../conf.src/90-no-synthetic.conf
 ▏lrwxrwxrwx ▏ 11h │ 29B│90-reject.conf → ../../conf.src/90-reject.conf


I have also tried to copy my old configs from arch with cp -ar but it doesn't help
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Mon Jan 26, 2015 7:48 pm    Post subject: Reply with quote

Does it work with any of the predefined settings? (eselect infinality list, eselect lcdfilter list)
Back to top
View user's profile Send private message
Neg
n00b
n00b


Joined: 26 Jan 2015
Posts: 3

PostPosted: Mon Jan 26, 2015 8:40 pm    Post subject: Reply with quote

When I set linux-infinality

Code:

s eselect infinality set 3


It fix this issue. But fonts getting a bit blurry and tiny(in compare to arch with this settings)
Also when I os/win and others I have really bad hinting. With a "dot" above "O", too tiny glyphs. And with ms fonts and ms config it's getting totally unusable!
Of course I restart X server after every iteration of it.

Changes of lcdfilter doesn't get affect on it for me.
Back to top
View user's profile Send private message
Neg
n00b
n00b


Joined: 26 Jan 2015
Posts: 3

PostPosted: Mon Jan 26, 2015 9:15 pm    Post subject: Reply with quote

When I downgrade to freetype-2.4.12(2) everithing works best!
What I should do to fix it more generalized?

Infinality "support" for freetype-2.5 is WRONG for me. It is a cause of weird hinting.
But for some reason I have deps like here:

Code:

 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 *
 *   >=media-libs/freetype-2.5.0.1:2/2=[abi_x86_64(-)] pulled in by:
 *     media-libs/harfbuzz-0.9.28
 *
 *   >=media-libs/freetype-2.5.0.1:2=[abi_x86_64(-)] pulled in by:
 *     x11-libs/pango-1.36.8
 *
 *   >=media-libs/freetype-2.5.0.1:2/2=[abi_x86_64(-)] pulled in by:
 *     x11-libs/pango-1.36.8
 *
 *   >=media-libs/freetype-2.5.3-r1[abi_x86_64(-)] pulled in by:
 *     media-libs/fontconfig-2.11.1-r2
 *
 *   >=media-libs/freetype-2.5.0.1[abi_x86_64(-)] pulled in by:
 *     media-libs/gd-2.0.35-r4
 *
 *   >=media-libs/freetype-2.5.0.1:2=[abi_x86_64(-)] pulled in by:
 *     media-libs/harfbuzz-0.9.28
 *
 *   >=media-libs/freetype-2.5.0.1:2[abi_x86_64(-)] pulled in by:
 *     media-libs/libass-0.11.2
 *
 *   >=media-libs/freetype-2.5.0.1:2[abi_x86_64(-)] pulled in by:
 *     media-video/ffmpeg-2.2.12
 *
 *   >=media-libs/freetype-2.5.0.1[abi_x86_64(-)] pulled in by:
 *     x11-libs/libXft-2.3.1-r1


I know that arch works well with freetype-2.4. What I should to do? I'm not very experienced in gentoo yet, sorry.
When I run revdep-rebuild everything looks ok.
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 91

PostPosted: Fri Mar 27, 2015 5:36 pm    Post subject: Reply with quote

I don't have the answer but am interested in the solution. I have not tried infinality yet, but the fonts I have are terrible (in general).
Back to top
View user's profile Send private message
spectromas
n00b
n00b


Joined: 13 Jul 2014
Posts: 50

PostPosted: Sat Mar 28, 2015 2:09 pm    Post subject: Reply with quote

You could try fontconfig-ultimate - https://bpaste.net/show/d4c5da3ed7ff
I think there's a non-9999 version in the sunrise overlay but I noticed considerable improvements with the 9999 version. I think you will need to change media-fonts/notofonts to media-fonts/noto.
I don't know what's wrong with the default infinality stuff in gentoo, I could never get it right, there was always some odd kerning or other weirdness somewhere.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum