Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Some unicode characters aren't appearing in Gnome3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mr-simon
Guru
Guru


Joined: 22 Nov 2002
Posts: 362
Location: Leamington Spa, Warks, UK

PostPosted: Thu Jan 22, 2015 10:46 am    Post subject: Some unicode characters aren't appearing in Gnome3 Reply with quote

I've been away from Gentoo for a long time, but I thought I'd try it out again.

Setup was easier than I remembered (admittedly I was bootstrapping from stage1 back then) and I've got to a running gnome3 fairly quickly.

Unfortunately, I'm not seeing unicode characters in either the terminal or Aurora. (Or, I assume, anything else.) I've selected a UTF8 locale and I only have the one locale in locale.gen. I've checked in the gnome terminal preferences -> encodings, and I'm seeing that the only things ticked are UTF-8 Unicode and UTF-8 Current Locale.

Some console output:
Code:
simon@stargazer:10:44:15 ruby-2.2.0 [~]
-> locale -a
C
en_GB.utf8
POSIX

simon@stargazer:10:44:19 ruby-2.2.0 [~]
-> locale
LANG=en_GB.UTF8
LC_CTYPE="en_GB.UTF8"
LC_NUMERIC=en_GB.utf8
LC_TIME=en_GB.utf8
LC_COLLATE="en_GB.UTF8"
LC_MONETARY=en_GB.utf8
LC_MESSAGES="en_GB.UTF8"
LC_PAPER=en_GB.utf8
LC_NAME="en_GB.UTF8"
LC_ADDRESS="en_GB.UTF8"
LC_TELEPHONE="en_GB.UTF8"
LC_MEASUREMENT=en_GB.utf8
LC_IDENTIFICATION="en_GB.UTF8"
LC_ALL=


Mixed capitalisation in the output, there. Not sure if that's an issue. Not sure what else to check. I have the unicode USE flag set and I've rebuilt world --newuse --deep to be sure. (shrug)

Any ideas?
_________________
"Pokey, are you drunk on love?"
"Yes. Also whiskey. But mostly love... and whiskey."


Last edited by mr-simon on Thu Jan 22, 2015 1:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Thu Jan 22, 2015 11:03 am    Post subject: Reply with quote

Are you having similar artifacts as in this thread?
Back to top
View user's profile Send private message
mr-simon
Guru
Guru


Joined: 22 Nov 2002
Posts: 362
Location: Leamington Spa, Warks, UK

PostPosted: Thu Jan 22, 2015 11:20 am    Post subject: Reply with quote

charles17 wrote:
Are you having similar artifacts as in this thread?


Unfortunately not quite. I see all of those characters, so it looks like support is somewhat partial. See: http://imgur.com/bHAkeGG

I have tried different fonts, and they all seem to do the same thing.
_________________
"Pokey, are you drunk on love?"
"Yes. Also whiskey. But mostly love... and whiskey."
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Thu Jan 22, 2015 12:10 pm    Post subject: Reply with quote

mr-simon wrote:
so it looks like support is somewhat partial. See: http://imgur.com/bHAkeGG
Looks like your browser does not have/find/know suitable unicode fonts.
Back to top
View user's profile Send private message
dlaor
n00b
n00b


Joined: 27 Jan 2008
Posts: 55

PostPosted: Thu Jan 22, 2015 12:38 pm    Post subject: Reply with quote

If you are using systemd (chances are you are, as you're running gnome 3), then what does "localectl" return? Here it gives

Code:

   System Locale: LANG=en_GB.utf8
       VC Keymap: us
      X11 Layout: us
     X11 Variant: altgr-intl
     X11 Options: eurosign:5


With the same command these variables can be set. Here gnome terminal displays e.g. arabic fonts fine, but I do not have aurora installed to check. Executing "locale" here gives output similar to yours, except with "utf8" in lower case so, as you suspect, that might be a problem.

Hope this helps!
Back to top
View user's profile Send private message
mr-simon
Guru
Guru


Joined: 22 Nov 2002
Posts: 362
Location: Leamington Spa, Warks, UK

PostPosted: Thu Jan 22, 2015 1:26 pm    Post subject: Reply with quote

charles17 wrote:
mr-simon wrote:
so it looks like support is somewhat partial. See: http://imgur.com/bHAkeGG
Looks like your browser does not have/find/know suitable unicode fonts.


Yeah, I thought that... But I've tried *all* installed gnome fonts from a vanilla install, and none of them know those characters. And the problem appears to be gnome-wide, not just in my browser.

Also, I notice that it's unable to render some of its own fonts properly ("Standard Symbols L" and Dingbats) with the same effect:
http://imgur.com/UFJxK2y
(that's the font selector in gnome-tweak-tools)

Is this "normal"?

dlaor wrote:
If you are using systemd (chances are you are, as you're running gnome 3), then what does "localectl" return?


Yeah, I'm using systemd.

Code:
simon@stargazer:13:19:16 ruby-2.2.0 [~]
-> localectl
   System Locale: LANG=en_GB.UTF8
       VC Keymap: uk
      X11 Layout: gb


Looks fine to me.
_________________
"Pokey, are you drunk on love?"
"Yes. Also whiskey. But mostly love... and whiskey."
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Thu Jan 22, 2015 1:36 pm    Post subject: Reply with quote

mr-simon wrote:
charles17 wrote:
Yeah, I thought that... But I've tried *all* installed gnome fonts from a vanilla install, and none of them know those characters. And the problem appears to be gnome-wide, not just in my browser.
What if starting your browser from strartx with no WM, just plain x11? Just to see if it's gnome specific.
Back to top
View user's profile Send private message
mr-simon
Guru
Guru


Joined: 22 Nov 2002
Posts: 362
Location: Leamington Spa, Warks, UK

PostPosted: Thu Jan 22, 2015 1:46 pm    Post subject: Reply with quote

charles17 wrote:
mr-simon wrote:
charles17 wrote:
Yeah, I thought that... But I've tried *all* installed gnome fonts from a vanilla install, and none of them know those characters. And the problem appears to be gnome-wide, not just in my browser.
What if starting your browser from strartx with no WM, just plain x11? Just to see if it's gnome specific.


Good question. Looks like the same characters don't work in xterm, firefox-outside-gnome, and the text console.

Curiouser and curiouser.
_________________
"Pokey, are you drunk on love?"
"Yes. Also whiskey. But mostly love... and whiskey."
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Thu Jan 22, 2015 2:15 pm    Post subject: Reply with quote

Not sure what fonts browsers can use. Maybe media-fonts/* ?
Quote:
$ eix -IC media-fonts --only-names
media-fonts/dejavu
media-fonts/encodings
media-fonts/font-adobe-100dpi
media-fonts/font-adobe-75dpi
media-fonts/font-adobe-utopia-100dpi
media-fonts/font-adobe-utopia-75dpi
media-fonts/font-adobe-utopia-type1
media-fonts/font-alias
media-fonts/font-arabic-misc
media-fonts/font-bh-100dpi
media-fonts/font-bh-75dpi
media-fonts/font-bh-lucidatypewriter-100dpi
media-fonts/font-bh-lucidatypewriter-75dpi
media-fonts/font-bh-ttf
media-fonts/font-bh-type1
media-fonts/font-bitstream-100dpi
media-fonts/font-bitstream-75dpi
media-fonts/font-bitstream-speedo
media-fonts/font-bitstream-type1
media-fonts/font-cronyx-cyrillic
media-fonts/font-cursor-misc
media-fonts/font-daewoo-misc
media-fonts/font-dec-misc
media-fonts/font-ibm-type1
media-fonts/font-isas-misc
media-fonts/font-jis-misc
media-fonts/font-micro-misc
media-fonts/font-misc-cyrillic
media-fonts/font-misc-ethiopic
media-fonts/font-misc-meltho
media-fonts/font-misc-misc
media-fonts/font-mutt-misc
media-fonts/font-schumacher-misc
media-fonts/font-screen-cyrillic
media-fonts/font-sony-misc
media-fonts/font-sun-misc
media-fonts/font-util
media-fonts/font-winitzki-cyrillic
media-fonts/font-xfree86-type1
media-fonts/liberation-fonts
media-fonts/libertine-ttf
media-fonts/ttf-bitstream-vera
media-fonts/urw-fonts
Back to top
View user's profile Send private message
mr-simon
Guru
Guru


Joined: 22 Nov 2002
Posts: 362
Location: Leamington Spa, Warks, UK

PostPosted: Thu Jan 22, 2015 2:57 pm    Post subject: Reply with quote

I'm less concerned about my browser, and more concerned about my terminal.

Nevertheless, I put up a webpage containing some characters that don't render. (Also happens to be a well-known emoji):
http://sd.ai/uni.html

None of my browser fonts would render it. I made no font selection in the webpage, so changing ff's default font caused the font to change. This way, I could cycle through all of them.

I also installed `corefonts` which installs the MS ttf fonts (Arial and friends). I know these have these characters in. No dice. I still get the square with four hex digits in it.

I'm pretty sure it's not a characters-not-in-font problem.
_________________
"Pokey, are you drunk on love?"
"Yes. Also whiskey. But mostly love... and whiskey."
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Thu Jan 22, 2015 4:24 pm    Post subject: Reply with quote

Sounds very strange. No idea if it helps, but there's this certain "unicode" flag.
Back to top
View user's profile Send private message
mr-simon
Guru
Guru


Joined: 22 Nov 2002
Posts: 362
Location: Leamington Spa, Warks, UK

PostPosted: Thu Jan 22, 2015 4:38 pm    Post subject: Reply with quote

charles17 wrote:
Sounds very strange. No idea if it helps, but there's this certain "unicode" flag.


Yeah, that's set. As is the unicode USE flag, globally.
_________________
"Pokey, are you drunk on love?"
"Yes. Also whiskey. But mostly love... and whiskey."
Back to top
View user's profile Send private message
dlaor
n00b
n00b


Joined: 27 Jan 2008
Posts: 55

PostPosted: Thu Jan 22, 2015 10:28 pm    Post subject: Reply with quote

I just checked here and in both cases (the font selector and your webpage) the fonts are not displayed either.

Here is what does work for me (and I've never needed more): in both opera and firefox the arabic fonts on e.g. http://www.bbc.co.uk/arabic look fine while any newly created folder, that is named with some words from that page, displays fine in gnome-terminal.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Thu Jan 22, 2015 11:14 pm    Post subject: Reply with quote

mr-simon wrote:
I also installed `corefonts` which installs the MS ttf fonts (Arial and friends). I know these have these characters in. No dice. I still get the square with four hex digits in it.

Really ? :roll:

emoji got added to unicode (well, to public set - they might have been used in PUA much earlier) fairly recently and and those `corefonts` in portage are at most early WinXP fonts, but more like up to Win9x. 'corefonts' means Arial, not Arial Unicode (which, btw., isn't all that good).

PS: ...and what's the purpose of that javascript snippet on that test page ?
Back to top
View user's profile Send private message
mr-simon
Guru
Guru


Joined: 22 Nov 2002
Posts: 362
Location: Leamington Spa, Warks, UK

PostPosted: Fri Jan 23, 2015 2:11 pm    Post subject: Reply with quote

VoidMage wrote:
PS: ...and what's the purpose of that javascript snippet on that test page ?


Arg. I hadn't spotted that until just now. I have my webserver behind cloudflare's free plan for their free DNS and caching. I guess this is something they inject for stats purposes, but I'll have to contact them and see what the deal is...

VoidMage wrote:
mr-simon wrote:
I also installed `corefonts` which installs the MS ttf fonts (Arial and friends). I know these have these characters in. No dice. I still get the square with four hex digits in it.


Really ? :roll:

emoji got added to unicode (well, to public set - they might have been used in PUA much earlier) fairly recently and and those `corefonts` in portage are at most early WinXP fonts, but more like up to Win9x. 'corefonts' means Arial, not Arial Unicode (which, btw., isn't all that good).


It looks like it's time to be scientific about this! ;-)

I threw up a vanilla Ubuntu 14.04 install in a virtual machine. I installed ms-corefonts. The md5sum of arial.ttf is f11c0317db527bdd80fa0afa04703441 on both that, and my gentoo system with corefonts installed.

I opened the test page I mentioned before in Firefox on both my Gentoo host, and Ubuntu guest. I selected Arial as the default font for both. The browser in Ubuntu shows the characters. The browser in Gentoo does not.

I then opened gnome-terminal on both. I ensured both were set to the same font (specifically, ubuntu-mono) and downloaded the test html file and piped it to the terminal. The characters show just fine on my Ubuntu machine, and not on my Gentoo one.

Here is a pair of screenshots showing the above, including output and active settings: http://imgur.com/a/lvDsc

I reiterate my assertion that it's not a characters-not-in-font problem, and is in fact a lower-level issue. :?

Unfortunately, that doesn't bring me any closer to a solution... :(
_________________
"Pokey, are you drunk on love?"
"Yes. Also whiskey. But mostly love... and whiskey."
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Sat Jan 24, 2015 12:11 am    Post subject: Reply with quote

Chances are 'fc-match -a <font pattern>' could shed some light on your problem.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Sun Jan 25, 2015 1:08 pm    Post subject: Re: Some unicode characters aren't appearing in Gnome3 Reply with quote

mr-simon wrote:
Some console output:
Code:
simon@stargazer:10:44:15 ruby-2.2.0 [~]
-> locale -a
C
en_GB.utf8
POSIX

simon@stargazer:10:44:19 ruby-2.2.0 [~]
-> locale
LANG=en_GB.UTF8
LC_CTYPE="en_GB.UTF8"
LC_NUMERIC=en_GB.utf8
LC_TIME=en_GB.utf8
LC_COLLATE="en_GB.UTF8"
LC_MONETARY=en_GB.utf8
LC_MESSAGES="en_GB.UTF8"
LC_PAPER=en_GB.utf8
LC_NAME="en_GB.UTF8"
LC_ADDRESS="en_GB.UTF8"
LC_TELEPHONE="en_GB.UTF8"
LC_MEASUREMENT=en_GB.utf8
LC_IDENTIFICATION="en_GB.UTF8"
LC_ALL=
Could you already solve that problem? Comparing your output with mine gives me a different spelling: UTF8 vs UTF-8. But I am using OpenRC. No clue if this makes a difference.
Quote:
$ locale -a
C
POSIX
en_US.utf8

$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=C
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
What about re-generating them?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum