Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Why does i965 load instead of i915
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
PasReel
n00b
n00b


Joined: 19 Jan 2015
Posts: 6

PostPosted: Mon Jan 19, 2015 12:47 am    Post subject: Why does i965 load instead of i915 Reply with quote

So I noticed today that on the gentoo install there is no hardware rendering. I went through the kernel and recopiled the i915 and agp intel modules as modules. But when ever I start x server it it gives me an error message that i965 could not be loaded but I don't use the i965 module just the i915 D;

Also I was managed to break my use flags...wondering what I need to fix them.
Code:

# *** CFLAGS and CXXFLAGS ***
# CFLAGS and CXXFLAGS variables define the optimization flags for gcc C and C++ compiler.
# See https://wiki.gentoo.org/wiki/GCC_optimization for more information.
 CFLAGS="-O2 -march=native"
 CXXFLAGS="${CFLAGS}"
#
# *** CHOST ***
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
# for 64bit Intel PCs
 CHOST="x86_64-pc-linux-gnu"
# for 32bit Intel PCs
# CHOST="i686-pc-linux-gnu"
#
# *** USE flags ***
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
# See official Gentoo docs for more information.
 USE=" xorg-base/xorg-drivers dev-libs/libxml2-2.9.2 gles sdl python media-plugins/alsa-plugins-1.0.28 pulseaudio opengl x11-libs/cairo-1.12.16 opengl svg png jpg jpeg imlib qt3support  dev-lang/python-2.7.9-r1:2.7 sqlite media-libs/libpng-1.6.16 apng media-libs/harfbuzz-0.9.37 icu sys-libs/zlib-1.2.8-r1 minizip dev-libs/libxm12-2-9.2 icu app-text/ghostscript-gpl-9.15-r1 cups qt4 alsa app-crypt/gcr-3.12.2 gtk x11-misc/notification-daemon-0.7.6 virtual/notification-daemon-0[-gnome] x11-libs/libnotify-0.7.5-r1 gnome-extra/nm-applet-0.9.10.0 nm-applet  sys-fs/udev-216 gudev ys-auth/consolekit-0.4.6 policykit dhclient net-misc/networkmanager dhcpd   xa libkms X11-base/xorg-server X bindist mmx sse sse2 udev branding dbus startup-notification dir glamor udev sna xorg"
#
# *** MAKEOPTS ***
# With MAKEOPTS you define how many parallel compilations should occur
# when you install a package. A good choice is the number of CPUs (or CPU cores)
# in your system plus one, but this guideline isn't always perfect.
 MAKEOPTS="-j5"
VIDEO_CARDS="intel i915"

ACCEPT_LICENSE="*"
[/code]
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6963
Location: Saint Amant, Acadiana

PostPosted: Mon Jan 19, 2015 1:53 am    Post subject: Reply with quote

Welcome, PasReel!

Regarding your USE flags, remove all of them, select correct profile for your setup, run emerge --info to see what is active. If there is something you need to tweak use an USE flag editor as ufed to make changes. Review your make.conf after that and you will understand how USE flags look like.

Regarding your VIDEO_CARDS variable, please see Gentoo wiki.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
PasReel
n00b
n00b


Joined: 19 Jan 2015
Posts: 6

PostPosted: Mon Jan 19, 2015 2:24 am    Post subject: Reply with quote

Jaglover wrote:
Welcome, PasReel!

Regarding your USE flags, remove all of them, select correct profile for your setup, run emerge --info to see what is active. If there is something you need to tweak use an USE flag editor as ufed to make changes. Review your make.conf after that and you will understand how USE flags look like.

Regarding your VIDEO_CARDS variable, please see Gentoo wiki.
So I uh deleted the use flags, but I still am getting the dependancy probles, and i can't emerge D;

Also in the gentoo wiki it sais the video_cards variable is intel i915 D;
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6963
Location: Saint Amant, Acadiana

PostPosted: Mon Jan 19, 2015 2:28 am    Post subject: Reply with quote

OK, what does lspci say about your card? And please, POSIX systems are case sensitive, there is no variable video_cards.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
PasReel
n00b
n00b


Joined: 19 Jan 2015
Posts: 6

PostPosted: Mon Jan 19, 2015 2:33 am    Post subject: Reply with quote

Jaglover wrote:
OK, what does lspci say about your card? And please, POSIX systems are case sensitive, there is no variable video_cards.
Sorry about the case sensitivity was just being lazy with typing. About the lspci I never emerged pciutils, but the modules loaded are
Code:
Module                  Size  Used by
i915                  850494  2
ath9k                 128740  0
ath9k_common           14066  1 ath9k
ath9k_hw              410786  2 ath9k_common,ath9k
ath                    19272  3 ath9k_common,ath9k,ath9k_hw
mac80211              477874  1 ath9k
intel_agp              10520  0
i2c_algo_bit            5175  1 i915
drm_kms_helper         61532  1 i915
r8169                  57553  0
drm                   238672  4 i915,drm_kms_helper
intel_gtt              12088  3 i915,intel_agp
cfg80211              357750  4 ath,ath9k_common,ath9k,mac80211
agpgart                26176  3 drm,intel_agp,intel_gtt

if that helps with anything
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6963
Location: Saint Amant, Acadiana

PostPosted: Mon Jan 19, 2015 2:35 am    Post subject: Reply with quote

You should make friends with wgetpaste and let us see your Xorg log. About pciutils, go ahead and emerge them, you do not need X for that.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
PasReel
n00b
n00b


Joined: 19 Jan 2015
Posts: 6

PostPosted: Mon Jan 19, 2015 2:41 am    Post subject: Reply with quote

Jaglover wrote:
You should make friends with wgetpaste and let us see your Xorg log. About pciutils, go ahead and emerge them, you do not need X for that.
Ohhoh wgetpaste is a cool little trick, http://pastebin.com/vV1Evh6j there is lspci
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6963
Location: Saint Amant, Acadiana

PostPosted: Mon Jan 19, 2015 2:44 am    Post subject: Reply with quote

Code:
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)


I'm not familiar with this chipset, but if it is asking for i965 why don't you enable it?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
PasReel
n00b
n00b


Joined: 19 Jan 2015
Posts: 6

PostPosted: Mon Jan 19, 2015 2:52 am    Post subject: Reply with quote

Jaglover wrote:
Code:
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)


I'm not familiar with this chipset, but if it is asking for i965 why don't you enable it?
Not going to lie didn't think about it.. But I didlook for it in the menuconfig but not too sure what to put for i965.


http://pastebin.com/CiyTUBp0
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6963
Location: Saint Amant, Acadiana

PostPosted: Mon Jan 19, 2015 2:58 am    Post subject: Reply with quote

Code:
VIDEO_CARDS="intel i965"


Followed by emerge -avND @world methinks. It probably will rebuild mesa, just try it, I'm not very proficient in all that Xorg stuff.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
v_andal
Guru
Guru


Joined: 26 Aug 2008
Posts: 521
Location: Germany

PostPosted: Mon Jan 19, 2015 8:01 am    Post subject: Reply with quote

There are 2 different things. In kernel, one should enable i915 driver (CONFIG_DRM_I915) but in make.conf one should have

VIDEO_CARDS="intel i965"

There's no i965 for kernel, but there's one for Xorg.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum