Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Slim Fluxbox xfce4-power-manager - no suspend or hibernate
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
feiticeir0
Apprentice
Apprentice


Joined: 13 Jul 2005
Posts: 281
Location: Castelo Branco, Portugal

PostPosted: Mon Jan 12, 2015 1:57 pm    Post subject: Slim Fluxbox xfce4-power-manager - no suspend or hibernate Reply with quote

Hi !

I'm using fluxbox as my desktop environment but it lacks automatic suspend or hibernation.

I've used xscreensaver but it has no option for hibernate or suspend. And i'm trying now xfce4-power-manager, but the suspend and hibernate options are disabled...

My user can hibernate the laptop - I have an option in fluxbox to hibernate my computer, but i would love that it could do that without my intervention after a period of time..

I'm using openrc - acpi, udev and consolekit are running ...

What can i do to enable the options ? any hints ?

Best regards

Bruno Santos
_________________
Do It With Rhythm
Back to top
View user's profile Send private message
SDNick484
Apprentice
Apprentice


Joined: 05 Dec 2005
Posts: 212

PostPosted: Thu Jan 15, 2015 7:12 am    Post subject: Reply with quote

My guess is that it's consolekit/polkit related. I know that in XFCE & LXDE I need to make sure that the consolekit and polkit use flags are set for suspend/hibernate to work. I also start my session with exec ck-launch-session startxfce4 for it to work.

One question, can you run ck-list-sessions from within X and post what it says. You should see "active = TRUE" in one of your sessions.
Back to top
View user's profile Send private message
feiticeir0
Apprentice
Apprentice


Joined: 13 Jul 2005
Posts: 281
Location: Castelo Branco, Portugal

PostPosted: Thu Jan 15, 2015 3:26 pm    Post subject: Reply with quote

Hi ! Thank you for the reply !

I've already check that and everything seems fine.

Code:

feiticeir0@nightcrawler ~ $ ck-list-sessions
Session1:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat1'
   session-type = 'x11'
   active = TRUE
   x11-display = ':0.0'
   x11-display-device = '/dev/tty7'
   display-device = ''
   remote-host-name = ''
   is-local = TRUE
   on-since = '2015-01-15T14:36:46.267172Z'
   login-session-id = '2'


I start my session using slim and slim has support for consolekit !
_________________
Do It With Rhythm
Back to top
View user's profile Send private message
SDNick484
Apprentice
Apprentice


Joined: 05 Dec 2005
Posts: 212

PostPosted: Fri Jan 16, 2015 12:50 am    Post subject: Reply with quote

feiticeir0 wrote:
Hi ! Thank you for the reply !

I've already check that and everything seems fine.

Code:

feiticeir0@nightcrawler ~ $ ck-list-sessions
Session1:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat1'
   session-type = 'x11'
   active = TRUE
   x11-display = ':0.0'
   x11-display-device = '/dev/tty7'
   display-device = ''
   remote-host-name = ''
   is-local = TRUE
   on-since = '2015-01-15T14:36:46.267172Z'
   login-session-id = '2'


I start my session using slim and slim has support for consolekit !


Interesting, usually that's the issue. I'll give fluxbox a go tonight (I've used it for years on my lower power systems, but I generally don't suspend/hibernate them), and see if I can get it to work.

EDIT 1: Hmm, things seem to be working for me under both fluxbox & openbox. I see "Power Management Enabled" as in xscreensaver and all the times are changeable (not greyed out). I also tested suspend by closing my lid which worked.

I do see the following:
$ xfce4-power-manager --dump
---------------------------------------------------
Xfce power manager version 1.4.2
With policykit support
Without network manager support
---------------------------------------------------
Can suspend: True
Can hibernate: True
Authorized to suspend: True
Authorized to hibernate: True
Authorized to shutdown: True
Has battery: True
Has brightness panel: True
Has power button: True
Has hibernate button: True
Has sleep button: True
Has LID: True

Will you run that command and see if you get the same output? If it matters, this is a session started via startx (with a .xinitrc that just says "exec ck-launch-session fluxbox").

EDIT 2: I also see upowerd is running.
Back to top
View user's profile Send private message
feiticeir0
Apprentice
Apprentice


Joined: 13 Jul 2005
Posts: 281
Location: Castelo Branco, Portugal

PostPosted: Fri Jan 16, 2015 8:23 am    Post subject: Reply with quote

Hi !

Thank you for the replies !

I can indeed hibernate and suspend with my user - but manually -

I'll give a go without slim and using .xinitrc

cheers

Bruno Santos
_________________
Do It With Rhythm
Back to top
View user's profile Send private message
SDNick484
Apprentice
Apprentice


Joined: 05 Dec 2005
Posts: 212

PostPosted: Thu Jan 22, 2015 12:16 am    Post subject: Reply with quote

Any luck?
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 516

PostPosted: Thu Jan 22, 2015 12:27 am    Post subject: Reply with quote

(WARN: I did not read all the above posts!)

Why don't you just pull in hibernate-script and use `hibernate' & `hibernate-ram' instead of that bloat? You need graphical buttons for that?
You can even bind the actual power switch/lid with a functional ACPI (check out acpid.)

Luck... may be with you.

NOTE: I don't want to waste my time on superfluous DE dependent package to suspend/hibernate when a script will do it with minimal dependencies.
_________________
home/:mkinitramfs-ll/:supervision/:e-gtk-theme/:overlay/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum