Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
system sleep for about 10 seconds
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Sat Jan 10, 2015 10:44 am    Post subject: system sleep for about 10 seconds Reply with quote

Hey Guys :)

I use the log in manager slim and a xfce desktop environment. After Start up xfce my Linux seems so sleep for about 10 seconds. Afterwards i can use it without any problems. This behaviour is "new". So i think it's the result of an update i did some week/months ago.

I think my problem is shown in this xorg.log snippet:

Code:

cat /var/log/Xorg.0.log

[    26.840]
X.Org X Server 1.15.0
Release Date: 2013-12-27
[    26.840] X Protocol Version 11, Revision 0
[    26.840] Build Operating System: Linux 3.6.11 x86_64 Gentoo
[    26.840] Current Operating System: Linux ronny-reiner-rambo 3.6.11 #28 SMP Thu Jan 8 22:03:18 CET 2015 x86_64
[    26.840] Kernel command line: root=/dev/sda6 acpi_osi=Linux acpi_backlight=vendor net.ifnames=0
[    26.840] Build Date: 28 March 2014  05:08:54PM
...
...
[    29.243] (**) PS/2 Logitech Wheel Mouse: always reports core events
[    29.243] (**) evdev: PS/2 Logitech Wheel Mouse: Device: "/dev/input/event7"
[    29.243] (--) evdev: PS/2 Logitech Wheel Mouse: Vendor 0x2 Product 0x1
[    29.243] (--) evdev: PS/2 Logitech Wheel Mouse: Found 3 mouse buttons
[    29.243] (--) evdev: PS/2 Logitech Wheel Mouse: Found relative axes
[    29.243] (--) evdev: PS/2 Logitech Wheel Mouse: Found x and y relative axes
[    29.243] (II) evdev: PS/2 Logitech Wheel Mouse: Configuring as mouse
[    29.243] (**) evdev: PS/2 Logitech Wheel Mouse: YAxisMapping: buttons 4 and 5
[    29.243] (**) evdev: PS/2 Logitech Wheel Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    29.243] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input7/event7"
[    29.243] (II) XINPUT: Adding extended input device "PS/2 Logitech Wheel Mouse" (type: MOUSE, id 14)
[    29.243] (II) evdev: PS/2 Logitech Wheel Mouse: initialized for relative axes.
[    29.243] (**) PS/2 Logitech Wheel Mouse: (accel) keeping acceleration scheme 1
[    29.243] (**) PS/2 Logitech Wheel Mouse: (accel) acceleration profile 0
[    29.243] (**) PS/2 Logitech Wheel Mouse: (accel) acceleration factor: 2.000
[    29.243] (**) PS/2 Logitech Wheel Mouse: (accel) acceleration threshold: 4
[    29.244] (II) config/udev: Adding input device PS/2 Logitech Wheel Mouse (/dev/input/mouse1)
[    29.244] (II) No input driver specified, ignoring this device.
[    29.244] (II) This device may have been added with another device file.
[    47.677] (II) intel(0): EDID vendor "INL", prod id 23
[    47.677] (II) intel(0): Printing DDC gathered Modelines:
[    47.677] (II) intel(0): Modeline "1366x768"x0.0   71.00  1366 1414 1446 1498  768 769 773 790 -hsync -vsync (47.4 kHz eP)




So u can see an 18 seconds "sleep" in the last lines

here is my kernel configuration: http://pastebin.com/XNY0qGvq
Back to top
View user's profile Send private message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Sun Jan 11, 2015 4:15 pm    Post subject: Reply with quote

Here is a output of lsusb, if this could be helpful:

Code:

Bus 002 Device 004: ID 046d:c312 Logitech, Inc. DeLuxe 250 Keyboard
Bus 002 Device 003: ID 046d:c047 Logitech, Inc. Laser Mouse M-UAL120
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 1bcf:288a Sunplus Innovation Technology Inc.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Back to top
View user's profile Send private message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Mon Jan 12, 2015 10:17 am    Post subject: Reply with quote

does nobody has a suspicion?? :(
Back to top
View user's profile Send private message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Tue Jan 13, 2015 6:17 pm    Post subject: Reply with quote

could anyone ble give me a hint or a try??? :(
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jan 16, 2015 10:00 pm    Post subject: Reply with quote

had this "behavior" myself for some time on my old system - after some weeks it went away (after some system + kernel updates)

any suspicious entries in dmesg or /var/log/kern.log ?

what exact kernel version ? (gentoo ?)

tried updating the kernel to something newer ?

output of lspci ?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3648
Location: Hamburg

PostPosted: Fri Jan 16, 2015 10:03 pm    Post subject: Reply with quote

Maybe in the BIOS there's a wait time to get monitor infos ?
Back to top
View user's profile Send private message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Mon Jan 19, 2015 7:10 am    Post subject: Reply with quote

Many thanks for your reply.

I'm using the 3.6.11 Kernel for a long time and be pretty happy. This behaviour didn't come together with switching the kernel version. So yes, maybe a software update is responsible :/

Unfortunately, I don't have a kern.log. But I dumped my rc.log:

Code:

rc shutdown logging started at Sun Jan 18 20:13:41 2015

 * Caching service dependencies ...
/etc/init.d/../conf.d/net: line 21: unexpected EOF while looking for matching `"'
/etc/init.d/../conf.d/net: line 30: syntax error: unexpected end of file
/etc/init.d/../conf.d/net: line 21: unexpected EOF while looking for matching `"'
/etc/init.d/../conf.d/net: line 30: syntax error: unexpected end of file
/etc/init.d/../conf.d/net: line 21: unexpected EOF while looking for matching `"'
/etc/init.d/../conf.d/net: line 30: syntax error: unexpected end of file
/etc/init.d/../conf.d/net: line 21: unexpected EOF while looking for matching `"'
/etc/init.d/../conf.d/net: line 30: syntax error: unexpected end of file
/etc/init.d/../conf.d/net: line 21: unexpected EOF while looking for matching `"'
/etc/init.d/../conf.d/net: line 30: syntax error: unexpected end of file
 [ ok ]
 * Stopping local ...
 [ ok ]
 * Saving random seed ...
 [ ok ]
 * Deactivating additional swap space ...
 [ ok ]
 * Stopping sshd ...
 [ ok ]
 * Unloading lm_sensors modules...
 *   Unloading coretemp ...
 [ ok ]
 * Stopping cupsd ...
 [ ok ]
 * Stopping DHCP Client Daemon ...
 [ ok ]
 * Running cpufreq-set --governor performance ...
 [ ok ]
 * Shutting down bluetooth ...
 [ ok ]
 * Storing ALSA Mixer Levels ...
 [ ok ]
 * Stopping slim ...
 [ ok ]
 * Stopping ConsoleKit daemon ...
 [ ok ]
 * Stopping D-BUS system messagebus ...
 [ ok ]
 * Stopping acpid ...
 [ ok ]
 * Unmounting loop devices
 * Unmounting filesystems
 *   Unmounting /home ...
 [ ok ]
 *   Unmounting /boot ...
 [ ok ]
 * Deactivating swap devices ...
 [ ok ]
 * Stopping udev ...
 [ ok ]
 * Setting hardware clock using the system clock [UTC] ...
 [ ok ]

rc shutdown logging stopped at Sun Jan 18 20:13:49 2015


rc shutdown logging started at Sun Jan 18 20:13:41 2015

 * Caching service dependencies ...
/etc/init.d/../conf.d/net: line 21: unexpected EOF while looking for matching `"'
/etc/init.d/../conf.d/net: line 30: syntax error: unexpected end of file
/etc/init.d/../conf.d/net: line 21: unexpected EOF while looking for matching `"'
/etc/init.d/../conf.d/net: line 30: syntax error: unexpected end of file
/etc/init.d/../conf.d/net: line 21: unexpected EOF while looking for matching `"'
/etc/init.d/../conf.d/net: line 30: syntax error: unexpected end of file
/etc/init.d/../conf.d/net: line 21: unexpected EOF while looking for matching `"'
/etc/init.d/../conf.d/net: line 30: syntax error: unexpected end of file
/etc/init.d/../conf.d/net: line 21: unexpected EOF while looking for matching `"'
/etc/init.d/../conf.d/net: line 30: syntax error: unexpected end of file
 [ ok ]
 * Stopping local ...
 [ ok ]
 * Saving random seed ...
 [ ok ]
 * Deactivating additional swap space ...
 [ ok ]
 * Stopping sshd ...
 [ ok ]
 * Unloading lm_sensors modules...
 *   Unloading coretemp ...
 [ ok ]
 * Stopping cupsd ...
 [ ok ]
 * Stopping DHCP Client Daemon ...
 [ ok ]
 * Running cpufreq-set --governor performance ...
 [ ok ]
 * Shutting down bluetooth ...
 [ ok ]
 * Storing ALSA Mixer Levels ...
 [ ok ]
 * Stopping slim ...
 [ ok ]
 * Stopping ConsoleKit daemon ...
 [ ok ]
 * Stopping D-BUS system messagebus ...
 [ ok ]
 * Stopping acpid ...
 [ ok ]
 * Unmounting loop devices
 * Unmounting filesystems
 *   Unmounting /home ...
 [ ok ]
 *   Unmounting /boot ...
 [ ok ]
 * Deactivating swap devices ...
 [ ok ]
 * Stopping udev ...
 [ ok ]
 * Setting hardware clock using the system clock [UTC] ...
 [ ok ]

rc shutdown logging stopped at Sun Jan 18 20:13:49 2015


rc boot logging started at Sun Jan 18 20:15:06 2015

 * Setting system clock using the hardware clock [UTC] ...
 [ ok ]
 * Loading module vboxnetadp ...
 [ ok ]
 * Autoloaded 1 module(s)
 * Checking local filesystems  ...
/dev/sda6: clean, 1198951/5758976 files, 15149412/23023616 blocks
/dev/sda5: clean, 45/16384 files, 27870/65536 blocks
/dev/sda2: clean, 174131/40026112 files, 76728457/160100352 blocks
 [ ok ]
 * Remounting root filesystem read/write ...
 [ ok ]
 * Remounting filesystems ...
 [ ok ]
 * Updating /etc/mtab ...
 [ ok ]
 * Activating swap devices ...
 [ ok ]
 * Mounting local filesystems ...
 [ ok ]
 * Configuring kernel parameters ...
* Applying /etc/sysctl.conf ...
net.ipv4.ip_forward = 0
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.all.rp_filter = 1
 [ ok ]
 * Creating user login records ...
 [ ok ]
 * Wiping /tmp directory ...
 [ ok ]
 * Restoring Mixer Levels ...
 [ ok ]
 * Setting terminal encoding [UTF-8] ...
 [ ok ]
 * Setting console font [default8x16] ...
 [ ok ]
 * Setting hostname to ronny-reiner-rambo ...
 [ ok ]
 * Setting keyboard mode [UTF-8] ...
 [ ok ]
 * Loading key mappings [de-latin1-nodeadkeys] ...
 [ ok ]
 * Bringing up network interface lo ...
 [ ok ]
 * Mounting misc binary format filesystem ...
 [ ok ]
 * Loading custom binary format handlers ...
 [ ok ]
 * Mounting SELinux filesystem ...
 [ ok ]
 * Activating additional swap space ...
 [ ok ]
 * setting up tmpfiles.d entries ...
 [ ok ]
 * Initializing random number generator ...
 [ ok ]

rc boot logging stopped at Sun Jan 18 20:15:11 2015


rc default logging started at Sun Jan 18 20:15:11 2015

 * Running hdparm on /dev/sda ...
 [ ok ]
 * Checking your configfile (/etc/syslog-ng/syslog-ng.conf) ...
 [ ok ]
 * Starting syslog-ng ...
 [ ok ]
 * Starting acpid ...
 [ ok ]
 * Setup Harddisk permissions ...
 * hdparm parameters EiEiEi

/dev/sda:
 setting Advanced Power Management level to disabled
 setting standby to 0 (off)
 APM_level   = off
 [ ok ]
 * Starting D-BUS system messagebus ...
 [ ok ]
 * Starting bluetooth ...
 [ ok ]
 * Starting ConsoleKit daemon ...
 [ ok ]
 * Running cpufreq-set --governor ondemand -- ...
 [ ok ]
 * Starting WPA Supplicant Daemon ...
Successfully initialized wpa_supplicant
 [ ok ]
 * Starting DHCP Client Daemon ...
 [ ok ]
 * Starting cupsd ...
 [ ok ]
 * Loading lm_sensors modules...
 *   Loading coretemp ...
 [ ok ]
 * Initializing sensors ...
 [ ok ]
 * Mounting network filesystems ...
 [ ok ]
 * Setting up slim ...
 [ ok ]
 * Starting local ...

rc battery logging started at Sun Jan 18 20:15:19 2015

 * Unmounting network filesystems ...
 [ ok ]
 * Stopping syslog-ng ...
 [ ok ]

rc battery logging stopped at Sun Jan 18 20:15:19 2015


rc shutdown logging started at Sun Jan 18 23:56:46 2015

 * Stopping local ...
 [ ok ]
 * Saving random seed ...
 [ ok ]
 * Deactivating additional swap space ...
 [ ok ]
 * Unloading lm_sensors modules...
 *   Unloading coretemp ...
 [ ok ]
 * Stopping cupsd ...
 [ ok ]
 * Stopping DHCP Client Daemon ...
 [ ok ]
 * Running cpufreq-set --governor performance ...
 [ ok ]
 * Shutting down bluetooth ...
 [ ok ]
 * Storing ALSA Mixer Levels ...
 [ ok ]
 * Stopping slim ...
 [ ok ]
 * Stopping ConsoleKit daemon ...
 [ ok ]
 * Stopping D-BUS system messagebus ...
 [ ok ]
 * Stopping acpid ...
 [ ok ]
 * Unmounting loop devices
 * Unmounting filesystems
 *   Unmounting /home ...
 [ ok ]
 *   Unmounting /boot ...
 [ ok ]
 * Deactivating swap devices ...
 [ ok ]
 * Stopping udev ...
 [ ok ]
 * Setting hardware clock using the system clock [UTC] ...
 [ ok ]

rc shutdown logging stopped at Sun Jan 18 23:56:51 2015


rc shutdown logging started at Sun Jan 18 23:56:46 2015

 * Stopping local ...
 [ ok ]
 * Saving random seed ...
 [ ok ]
 * Deactivating additional swap space ...
 [ ok ]
 * Unloading lm_sensors modules...
 *   Unloading coretemp ...
 [ ok ]
 * Stopping cupsd ...
 [ ok ]
 * Stopping DHCP Client Daemon ...
 [ ok ]
 * Running cpufreq-set --governor performance ...
 [ ok ]
 * Shutting down bluetooth ...
 [ ok ]
 * Storing ALSA Mixer Levels ...
 [ ok ]
 * Stopping slim ...
 [ ok ]
 * Stopping ConsoleKit daemon ...
 [ ok ]
 * Stopping D-BUS system messagebus ...
 [ ok ]
 * Stopping acpid ...
 [ ok ]
 * Unmounting loop devices
 * Unmounting filesystems
 *   Unmounting /home ...
 [ ok ]
 *   Unmounting /boot ...
 [ ok ]
 * Deactivating swap devices ...
 [ ok ]
 * Stopping udev ...
 [ ok ]
 * Setting hardware clock using the system clock [UTC] ...
 [ ok ]

rc shutdown logging stopped at Sun Jan 18 23:56:51 2015


rc boot logging started at Mon Jan 19 07:46:46 2015

 * Setting system clock using the hardware clock [UTC] ...
 [ ok ]
 * Loading module vboxnetadp ...
 [ ok ]
 * Autoloaded 1 module(s)
 * Checking local filesystems  ...
/dev/sda6: clean, 1198945/5758976 files, 15149365/23023616 blocks
/dev/sda5: clean, 45/16384 files, 27870/65536 blocks
/dev/sda2: clean, 174660/40026112 files, 76729267/160100352 blocks
 [ ok ]
 * Remounting root filesystem read/write ...
 [ ok ]
 * Remounting filesystems ...
 [ ok ]
 * Updating /etc/mtab ...
 [ ok ]
 * Activating swap devices ...
 [ ok ]
 * Mounting local filesystems ...
 [ ok ]
 * Configuring kernel parameters ...
* Applying /etc/sysctl.conf ...
net.ipv4.ip_forward = 0
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.all.rp_filter = 1
 [ ok ]
 * Creating user login records ...
 [ ok ]
 * Wiping /tmp directory ...
 [ ok ]
 * Restoring Mixer Levels ...
 [ ok ]
 * Setting terminal encoding [UTF-8] ...
 [ ok ]
 * Setting console font [default8x16] ...
 [ ok ]
 * Setting hostname to ronny-reiner-rambo ...
 [ ok ]
 * Setting keyboard mode [UTF-8] ...
 [ ok ]
 * Loading key mappings [de-latin1-nodeadkeys] ...
 [ ok ]
 * Bringing up network interface lo ...
 [ ok ]
 * Mounting misc binary format filesystem ...
 [ ok ]
 * Loading custom binary format handlers ...
 [ ok ]
 * Mounting SELinux filesystem ...
 [ ok ]
 * Activating additional swap space ...
 [ ok ]
 * setting up tmpfiles.d entries ...
 [ ok ]
 * Initializing random number generator ...
 [ ok ]

rc boot logging stopped at Mon Jan 19 07:46:51 2015


rc default logging started at Mon Jan 19 07:46:51 2015

 * Running hdparm on /dev/sda ...
 [ ok ]
 * Checking your configfile (/etc/syslog-ng/syslog-ng.conf) ...
 [ ok ]
 * Starting syslog-ng ...
 [ ok ]
 * Starting acpid ...
 [ ok ]
 * Setup Harddisk permissions ...
 * hdparm parameters EiEiEi

/dev/sda:
 setting Advanced Power Management level to disabled
 setting standby to 0 (off)
 APM_level   = off
 [ ok ]
 * Starting D-BUS system messagebus ...
 [ ok ]
 * Starting bluetooth ...
 [ ok ]
 * Starting ConsoleKit daemon ...
 [ ok ]
 * Running cpufreq-set --governor ondemand -- ...
 [ ok ]
 * Starting WPA Supplicant Daemon ...
Successfully initialized wpa_supplicant
 [ ok ]
 * Starting DHCP Client Daemon ...
 [ ok ]
 * Starting cupsd ...
 [ ok ]
 * Loading lm_sensors modules...
 *   Loading coretemp ...
 [ ok ]
 * Initializing sensors ...
 [ ok ]
 * Mounting network filesystems ...
 [ ok ]
 * Setting up slim ...
 [ ok ]
 * Starting local ...

rc battery logging started at Mon Jan 19 07:46:59 2015

 * Unmounting network filesystems ...
 [ ok ]
 * Stopping syslog-ng ...
 [ ok ]

rc battery logging stopped at Mon Jan 19 07:46:59 2015



my lspci looks like that;

Code:

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Ethernet controller: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet (rev c0)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
04:00.1 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
05:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)


a more detailed output of lspci can be found here: http://pastebin.com/qJqEd9fn

If there is n solution for me i think i will update my kernel
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum