Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failed to update system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Fri Jan 09, 2015 6:13 pm    Post subject: Failed to update system Reply with quote

trying to update our 2 year old system, but get these errors:

Code:
emerge --update @world
--- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies \

!!! Problem resolving dependencies for sys-boot/boot-update from @selected    ... done!

!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
virtual/pager

!!! The ebuild selected to satisfy "sys-boot/boot-update" has unmet requirements.
- sys-boot/boot-update-1.7.2::gentoo USE="(uclibc) -python_abis_2.6 -python_abis_2.7 -python_abis_3.2 -python_abis_3.3 -python_abis_3.4 (-python_abis_3.5)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( python_abis_2.6 python_abis_2.7 python_abis_3.2 python_abis_3.3 python_abis_3.4 python_abis_3.5 )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Any suggestions?
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10459
Location: Somewhere over Atlanta, Georgia

PostPosted: Fri Jan 09, 2015 6:18 pm    Post subject: Reply with quote

Output from
Code:
emerge --info
and
Code:
eselect profile list
please.

The biggest suggestion is, don't wait two years to update a Gentoo system. Gentoo tends to punish you if you wait too long between updates.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Fri Jan 09, 2015 7:26 pm    Post subject: Reply with quote

here you go.... tx

Code:
 emerge --info
--- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0'
Portage 2.3.4-r2 (hardened/linux/uclibc/x86, gcc-4.6.2, glibc-2.13-r4, 3.4.0-gentoo i686)
=================================================================
System uname: Linux-3.4.0-gentoo-i686-Intel-R-_Pentium-R-_4_CPU_2.00GHz-with-gentoo-2.1.8
Timestamp of tree: Unknown
app-shells/bash:          4.2_p24
dev-lang/perl:            5.12.4-r1
dev-lang/python:          2.7.3-r1000, 3.2.3-r1000
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1.8-r3
sys-apps/openrc:          0.8.3-r8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.69
sys-devel/automake:       1.11.5
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.6.2-r1
sys-devel/gcc-config:     1.5
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
Installed sets:
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -fomit-frame-pointer -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -fomit-frame-pointer -march=pentium4 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="alac alsa apache2 berkdb cdr cgi cli cracklib crypt cxx dlloader dri dvd dvdr dvdread encode flac fortran gif hardened iconv imap ipv6 jpeg lame mad modules mp3 mpeg mudflap mysql mysqli ncurses nptl nptlonly ogg openmp openssl pax_kernel pcre pdflib pdo perl pic png pppd python readline session ssl tcpd tiff truetype uclibc unicode vorbis wavpack win32codecs x86 xattr xml xorg zlib" ABI_X86="32" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="uclibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="dummy fbdev v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK


Code:
 eselect profile list
Available profile symlink targets:
  [1]   default/linux/x86/13.0
  [2]   default/linux/x86/13.0/selinux
  [3]   default/linux/x86/13.0/desktop
  [4]   default/linux/x86/13.0/desktop/gnome
  [5]   default/linux/x86/13.0/desktop/gnome/systemd
  [6]   default/linux/x86/13.0/desktop/kde
  [7]   default/linux/x86/13.0/desktop/kde/systemd
  [8]   default/linux/x86/13.0/developer
  [9]   hardened/linux/x86
  [10]  hardened/linux/x86/selinux
  [11]  hardened/linux/musl/x86
  [12]  default/linux/uclibc/x86
  [13]  hardened/linux/uclibc/x86 *
Back to top
View user's profile Send private message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Fri Jan 09, 2015 8:19 pm    Post subject: Reply with quote

problem was the server was offline almost 2 years for personal reasons. So updates were not done.
Back to top
View user's profile Send private message
lexflex
Guru
Guru


Joined: 05 Mar 2006
Posts: 363
Location: the Netherlands

PostPosted: Fri Jan 09, 2015 8:34 pm    Post subject: Reply with quote

musicweb wrote:
problem was the server was offline almost 2 years for personal reasons. So updates were not done.


Can you maybe use with ask option and see what is to be upgraded;
Code:
emerge --update --ask @world


You can then decide to upgrade some 'easy' parts first. ( i.e. not @world at once)

Alex.
[/code]
Back to top
View user's profile Send private message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Fri Jan 09, 2015 10:05 pm    Post subject: Reply with quote

this is what I get:

Code:
emerge --update --ask @world
--- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies /

!!! Problem resolving dependencies for sys-boot/boot-update from @selected    ... done!

!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
virtual/pager

!!! The ebuild selected to satisfy "sys-boot/boot-update" has unmet requirements.
- sys-boot/boot-update-1.7.2::gentoo USE="(uclibc) -python_abis_2.6 -python_abis_2.7 -python_abis_3.2 -python_abis_3.3 -python_abis_3.4 (-python_abis_3.5)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( python_abis_2.6 python_abis_2.7 python_abis_3.2 python_abis_3.3 python_abis_3.4 python_abis_3.5 )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 16506

PostPosted: Fri Jan 09, 2015 11:51 pm    Post subject: Reply with quote

musicweb wrote:
Code:
 emerge --info
--- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0'
Portage 2.3.4-r2 (hardened/linux/uclibc/x86, gcc-4.6.2, glibc-2.13-r4, 3.4.0-gentoo i686)
SYNC="git://github.com/funtoo/ports-2012.git"
That Portage version looks wrong. The newest version in the tree I see is 2.2.15. Your system is two years out of date, but claims to have a much newer Portage. I suspect it is from your Funtoo overlay, which will make this even more complicated.
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1791

PostPosted: Sat Jan 10, 2015 12:23 am    Post subject: Reply with quote

As for the issues (excluding the ones coming from the funtoo tree) the error message
Code:
!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
virtual/pager

Says virtual/pager does not exist in the tree, as for if it's was replaced by something or what in a newer tree of funtoo I couldn't say.

Code:

!!! The ebuild selected to satisfy "sys-boot/boot-update" has unmet requirements.
- sys-boot/boot-update-1.7.2::gentoo USE="(uclibc) -python_abis_2.6 -python_abis_2.7 -python_abis_3.2 -python_abis_3.3 -python_abis_3.4 (-python_abis_3.5)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( python_abis_2.6 python_abis_2.7 python_abis_3.2 python_abis_3.3 python_abis_3.4 python_abis_3.5 )

Says exactly what the problem is and how to fix it straight enough. You need to add one of the use flags it says in your package.use file like for example
Code:
sys-boot/boot-update python_abis_2.7
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1428

PostPosted: Sat Jan 10, 2015 12:32 am    Post subject: Reply with quote

AFAICR a lot of virtuals have been removed. What is the output of:
Code:
emerge -1av portage
?
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Sat Jan 10, 2015 12:39 am    Post subject: Reply with quote

Code:
eselect profile list
Available profile symlink targets:
  [1]   default/linux/x86/13.0
  [2]   default/linux/x86/13.0/selinux
  [3]   default/linux/x86/13.0/desktop
  [4]   default/linux/x86/13.0/desktop/gnome
  [5]   default/linux/x86/13.0/desktop/gnome/systemd
  [6]   default/linux/x86/13.0/desktop/kde
  [7]   default/linux/x86/13.0/desktop/kde/systemd
  [8]   default/linux/x86/13.0/developer
  [9]   hardened/linux/x86
  [10]  hardened/linux/x86/selinux
  [11]  hardened/linux/musl/x86
  [12]  default/linux/uclibc/x86
  [13]  hardened/linux/uclibc/x86 *


Code:
 emerge -1av portage
--- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "portage" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/portage-2.3.7::gentoo (masked by: EAPI 5-progress)
- sys-apps/portage-2.3.6-r9::gentoo (masked by: EAPI 5-progress)

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1428

PostPosted: Sat Jan 10, 2015 12:53 am    Post subject: Reply with quote

This is gonna take some work but can be done:

Code:
emerge -av perl
(I need to see if your current version is >=5.10) and
Code:
eselect python list

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Sat Jan 10, 2015 1:01 am    Post subject: Reply with quote

Code:
emerge -av perl
--- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "perl" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/perl-5.20.1-r4::gentoo (masked by: EAPI 5)
- dev-lang/perl-5.18.2-r2::gentoo (masked by: EAPI 5)

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Code:
 eselect python list
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.2
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1428

PostPosted: Sat Jan 10, 2015 1:12 am    Post subject: Reply with quote

You lucked out, because python is >=2.7 which implies perl >=5.10 There are no portage ebulds that support <python:2.7 in the tree anymore

Does
Code:
emerge --ask --oneshot --nodeps portage
succeed? You can also do or try
Code:
emerge -a1O portage
for short. That's an OOH not a zero
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper


Last edited by eyoung100 on Sat Jan 10, 2015 2:09 am; edited 3 times in total
Back to top
View user's profile Send private message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Sat Jan 10, 2015 1:14 am    Post subject: Reply with quote

Code:
emerge -ask --oneshot --nodeps portage
--- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0'
Searching...
[ Results for search key : portage ]
[ Applications found : 6 ]

*  app-portage/kportagetray [ Masked ]
      Latest version available: 0.2.4-r1
      Latest version installed: [ Not Installed ]
      Size of files: 0 kB
      Homepage:
      Description:
      License:

*  app-portage/portage-mod_jabber
      Latest version available: 0.0.5.1
      Latest version installed: [ Not Installed ]
      Size of files: 8 kB
      Homepage:      http://usrportage.de/
      Description:   A notification module for the portage elog-system to notify via the XMPP (Jabber) protocol
      License:       GPL-2

*  app-portage/portage-utils
      Latest version available: 0.53
      Latest version installed: 0.10
      Size of files: 394 kB
      Homepage:      http://www.gentoo.org/doc/en/portage-utils.xml
      Description:   small and fast portage helper tools written in C
      License:       GPL-2

*  dev-perl/PortageXS [ Masked ]
      Latest version available: 0.02.12
      Latest version installed: [ Not Installed ]
      Size of files: 0 kB
      Homepage:
      Description:
      License:

*  dev-python/yolk-portage [ Masked ]
      Latest version available: 0.1-r1
      Latest version installed: [ Not Installed ]
      Size of files: 0 kB
      Homepage:
      Description:
      License:

*  sys-apps/portage
      Latest version installed: 2.3.4-r2
      Homepage:      http://www.gentoo.org/proj/en/portage/index.xml
      Description:   Portage is the package management and distribution system for Gentoo
      License:       GPL-2
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1428

PostPosted: Sat Jan 10, 2015 1:18 am    Post subject: Reply with quote

Deleted
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper


Last edited by eyoung100 on Sat Jan 10, 2015 1:28 am; edited 2 times in total
Back to top
View user's profile Send private message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Sat Jan 10, 2015 1:22 am    Post subject: Reply with quote

Code:
 emerge --ask --oneshot --nodeps portage
--- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:


!!! All ebuilds that could satisfy "portage" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/portage-2.3.7::gentoo (masked by: EAPI 5-progress)
- sys-apps/portage-2.3.6-r9::gentoo (masked by: EAPI 5-progress)

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1428

PostPosted: Sat Jan 10, 2015 1:28 am    Post subject: Reply with quote

Since you have a Funtoo version of portage, if the command I fixed above fails or reinstalls the same version, we need to use explicit versioning:
Code:
emerge --ask --nodeps --oneshot =sys-apps/portage-2.2.14

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper


Last edited by eyoung100 on Sat Jan 10, 2015 1:42 am; edited 3 times in total
Back to top
View user's profile Send private message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Sat Jan 10, 2015 1:39 am    Post subject: Reply with quote

Code:
 emerge --ask --nodeps --oneshot =sys-apps/portage-2.2.14
--- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:


emerge: there are no ebuilds to satisfy "=sys-apps/portage-2.2.14".
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1428

PostPosted: Sat Jan 10, 2015 1:42 am    Post subject: Reply with quote

If this fails, we can Fix a broken portage. As root issue the following:

Code:
wget -P /usr/portage/distfiles http://distfiles.gentoo.org/distfiles/portage-2.2.14.tar.bz2
cd /root
mkdir portage-recover
cd portage-recover
tar xfj /usr/portage/distfiles/portage-2.2.14.tar.bz2
cd /root/portage-recover/portage-2.2.14
rm -rf /usr/lib/portage/*
cp -R pym bin /usr/lib/portage/
rm -f /usr/lib/portage/bin/sed (Non FreeBSD)
emerge -a1v portage


If you get a command not found error message when you try to run emerge you have to recreate the symlink:

Code:
ln -sf ../lib/portage/bin/emerge /usr/bin/emerge

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
dilfridge
Developer
Developer


Joined: 18 Sep 2010
Posts: 111
Location: Regensburg, Germany

PostPosted: Sat Jan 10, 2015 2:07 am    Post subject: Reply with quote

This is probably more something for the Funtoo site.
Back to top
View user's profile Send private message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Sat Jan 10, 2015 2:10 am    Post subject: Reply with quote

all went well until the end :)

Code:
emerge -a1v portage
--- EAPI '0' does not support 'use.stable.mask': '/usr/portage/profiles/base/use.stable.mask'
--- EAPI '0' does not support 'package.use.stable.mask': '/usr/portage/profiles/base/package.use.stable.mask'
--- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0'
FEATURES variable contains unknown value(s): parse-eapi-ebuild-head

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "portage" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/portage-2.3.7::gentoo (masked by: package.mask, mirror in RESTRICT)
/usr/portage/profiles/package.mask/funtoo-staging:
# FL-1761: new rebased Portage, needs a lot of testing

- sys-apps/portage-2.3.6-r9::gentoo (masked by: mirror in RESTRICT)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1428

PostPosted: Sat Jan 10, 2015 2:11 am    Post subject: Reply with quote

@Dilfridge That's why I linked it, but I provided the commands to match the current stable version.
@MusicWeb The rest is Funtoo related as they use git based trees. For starters though, I would use package.mask to mask versions > 2.2.14 and then attempt an
Code:
emerge -a1v portage
, and an
Code:
emerge -uDNav world


Masking portage above 2.2.14 will cause portage to reinstall a downgraded version as seen in the GitHub Tree. You should no longer receive EAPI warnings as portage 2.2.14 is the stable version from the Gentoo rsync based tree that supports EAPI 5. If you've marked portage as ~arch, I recommend removing that so you get the stable version from the Funtoo tree. Update world once then test or fix all your masks/testing etc. My hunch is you will have a HUGE LIST of blockers 8O
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Sat Jan 10, 2015 2:50 am    Post subject: Reply with quote

Will probably just leave it running the way it is.
I don't think I can do all that you're telling me.

May just build a new hard drive and reinstall everything...

Thanks to everyone for their help on this....
Back to top
View user's profile Send private message
musicweb
n00b
n00b


Joined: 30 Jan 2013
Posts: 36

PostPosted: Sun Jan 18, 2015 2:16 am    Post subject: Reply with quote

new development....
when rebooting yesterday, the boot process halted at this:

Code:
Kernel panic - not syncing: No init found. Try passing init= option to kernel.


Tried several times, no difference.

Can we boot from a minimal install CD and get to a root prompt or something to fix this?

Then the next question is.... what went wrong?

Any suggestions.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum