Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
after an update - primusrun error - only for 1 aplication
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1575
Location: /mnt/Gentoo/Europe

PostPosted: Tue Jan 06, 2015 3:36 pm    Post subject: after an update - primusrun error - only for 1 aplication Reply with quote

Hi,

I have made some Gentoo's updates Yesterday, and my Eve Online withch I use wit PlayOnLinux and primusrun doesn't work any more.
Code:
$ primusrun playonlinux


[1] PlayOnLinux starts
[2] I run EVE Online and I have a EVE Online starter window and after login I have a game window, but only black window. On the console I have an error:

for wine 1.7.32
Code:
primus: fatal: failed to acquire direct rendering context for display thread


for wine 1.7.33
Code:
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  25
  Current serial number in output stream:  24


for wine 1.7.33-WGL-ShareList
Code:
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  25
  Current serial number in output stream:  24


The game works with Intel driver and card, of corse very slowly. Any other games + steam games, works pretty well with primusrun - so whats happened to EVE with PlayOnLinux + primusrun?

I have reemerged Intel & Nvidia drivers, primusrun, bumblebee, bbswitch, Xorg-server, mesa.

I think this happend probably after new xorg-server, mesa, glproto or eselect-opengl on the 2nd-5th of January 2015: (have a look on portage errors)
Code:
>>> Messages generated by process 19185 on 2015-01-05 06:46:16 GMT for package app-emulation/emul-linux-x86-opengl-20140508-r1:

ERROR: preinst
This package will overwrite one or more files that may belong to other
packages (see list below). You can use a command such as `portageq
owners / <filename>` to identify the installed package that owns a
file. If portageq reports that only one package owns a file then do
NOT file a bug report. A bug report is only useful if it identifies at
least two or more packages that are known to install the same file(s).
If a collision occurs and you can not explain where the file came from
then you should simply ignore the collision since there is not enough
information to determine if a real problem exists. Please do NOT file
a bug report at http://bugs.gentoo.org unless you report exactly which
two packages install the same file(s). See
http://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how to
solve the problem. And once again, please do NOT file a bug report
unless you have completely understood the above message.

Detected file collision(s):

   /usr/lib32/libGL.so
   /usr/lib32/libGL.so.1

Searching all installed packages for file collisions...

Press Ctrl-C to Stop

None of the installed packages claim the file(s).

Package 'app-emulation/emul-linux-x86-opengl-20140508-r1' merged
despite file collisions. If necessary, refer to your elog messages for
the whole content of the above message.


Code:
>>> Messages generated by process 5031 on 2015-01-02 01:19:16 GMT for package x11-base/xorg-server-1.16.2.901-r1:

ERROR: preinst
This package will overwrite one or more files that may belong to other
packages (see list below). You can use a command such as `portageq
owners / <filename>` to identify the installed package that owns a
file. If portageq reports that only one package owns a file then do
NOT file a bug report. A bug report is only useful if it identifies at
least two or more packages that are known to install the same file(s).
If a collision occurs and you can not explain where the file came from
then you should simply ignore the collision since there is not enough
information to determine if a real problem exists. Please do NOT file
a bug report at http://bugs.gentoo.org unless you report exactly which
two packages install the same file(s). See
http://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how to
solve the problem. And once again, please do NOT file a bug report
unless you have completely understood the above message.

Detected file collision(s):

   /usr/lib64/xorg/modules/extensions/libglx.so

Searching all installed packages for file collisions...

Press Ctrl-C to Stop

None of the installed packages claim the file(s).

Package 'x11-base/xorg-server-1.16.2.901-r1' merged despite file
collisions. If necessary, refer to your elog messages for the whole
content of the above message.


Code:
>>> Messages generated by process 5031 on 2015-01-02 00:55:48 GMT for package x11-proto/glproto-1.4.17-r1:

ERROR: preinst
This package will overwrite one or more files that may belong to other
packages (see list below). You can use a command such as `portageq
owners / <filename>` to identify the installed package that owns a
file. If portageq reports that only one package owns a file then do
NOT file a bug report. A bug report is only useful if it identifies at
least two or more packages that are known to install the same file(s).
If a collision occurs and you can not explain where the file came from
then you should simply ignore the collision since there is not enough
information to determine if a real problem exists. Please do NOT file
a bug report at http://bugs.gentoo.org unless you report exactly which
two packages install the same file(s). See
http://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how to
solve the problem. And once again, please do NOT file a bug report
unless you have completely understood the above message.

Detected file collision(s):

   /usr/include/GL/glxmd.h
   /usr/include/GL/glxtokens.h
   /usr/include/GL/glxproto.h

Searching all installed packages for file collisions...

Press Ctrl-C to Stop

None of the installed packages claim the file(s).

Package 'x11-proto/glproto-1.4.17-r1' merged despite file collisions.
If necessary, refer to your elog messages for the whole content of the
above message.


Code:

>>> Messages generated by process 5031 on 2015-01-02 01:13:04 GMT for package media-libs/mesa-10.3.5-r1:

ERROR: preinst
This package will overwrite one or more files that may belong to other
packages (see list below). You can use a command such as `portageq
owners / <filename>` to identify the installed package that owns a
file. If portageq reports that only one package owns a file then do
NOT file a bug report. A bug report is only useful if it identifies at
least two or more packages that are known to install the same file(s).
If a collision occurs and you can not explain where the file came from
then you should simply ignore the collision since there is not enough
information to determine if a real problem exists. Please do NOT file
a bug report at http://bugs.gentoo.org unless you report exactly which
two packages install the same file(s). See
http://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how to
solve the problem. And once again, please do NOT file a bug report
unless you have completely understood the above message.

Detected file collision(s):

   /usr/include/GLES2/gl2platform.h
   /usr/include/GLES2/gl2ext.h
   /usr/include/GLES2/gl2.h
   /usr/include/GLES3/gl3.h
   /usr/include/GLES3/gl3platform.h
   /usr/include/GLES3/gl3ext.h
   /usr/include/GLES3/gl31.h
   /usr/include/EGL/eglextchromium.h
   /usr/include/EGL/eglmesaext.h
   /usr/include/EGL/eglplatform.h
   /usr/include/EGL/eglext.h
   /usr/include/EGL/egl.h
   /usr/include/GL/glx.h
   /usr/include/GL/gl.h
   /usr/include/GL/glext.h
   /usr/include/GL/glxext.h
   /usr/include/KHR/khrplatform.h
   /usr/lib64/libGL.so
   /usr/lib64/libEGL.so.1
   /usr/lib64/libEGL.so
   /usr/lib64/libGLESv2.so.2
   /usr/lib64/libGL.so.1
   /usr/lib64/libGLESv2.so

Searching all installed packages for file collisions...

Press Ctrl-C to Stop

None of the installed packages claim the file(s).

Package 'media-libs/mesa-10.3.5-r1' merged despite file collisions. If
necessary, refer to your elog messages for the whole content of the
above message.
LOG: postinst
USE="bindist" was not set. Potentially patent encumbered code was
enabled. Please see patents.txt for an explanation.
Back to top
View user's profile Send private message
Bloss
n00b
n00b


Joined: 05 Dec 2014
Posts: 20
Location: MI, USA

PostPosted: Wed Jan 07, 2015 4:05 am    Post subject: Reply with quote

Can you post the output of eselect opengl list?
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1575
Location: /mnt/Gentoo/Europe

PostPosted: Wed Jan 07, 2015 10:15 am    Post subject: Reply with quote

Bloss wrote:
Can you post the output of eselect opengl list?


Code:
# eselect opengl list
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *


I think it was something with files bellow (important changes in January) and it happend after this:
http://packages.gentoo.org/package/app-emulation/emul-linux-x86-opengl
http://packages.gentoo.org/package/app-admin/eselect-opengl
http://packages.gentoo.org/package/x11-proto/glproto
http://packages.gentoo.org/package/media-libs/mesa
and maybe this bug:
https://bugs.gentoo.org/show_bug.cgi?id=531842

Quote:

/usr/lib32/libGL.so
/usr/lib32/libGL.so.1

/usr/lib64/xorg/modules/extensions/libglx.so

/usr/include/GL/glxmd.h
/usr/include/GL/glxtokens.h
/usr/include/GL/glxproto.h

/usr/include/GLES2/gl2platform.h
/usr/include/GLES2/gl2ext.h
/usr/include/GLES2/gl2.h
/usr/include/GLES3/gl3.h
/usr/include/GLES3/gl3platform.h
/usr/include/GLES3/gl3ext.h
/usr/include/GLES3/gl31.h
/usr/include/EGL/eglextchromium.h
/usr/include/EGL/eglmesaext.h
/usr/include/EGL/eglplatform.h
/usr/include/EGL/eglext.h
/usr/include/EGL/egl.h
/usr/include/GL/glx.h
/usr/include/GL/gl.h
/usr/include/GL/glext.h
/usr/include/GL/glxext.h
/usr/include/KHR/khrplatform.h
/usr/lib64/libGL.so
/usr/lib64/libEGL.so.1
/usr/lib64/libEGL.so
/usr/lib64/libGLESv2.so.2
/usr/lib64/libGL.so.1
/usr/lib64/libGLESv2.so


UPDATE: 2:20pm
Unfortunatley, I was trying to downgrade some system files, but with no results...

Quote:
#>x11-drivers/nvidia-drivers-343.36
#>app-emulation/emul-linux-x86-opengl-20140508
#>app-admin/eselect-opengl-1.2.7
#>x11-proto/glproto-1.4.17
#>media-libs/mesa-10.3.5
#>x11-base/xorg-server-1.16.2
#>x11-drivers/xf86-video-intel-2.99.910
Back to top
View user's profile Send private message
novazur
Guru
Guru


Joined: 19 Mar 2005
Posts: 461
Location: Martinique

PostPosted: Wed Jan 07, 2015 3:11 pm    Post subject: Reply with quote

Xywa wrote:
Bloss wrote:
Can you post the output of eselect opengl list?


Code:
# eselect opengl list
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *


Code:
eselect opengl set nvidia
?
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1575
Location: /mnt/Gentoo/Europe

PostPosted: Wed Jan 07, 2015 3:42 pm    Post subject: Reply with quote

novazur wrote:
Code:
eselect opengl set nvidia
?


It wont be working (the X wouldn't start) as I use bumblebee through Intel card.

But, somene had an idea to run primusrun with LIBGL_DEBUG=verbose nad I can see the problem, but I doesn't know to wich program those files belong to fix it:

Code:
LIBGL_DEBUG=verbose primusrun playonlinux


Code:
libGL: OpenDriver: trying /usr/lib32/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib32/dri/i965_dri.so
libGL: Can't open configuration file /home/ryszard/.drirc: No such file or directory.                                                                 
libGL: OpenDriver: trying /usr/lib32/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib32/dri/i965_dri.so
libGL: Can't open configuration file /home/ryszard/.drirc: No such file or directory.
libGL: OpenDriver: trying /usr/lib32/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib32/dri/i965_dri.so
libGL: Can't open configuration file /home/ryszard/.drirc: No such file or directory.
libGL: Can't open configuration file /home/ryszard/.drirc: No such file or directory.
libGL: OpenDriver: trying /usr/lib32/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib32/dri/i965_dri.so
libGL: Can't open configuration file /home/ryszard/.drirc: No such file or directory.
primus: fatal: failed to acquire direct rendering context for display thread



Maybe mesa?
Code:
# eselect mesa list
64bit i915 (Intel 915, 945)
  [1]   classic
  [2]   gallium *
64bit i965 (Intel GMA 965, G/Q3x, G/Q4x, HD)
  [1]   classic *
64bit r300 (Radeon R300-R500)
64bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
64bit sw (Software renderer)
  [1]   classic
  [2]   gallium *
32bit i915 (Intel 915, 945)
  [1]   classic
  [2]   gallium *
32bit i965 (Intel GMA 965, G/Q3x, G/Q4x, HD)
  [1]   classic *
32bit r300 (Radeon R300-R500)
  [1]   gallium *
32bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
  [1]   gallium *
32bit sw (Software renderer)
  [1]   classic
  [2]   gallium *


or maybe I should add a USE flag?
Code:
# equery u libva-intel-driver
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for x11-libs/libva-intel-driver-1.5.0:
 U I
 + + X          : Add support for X11
 - - abi_x86_32 : 32-bit (x86) libraries
 + + drm        : Enables VA/DRM API support.
 - - wayland    : Enable dev-libs/wayland backend
Back to top
View user's profile Send private message
Bloss
n00b
n00b


Joined: 05 Dec 2014
Posts: 20
Location: MI, USA

PostPosted: Thu Jan 08, 2015 12:03 am    Post subject: Reply with quote

I would double check with the http://wiki.gentoo.org/wiki/NVIDIA_Driver_with_Optimus_Laptops although it doesn't have bumble bee apart of it.

Wish I could be more helpful but you're running a weird configuration and I'm not to well rehearsed with wine.
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1575
Location: /mnt/Gentoo/Europe

PostPosted: Thu Jan 08, 2015 6:03 am    Post subject: Reply with quote

Bloss wrote:
I would double check with the http://wiki.gentoo.org/wiki/NVIDIA_Driver_with_Optimus_Laptops although it doesn't have bumble bee apart of it.

Wish I could be more helpful but you're running a weird configuration and I'm not to well rehearsed with wine.


I would love to, but I cannot manage this driver to work without bumblebee, here is my topic:
https://forums.gentoo.org/viewtopic-t-1007418-highlight-.html
Back to top
View user's profile Send private message
Bloss
n00b
n00b


Joined: 05 Dec 2014
Posts: 20
Location: MI, USA

PostPosted: Fri Jan 09, 2015 3:03 am    Post subject: Reply with quote

did you make sure your kernel is setup like this?

Code:

KERNEL
DeviceDrivers  --->
    Graphics Support  --->
        <*> Intel 8xx/9xx/Gex/G4x/HD Graphics
        [*]   Enable modesetting on intel by default
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1575
Location: /mnt/Gentoo/Europe

PostPosted: Fri Jan 09, 2015 9:04 am    Post subject: Reply with quote

Bloss wrote:
did you make sure your kernel is setup like this?

Code:

KERNEL
DeviceDrivers  --->
    Graphics Support  --->
        <*> Intel 8xx/9xx/Gex/G4x/HD Graphics
        [*]   Enable modesetting on intel by default


Yes. I have this:
Code:
 
<*> Intel 8xx/9xx/G3x/G4x/HD Graphics
[*]   Enable modesetting on intel by default
[*]   Enable legacy fbdev support for the modesetting intel driver
[ ]   Enable preliminary support for prerelease Intel hardware by default
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum