Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
File-roller can't open ISO anymore
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
alex6
Apprentice
Apprentice


Joined: 18 Jul 2011
Posts: 157

PostPosted: Tue Jan 06, 2015 1:36 pm    Post subject: File-roller can't open ISO anymore Reply with quote

I'm using file-roller to uncompress archive, without having gnome-installer. I'm using openbox.

Recently I figured file-roller wasn't able to display content of ISO files or extract them.

Any idea if something could be missing ? (dependency/useflag)

I didn't report it yet to gentoo bugzilla as I'm not 100 % sure it's a bug...
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7234
Location: almost Mile High in the USA

PostPosted: Tue Jan 06, 2015 3:07 pm    Post subject: Reply with quote

What version are you using?

file-roller-3.12.2 seems to extract isos for me...
http://fileroller.sourceforge.net/features.html
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
NathanZachary
Moderator
Moderator


Joined: 30 Jan 2007
Posts: 2469
Location: /home/zach

PostPosted: Tue Jan 06, 2015 8:59 pm    Post subject: Reply with quote

I can't imagine it being a problem with file-roller, as the only USE flags are 'nautilus' and 'packagekit.' I am also using it with Openbox and don't have any problem opening ISOs. Do you have the loopback device enabled in your kernel?

Code:

grep LOOP /usr/src/linux/.config
CONFIG_BLK_DEV_LOOP=y
CONFIG_BLK_DEV_LOOP_MIN_COUNT=8
# CONFIG_BLK_DEV_CRYPTOLOOP is not set
# CONFIG_SND_ALOOP is not set

_________________
“Truth, like infinity, is to be forever approached but never reached.” --Jean Ayres (1972)
---avatar cropped from =AimanStudio---


Last edited by NathanZachary on Wed Jan 07, 2015 5:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
alex6
Apprentice
Apprentice


Joined: 18 Jul 2011
Posts: 157

PostPosted: Wed Jan 07, 2015 4:40 pm    Post subject: Reply with quote

yes :

Code:

CONFIG_BLK_DEV_LOOP=y
CONFIG_BLK_DEV_LOOP_MIN_COUNT=8
# CONFIG_BLK_DEV_CRYPTOLOOP is not set


Using file-roller-3.12.2

I don't know if it has any link but it also have a problem with icons and I can't navigate on the shortcut bar on the left when using "File > Open"
The icon theme on the left side bar seems to be "high-contrast" theme, while I'm using another one, which is displayed correctly on the right part of the windows (where I can navigate)

It gives me the following error :

Code:

(file-roller:24063): GLib-GIO-CRITICAL **: g_loadable_icon_load: assertion 'G_IS_LOADABLE_ICON (icon)' failed


Running file-roller in a terminal doesn't give any other error messages...

I can successfully open all other file formats....Only ISO doesn't work.Any idea if there is any dependency for opening ISO with file-roller I would miss ?

Could that be linked with the Webkit-GTK Bug With nvidia graphic cards ? (had to change my opengl interface to be able to compile it)
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7234
Location: almost Mile High in the USA

PostPosted: Wed Jan 07, 2015 4:45 pm    Post subject: Reply with quote

What version of libarchive are you using?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
alex6
Apprentice
Apprentice


Joined: 18 Jul 2011
Posts: 157

PostPosted: Wed Jan 07, 2015 7:37 pm    Post subject: Reply with quote

eccerr0r wrote:
What version of libarchive are you using?


libarchive-3.1.2-r1 with the following USE flags : acl bzip2 e2fsprogs iconv lzma zlib -expat -lzo -nettle -static-libs -xattr
Back to top
View user's profile Send private message
alex6
Apprentice
Apprentice


Joined: 18 Jul 2011
Posts: 157

PostPosted: Wed Jan 21, 2015 6:35 pm    Post subject: Reply with quote

I switched to the equivalent in MATE (engranpa) which doesn't have any problem with ISO files
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum