Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
firefox suddenly refused to start as non-root user
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3647
Location: Hamburg

PostPosted: Tue Jan 06, 2015 9:00 am    Post subject: firefox suddenly refused to start as non-root user Reply with quote

[same happend for thunderbird too]

The issue suddenly appeared and went away - I'm convinced it is worth to be evaluated. I rebooted a hardened stable Gentoo (installed in December 2014) after an uptime of 7 days. Updates were made daily, user environment is KDE 4.11.3

After the reboot neither Firefox nor Thunderbird could be started, the error message was "cannot open profile directory". As root however
Code:
$>xauth merge /home/tfoerste/.Xauthority;  sudo -u <common user> firefox
worked however. There were no other issue with creating/deleting files. Moving away of ~/.mozilla and ~/.thunderbird even doesn't help nor any "-safe-mode", "-profilemanager" as starting parameter. I started to revert all package upgrades since last boot (29th of December), beginnning with libical (kdepimlibs was re-emerged too due to dependiencies) - no luck. Stopped that attempt in favor of booting a stable gentoo sources, no success.

Rebooted back to the hardened kernel (3.1.7.7-r1) and added the user to the group "video" (via
Code:
usermod -a -G video tfoerste
- issue went away !
Removing the group video from the user via manual editing /etc/group - firefox and thunderbird started now fine too.

So - what was the culprit ??


Last edited by toralf on Tue Jan 06, 2015 10:27 am; edited 4 times in total
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 418

PostPosted: Tue Jan 06, 2015 9:12 am    Post subject: Reply with quote

I suspect 3D acceleration. Firefox settings - Advanced (last tab) - General - Use hardware acceleration. If turned off, firefox doesn't use 3D graphics for the UI. I don't know if this affects web content too. Maybe you would have to turn off webgl in about:config.

But having the user in the "video" group is the right way to do it. I have no clue how/why it works even after you removed the user from the group.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3647
Location: Hamburg

PostPosted: Tue Jan 06, 2015 3:49 pm    Post subject: Reply with quote

Hhm - 3D- accelaration isn't an option in Thunderbird, which refused to work too with the same error.
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 418

PostPosted: Tue Jan 06, 2015 3:58 pm    Post subject: Reply with quote

In thunderbird it is hidden in the config editor (thunderbird's "about:config"): The preference is "layers.acceleration.disabled" in both firefox and thunderbird. Default is "false": Acceleration is enabled by default.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum