Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
manpage reader
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Off the Wall
View previous topic :: View next topic  
Author Message
aztech
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jul 2002
Posts: 130
Location: Stenungsund, Sweden

PostPosted: Mon Jul 29, 2002 7:23 pm    Post subject: manpage reader Reply with quote

How do I set most to be the default manreader ??!
:?:
Back to top
View user's profile Send private message
proxy
Apprentice
Apprentice


Joined: 20 Apr 2002
Posts: 253
Location: Chantilly, VA

PostPosted: Mon Jul 29, 2002 7:42 pm    Post subject: Reply with quote

why the heck did you post a quesiton in the tips and tricks forum?!

please read the guidelines. This is a "post your trick/tip here" section.

I promis you will get no responces besides verbal bashings until one of the moderators notices this post and either deletes it or moves it.

please read the guidelines. is it that hard?

proxy
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Mon Jul 29, 2002 8:27 pm    Post subject: Reply with quote

Moving to General Linux, as it's a man thing not a Gentoo thing.
_________________
I don't believe in witty sigs.
Back to top
View user's profile Send private message
Naan Yaar
Bodhisattva
Bodhisattva


Joined: 27 Jun 2002
Posts: 1549

PostPosted: Wed Jul 31, 2002 2:37 am    Post subject: Reply with quote

You need to set the PAGER variable to 'most'. Putting:
Code:

PAGER=/usr/bin/most

at the bottom of /etc/profile will do it for bash and
Code:

setenv PAGER /usr/bin/most

at the bottom of /etc/csh.cshrc should do it for tcsh.
Back to top
View user's profile Send private message
Naan Yaar
Bodhisattva
Bodhisattva


Joined: 27 Jun 2002
Posts: 1549

PostPosted: Wed Jul 31, 2002 11:35 am    Post subject: Reply with quote

If you don't like setting PAGER, you can also set MANPAGER to use 'most' only for man. man -P most ... will also work.

Edit:
You need to do:
Code:

export MANPAGER=/usr/bin/most

in /etc/profile since MANPAGER is not exported from profile.env already.
Naan Yaar wrote:
You need to set the PAGER variable to 'most'. Putting:
Code:

PAGER=/usr/bin/most

at the bottom of /etc/profile will do it for bash and
Code:

setenv PAGER /usr/bin/most

at the bottom of /etc/csh.cshrc should do it for tcsh.


Last edited by Naan Yaar on Wed Jul 31, 2002 3:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
masseya
Bodhisattva
Bodhisattva


Joined: 17 Apr 2002
Posts: 2602
Location: Raleigh, NC

PostPosted: Wed Jul 31, 2002 12:34 pm    Post subject: Reply with quote

I had to use
Code:
export MANPAGER="/usr/bin/most"
to get this to work for bash.
_________________
if i never try anything, i never learn anything..
if i never take a risk, i stay where i am..
Back to top
View user's profile Send private message
Naan Yaar
Bodhisattva
Bodhisattva


Joined: 27 Jun 2002
Posts: 1549

PostPosted: Wed Jul 31, 2002 3:48 pm    Post subject: Reply with quote

Yeah... PAGER is already exported in profile.env; so you would not have to say "export" again in /etc/profile. If you want to set MANPAGER, you would need to add "export" in front in your /etc/profile since it is not exported previously. Thanks. I will add it to my previous post.
Tristam29 wrote:
I had to use
Code:
export MANPAGER="/usr/bin/most"
to get this to work for bash.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Off the Wall All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum