Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Default browser setting I simply can't find [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1380

PostPosted: Sat Jan 03, 2015 10:20 pm    Post subject: Default browser setting I simply can't find [solved] Reply with quote

This ones been driving me nuts forever and has come up in several applications...first some time back in pidgin, and again now in thunderbird:

I have a default browser setting for "opera" hidden somewhere that I simply cannot find. First of all, I've been using nothing but fluxbox for many years now. Prior to that I was using KDE. There was a time way back when I tended to use opera as a browser, but now I use firefox. Also, just to note, I have this in ~/.local/share/applications/mimeapps.list:

Code:
cat ~/.local/share/applications/mimeapps.list
[Default Applications]
x-scheme-handler/http=firefox.desktop
x-scheme-handler/https=firefox.desktop
x-scheme-handler/ftp=firefox.desktop


That, as I recall, was what fixed pidgin for me when it was defaulting to opera.

This week I started using thunderbird for email (via imap) for the first time, and once again, it was using opera by default. I went through literally hours of hell getting links to default to firefox. It took quite some time for me to discover that all the references to network.protocol-handler.app.http configurations and the like (that still permeate even the mozilla site), no longer do anything at all...ffs. What finally worked for me was to set these:

Code:
user_pref("network.protocol-handler.warn-external.ftp", true);
user_pref("network.protocol-handler.warn-external.http", true);
user_pref("network.protocol-handler.warn-external.https", true);


...in pref.js (which can be done in Preferences -> Advanced -> Config Editor). This finally let me choose the application I wanted and optionally, to "remember this choice". This actually creates the file mimeTypes.rdf in the thunderbird profile directory. Once that was there, I was finally able to see these choices in Preferences -> Attachments...something that I'd read enough times to bring tears to my eyes, yet did not exist before. Pure f****** madness. Further proof to me that that Mozilla project has just lost it's way...but I digress...

That aside, even though I got that to work, the "default" entry for http, https etc (for example in Preferences -> Attachments) is still opera, and I have no clue where it's coming from. My entries for firefox are essentially overrides to this mystery default.

If anyone could help me hunt that down and beat it into tiny pieces with a stick I'd appreciate it ;).

Tom


Last edited by tld on Sun Jan 04, 2015 3:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
amair
n00b
n00b


Joined: 12 Aug 2003
Posts: 54

PostPosted: Sun Jan 04, 2015 8:01 am    Post subject: Re: Default browser setting I simply can't find Reply with quote

Hi Tom,

that drove me nuts for a long time, too.

tld wrote:
That aside, even though I got that to work, the "default" entry for http, https etc (for example in Preferences -> Attachments) is still opera, and I have no clue where it's coming from. My entries for firefox are essentially overrides to this mystery default.

If anyone could help me hunt that down and beat it into tiny pieces with a stick I'd appreciate it ;).

Tom


Try
Code:
xdg-mime query default x-scheme-handler/https
xdg-mime query default x-scheme-handler/http

I guess both will result in something like opera.desktop.

You can change it to FireFox using
Code:
xdg-mime  default firefox.desktop x-scheme-handler/http
xdg-mime  default firefox.desktop x-scheme-handler/https


Best regards,
Andreas
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1380

PostPosted: Sun Jan 04, 2015 10:37 am    Post subject: Reply with quote

Thanks. However I've already been there unfortunately:
Code:
xdg-mime query default x-scheme-handler/http
firefox.desktop
xdg-mime query default x-scheme-handler/https
firefox.desktop

Like I said, this one it a total mystery. I would have thought it might be related to old kde stuff but my old ~/.kde* directories are totally gone.

Any other ideas?
Back to top
View user's profile Send private message
amair
n00b
n00b


Joined: 12 Aug 2003
Posts: 54

PostPosted: Sun Jan 04, 2015 10:52 am    Post subject: Reply with quote

Hi Tom,

yes, it's really a mystery. On one workstation it worked like I've written above.

On another workstation it didn't. I've played with "gconftool-2", but in the end I gave up and selected "/usr/bin/xdg-open" in Thunderbird for both scheme handlers.

No more ideas, but I'd really like to understand how it works, too.

Best regards,
Andreas
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42588
Location: 56N 3W

PostPosted: Sun Jan 04, 2015 10:57 am    Post subject: Reply with quote

tld,

You browsers know where the setting is.
They all have an option to "Check for the default browser on startup" and they usually offer to set it too.
So its in your browser(s) somewhere

I had to read the instructions to fix this on my wifes system that defaulted to links instead of firefox.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 730
Location: S.O. France

PostPosted: Sun Jan 04, 2015 11:53 am    Post subject: Reply with quote

Like Neddy said, just check if firefox is your default browser
I had the same problem and simply solved it by checking
Firefox/Preferences/Advanced/General and click on "make firefox the default browser"
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1380

PostPosted: Sun Jan 04, 2015 3:06 pm    Post subject: Reply with quote

Thanks you!! Opera for Linux has no such setting apparently (as it does in windows), and the help only indicates how to make that setting for Gnome or KDE:

http://help.opera.com/Linux/12.10/en/default.html

Firefox on the other hand does have the setting as sebB described which did in fact change the default as seen by thunderbird.

Jeeez though...this black box "who knows where it is" crap really has freedesktop.org written all over it. I'd love to know where that was. I literally grep'ed every file under every hidden directory in my home without finding that opera setting.

Thanks again!
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5593

PostPosted: Sun Jan 04, 2015 9:08 pm    Post subject: Reply with quote

Setting the $BROWSER environment variable might also work.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6971
Location: Saint Amant, Acadiana

PostPosted: Sun Jan 04, 2015 9:22 pm    Post subject: Reply with quote

I have similar mysterious problem myself. When I click on a mailto: link in Chromium Firefox is launched and then Claws. I haven't tried hard, but Chromium is my default browser and Claws is my default mail client. Why on earth FF pops up?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
robvr
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2004
Posts: 90
Location: Best, The Netherlands

PostPosted: Mon Jan 05, 2015 3:11 pm    Post subject: Re: Default browser setting I simply can't find [solved] Reply with quote

tld wrote:
I went through literally hours of hell getting links to default to firefox. It took quite some time for me to discover that all the references to network.protocol-handler.app.http configurations and the like (that still permeate even the mozilla site), no longer do anything at all...ffs. What finally worked for me was to set these:

Thanks for posting this; it saved me from a similar journey through hell tracking this down.

Afraid I can't help you with the rest of the problem though :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum